Sehr geehrte NTCS-Anwenderin! Sehr geehrter NTCS-Anwender!
Mit dem NTCS Update 2018.21.45 erhalten Sie Neuprogramme und Änderungen. Hier finden Sie einen Auszug aus den interessantesten Neuerungen im Bereich der Tools.
Inhalt
Jeder Benutzer kann für sich jene Fenster definieren, die beim Start der NTCS automatisch geöffnet werden sollen. Wenn Sie unternehmensübergreifend bestimmte Fenster für alle Benutzer starten möchten, müssen Sie die Autostartfunktionen mit dem BMD-Benutzer definieren. Zusätzlich müssen Sie den neuen Parameter Autostartfunktionen von Benutzer BMD starten aktivieren, unter Tools → Überblick über alle Tools-Parameter → Gesamtsystem → Allgemeine Einstellungen → 6 Gesamtsystem.
Wenn Sie diesen Parameter auf "JA" stellen, werden zusätzlich zu den benutzerdefinierten Autostartfunktionen auch die des Benutzers BMD gestartet. Die Autostartfunktionen des BMD-Benutzers werden immer zuletzt gestartet, damit diese als erste den Fokus haben.
Es gibt im Menü eine neue Funktion "BMD-Dienste neu starten" unter Tools → Administration → Updates. Mit Hilfe dieser Funktion ist es möglich, alle BMD-Dienste am Server neu zu starten.
Die Funktion ist nur für Administratoren gedacht. Wir empfehlen diese Funktion auch nicht während des laufenden Betriebes auszuführen, es sei denn es ist unbedingt nötig, weil in einem bestimmten Bereich die Funktionalität wiederhergestellt werden muss (z. B. Synchronisation funktioniert nicht mehr, weil der Sync-Service neu gestartet werden muss). Dann sollten alle Mitarbeiter, die in NTCS arbeiten, Ihre Arbeit kurz unterbrechen, weil dann natürlich auch beispielsweise der Archivservice neu gestartet wird.
Achtung! | Falls Sie BMDGhost im Einsatz haben, ist es auch wichtig, sich davon zu überzeugen, dass dieser Neustart der Dienste zu einem Zeitpunkt durchgeführt wird, zu dem BMDGhost keine geplanten Aufgaben abarbeitet. Durch den Neustart des BMDNTCSSoapSvc würde er dabei unter Umständen so unterbrochen, dass er den Task nicht korrekt zu Ende führen kann.
|
In der Mailsystem Diagnose haben Sie jetzt die Möglichkeit, die SMTP-Zugangsdaten für einen bestimmten BMD-Benutzer zu testen. Dafür gibt es jetzt das Einstiegsfeld BMD-Benutzer, in dem Sie jenen Benutzer auswählen können, für den Sie die SMTP-Zugangsdaten testen möchten.
Wenn Sie für einen anderen Benutzer diesen Test durchführen, können die Optionen Mail mit Account testen und Mail-Client im Vordergrund öffnen nicht durchgeführt werden.
Es ist über eine neue Funktion jetzt möglich, alle SMTP-Mail-Zugangsdaten über alle Mitarbeiter eines Unternehmens hinweg zu prüfen. Diese Funktion finden Sie unter "Tools → Zugangsdaten → Mailsystem Diagnose" im gelben BMD-Menü unter "Extras → SMTP-Benutzer testen".
Nach Klicken auf diese Funktion erfolgt noch eine Abfrage, bevor die Überprüfung tatsächlich gestartet wird. Hier wird die Anzahl der zu überprüfenden Mitarbeiter angeführt.
Für E-Mails, die im NTCS automatisch im Hintergrund über SMTP versendet werden, gibt es folgende beiden Parameter. Diese finden Sie unter Tools → Überblick über alle Tools-Parameter → 1 Gesamtsystem → Allgemeine Einstellungen → 8 Standard-E-Mail.
Antwort Mailadresse
Wenn Sie in diesem Parameter eine Antwortadresse hinterlegen, wird diese automatisch beim Beantworten eines SMTP-Mails als Empfänger E-Mailadresse vorgeschlagen.
Absendername
Wenn Sie in diesem Feld einen Absendernamen hinterlegen, dann wird die Absender-Adresse der E-Mail automatisch mit dem Absendernamen und Absender E-Mail-Adresse kombiniert. Zum Beispiel, wenn Sie als Absendername BMD-Systemhaus und als Absenderadresse bmd@bmd.at hinterlegen, wird als Absender im E-Mail Folgendes angezeigt: "BMD-Systemhaus <bmd@bmd.at>"
Sie können jetzt über Parameter aktivieren, ob Sie beim Beenden der NTCS die Möglichkeit haben möchten, eine Sicherung der Datenbank durchzuführen. Dafür gibt es die beiden Parameter Datenbank sichern beim Beenden und Intervall der Datenbanksicherungsabfrage (Tage) unter Tools → Überblick über alle Tools-Parameter → 2 BMD-System → Allgemeine Einstellungen → 9 Datenbank. Wenn Sie den Parameter Datenbank sichern beim Beenden auf "JA" setzen, wird beim Beenden der NTCS zusätzlich eine Schaltfläche Sichern und beenden angeboten.
Im Parameter Intervall der Datenbanksicherungsabfrage (Tage) können Sie die Anzahl der Tage eintragen, die seit der letzten Datenbanksicherung vergangen sein müssen, damit die Schaltfläche beim Beenden der NTCS angeboten wird. Sie können dann entscheiden, ob Sie die NTCS nur beenden möchten oder vorher noch eine Datenbanksicherung durchgeführt werden soll.
Voraussetzung, damit diese Abfragemöglichkeit angeboten wird, ist, dass eine Datenbanksicherung von Ihrer aktuellen Umgebung aus grundsätzlich möglich ist. Kann die Datenbanksicherung auch manuell direkt in NTCS nicht gestartet werden, wird diese Schaltfläche zum Sichern der Datenbank beim Beenden der NTCS auch nicht angeboten.
Das Zusammenspiel zwischen der NTCS-Stapelverarbeitung und der Windows-Aufgabenplanung wurde verbessert. Über die NTCS-Stapelverarbeitung kann jetzt gesteuert werden, dass das Ausführen eines Stapels beendet werden soll, wenn die Ausführung länger als eine bestimmte Zeit dauert. Dazu gibt es im Fenster "Geplante Ausführung" das Feld Ausführung beenden nach: In diesem Feld können Sie definieren, nach wie vielen Stunden bzw. Tagen die Stapelausführung beendet werden soll. Der in diesem Feld ausgewählte Wert wird in die Einstellung Aufgabe beenden, falls Ausführung länger als der Windows-Aufgabenplanung übernommen.
Wenn Sie in einem Fenster für ein oder mehrere Einstiegsfelder Einstiegswerte speichern, wird künftig ein grünes Häkchen bei diesem Symbol

angezeigt. So ist sofort beim Start des Fensters zu erkennen, dass Einstiegswerte geladen werden.
Nach dem Login im BMD Web werden standardmäßig zuerst die übergeordneten Pakete (CRM, FIBU, Zeit, ...) angezeigt und mit einem Klick auf das entsprechende Paket die Funktionen darunter. Um einen schnelleren Einstieg in die gewünschte Funktion zu ermöglichen, können Sie die Paketgruppierung jetzt über den Parameter Ansicht Menü deaktivieren und gleich alle lizenzierten bzw. berechtigten Funktionen am Startbildschirm anzeigen. Diesen Parameter finden Sie unter Tools → Überblick über alle Tools-Parameter → 8 BMD Web → Allgemeine Einstellungen → 4 Oberfläche. Wenn Sie die Ausprägung 2 - Nur Funktionen anzeigen wählen, dann werden gleich nach der Anmeldung die Funktionen aller Pakete angezeigt, wie in der Abbildung unterhalb ersichtlich.
Dies ist vor allem dann sinnvoll, wenn es sich um eine überschaubare Anzahl an Funktionen handelt, die Sie im Web benutzen. Wenn Sie aber die Funktionen je Pakete gruppiert haben möchten, dann müssen Sie die Ausprägung Nach Pakete gruppiert wählen.
Im Dialog zum Import einer Textdatei können Sie jetzt am Reiter "Erweitert" in der Feldgruppe Aktionen nach Import der Datei definieren, was mit der Importdatei nach erfolgreichem Import geschehen soll. Im Feld Datei können Sie definieren, ob die Datei nach dem Import umbenannt bzw. in ein anderes Verzeichnis verschoben werden soll.

Wenn Sie hier die Ausprägung Verschieben bzw. Umbenennen und Verschieben auswählen, dann werden die Felder "Sicherungsverzeichnis, in das die Datei verschoben werden soll" und "Sicherungsdateien älter als (n) Tage löschen" aktiv. Im Feld "Sicherungsverzeichnis, in das die Datei verschoben werden soll", können Sie das Verzeichnis angeben, in welches die Importdatei nach dem Import verschoben werden soll. Im Feld "Sicherungsverzeichnis, in das die Datei verschoben werden soll", können Sie die Anzahl der Tage definieren, die die Sicherungsdatei nach dem Verschieben in diesem Verzeichnis gespeichert werden soll, bevor diese beim nächsten Start des Imports gelöscht wird.
Über den Parameter AddIn Standardfunktion können Sie definieren, welche Funktion beim Klick direkt auf die Add-in-Schaltfläche standardmäßig gestartet werden soll.
Sie können zwischen mehreren Funktionen wählen zum Beispiel "Archivieren", "Archivieren und senden", "Aufgabe anlegen", etc. Diesen Parameter finden Sie unter "Tools → Überblick über alle Tools-Parameter → 9 BMD-ComAddIns → Allgemeine Einstellungen → 2 Funktionen".
Über den Parameter "rchivieren und Schließen können Sie jetzt entscheiden, ob Ihnen im Outlook AddIn beim Erfassen einer neuen E-Mail nur die Funktion Archivieren oder Archivieren und schließen angezeigt werden soll oder ob Sie beide Funktionen aktivieren möchten. Diesen Parameter finden Sie unter Tools → Überblick über alle Tools-Parameter → 9 BMD-ComAddIns → 2 Funktionen.
Über das BMD Outlook AddIn gibt es die Möglichkeit, einen neuen Termin anzulegen. Mit einem Klick auf diese Funktion wird die Neuanlagemaske des Termins immer mit dem aktuellen Tagesdatum als Vorschlag geöffnet. Zusätzlich werden der Betreff der E-Mail und der Text der E-Mail in die Neuanlagemaske übergeben.
Damit diese Funktion im Outlook AddIn verfügbar ist, müssen Sie den Parameter Termin anlegen aktivieren. Diesen Parameter finden Sie unter Tools → Überblick über alle Tools-Parameter → 9 BMD-ComAddIns → Allgemeine Einstellungen → 2 Funktionen.
Beim Archivieren von verschlüsselten E-Mails über das Outlook AddIn ins BMD DMS, können Sie entscheiden, ob die Verschlüsselung beim Archivieren entfernt werden soll oder nicht. Dafür gibt es den Parameter Verschlüsselte Mails, in dem Sie zwischen folgenden Ausprägungen wählen können:
| 0 - Mails nicht automatisch entschlüsseln | Haben Sie die Ausprägung gewählt, wird die E-Mail immer mit der Verschlüsselung archiviert. Diese E-Mails können im DMS dann nur jene Anwender sehen, die das entsprechende Zertifikat zum Entschlüsseln dieser E-Mail besitzen. |
| 1 - Mails immer automatisch entschlüsseln | Bei dieser Einstellung, wird beim Archivieren von E-Mails die Verschlüsselung automatisch entfernt. Diese E-Mails können dann von allen Benutzern im DMS gelesen werden. |
| 2 - Vor dem Archivieren fragen, ob das Mail entschlüsselt werden soll | Wenn Sie diese Ausprägung gewählt haben, werden Sie vor dem Archivieren gefragt, ob die Verschlüsselung entfernt werden soll oder nicht. Sie erhalten gleich nach dem Klick auf eine Archivierungsfunktion im Outlook AddIn folgende Abfragemeldung:
|
Diesen Parameter finden Sie unter Tools → Überblick über alle Tools-Parameter → 9 BMD-ComAddIns → Allgemeine Einstellungen → 4 Sonstige Einstellungen.
| Hinweis |
|
 | Das Entfernen der Verschlüsselung beim Archivieren von E-Mails funktioniert nur dann, wenn Sie das entsprechende Zertifikat zum Entschlüsseln der E-Mail besitzen. Ansonsten erhalten Sie folgende Hinweismeldung und die Archivierung kann nicht durchgeführt werden.
|
Mit dem Parameter Mail entschlüsseln (Kopie) können Sie eine eigene Funktion im Outlook AddIn aktivieren, die eine unverschlüsselte Kopie einer mit Zertifikat verschlüsselten E-Mail erzeugt. Die Kopie der E-Mail wird nur dann erzeugt, wenn Sie - wie im Hinweis oberhalb schon erwähnt - das entsprechende Zertifikat zum Entschlüsseln der E-Mail besitzen.
Diesen Parameter finden Sie unter Tools → Überblick über alle Tools-Parameter → 9 BMD-ComAddIns → Allgemeine Einstellungen → 2 Funktionen.