1. Allgemein
Die Schnellsuche stellt eine alternative Suchvariante dar, welche auf die Suche in den verschiedenen Suchlisten abgestimmt ist.
Sie validiert jedes eingegebene Suchzeichen sofort und stellt die Treffer in Form einer Vorschlagsliste dar, welche mit der Eingabe jedes weiteren Zeichens aktualisiert wird.
Die Schnellsuche steht in den am häufigsten benötigten Suchfenstern (

F4-Felder), sowie in den Einstiegsfeldern, zur Verfügung.
Auf der linken Seite werden die Suchergebnisse angezeigt. Auf der rechten Seite unterstützen Sie zusätzliche Informationen dabei, die richtige Auswahl zu treffen.
Die Schnellsuche bietet nicht alle Suchmodi, die über die normale Suche in der Filterleiste möglich sind. Vielmehr sucht sie nach einer fixen Vorgabe. Über einen Parameter kann eingestellt werden, mit welchem Standardsuchmodus die Schnellsuche arbeitet: Tools → Überblick über alle Tools-Paramter → 1.Gesamtsystem → 21.Filter → Standardsuchmodus der Schnellsuche.
| Stellen Sie den Standardsuchmodus ein, mit dem die Schnellsuche suchen soll.
1 - Beginnend mit 2 - Volltextsuche
|
Je nach eingestelltem Standardsuchmodus sind folgende Suchvarianten möglich:
| Beginnend mit | Im Modus beginnt mit wird im linken Teil der Schnellsuche-Liste der Suchwert dargestellt und Übereinstimmungen werden grün markiert:
- Eingabe einer Nummer. Beispiel: "2000"
→ Es wird nach der Nummer gesucht, beginnend mit "2000".

- Eingabe einer Nummer mit vorangestelltem "%"-Symbol. Beispiel: "%2000"
→ Es wird nach der Nummer in der Bezeichnung in Volltextsuche gesucht.

- Eingabe eines Namens/einer Bezeichnung. Beispiel: "All"
→ Es wird nach der Bezeichnung gesucht, beginnend mit All".

- Eingabe eines Namens/einer Bezeichnung mit vorangestelltem "%" -Symbol. Beispiel "%inger"
→ Es wird nach der Bezeichnung in der Volltextsuche gesucht.

Hinweis | Sie können auch eine Suche "beginnt mit" und "beinhaltet" kombinieren. Geben Sie zuerst jenen Teil ein, nach dem Sie im Modus "beginnt mit" suchen möchten. Ergänzen Sie den Teil für die "beinhaltet"-Suche mit "%".
|
|
| Volltextsuche | - Eingabe einer Nummer. Beispiel: "2000"
→ Es wird nach der Nummer gesucht, beginnend mit "2000".

- Eingabe eines Namens/einer Bezeichnung. Beispiel: "inger"
→ Es wird nach der Bezeichnung in der Volltextsuche gesucht.

Hinweis | Sie können auch im Standardsuchmodus "Volltextsuche" nach einer Nummer in der Bezeichnung suchen. Geben Sie dazu einen Teil der Bezeichnung ein und ergänzen Sie mit dem "%"-Symbol die Nummer. 
Eine ausschließliche Suche nach einer Nummer in der Bezeichnung ist in diesem Standardsuchmodus nicht möglich. Sie benötigen zumindest ein alphanumerisches Zeichen. |
|
Mittels der Cursor-Tasten Pfeil nach oben bzw. Pfeil nach unten kann in den vorgeschlagenen Suchergebnissen navigiert und mit Enter bzw. Eingabe übernommen werden. Ebenso können Sie den gewünschten Treffer mit der Maus wählen. Der oberste Treffer in der Liste kann immer mit der Taste Pfeil nacht Rechts übernommen werden, ohne dass man diese Zeile zuvor extra auswählen muss.
Die Schnellsuche bietet somit die häufigsten Suchmodi an und verzichtet - für eine schnelle Reaktionszeit - auf zusätzliche Suchmöglichkeiten. Diese stehen wie gewohnt in der Liste zur Verfügung.
Jener Suchwert, bei dem eine Übereinstimmung festgestellt wird, wird im linken Teil der Ergebnisliste grün markiert. Auf der rechten Seite der Ergebnisliste werden zusätzliche Informationen angezeigt, die Sie dabei unterstützen, die richtige Auswahl zu treffen. Der Inhalt für die Anzeige beider Spalten ist fix vorgegeben und kann nicht verändert werden.
Sollten zum eingegebenen Suchwert mehr Treffer als die maximale Suchmenge lt.
Parameter erzielt werden, werden am Ende der Suchliste drei Punkte angezeigt.
Wenn man die Punkte mit ENTER bestätigt, oder mit der Maus anklickt, wird die

F4-Suche ausgelöst.
Hinweis
| In welchen Feldern gesucht wird, kann nicht beeinflusst werden. Oberste Maßgabe ist, dass es eine Schnellsuche sein soll, weshalb versucht wurde, den Standardsuchmodus für jede Suchliste individuell zu optimieren, indem nach den naheliegendsten Feldern gefiltert wird. Eine beliebige Erweiterung ist daher nicht möglich und sinnvoll, da die Programmierung fix auf die optimale Suchperformance zugeschnitten ist.
Mittels F4 kann jederzeit die gewohnte Suchliste geöffnet werden.
|
Die KI-Suche unterstützt Sie bei der Suche nach den für Sie relevantesten Daten und ist durch die grüne Hinterlegung bei der Schnellsuche und in Suchlisten erkennbar.
Mit der KI-Suche wird erreicht, dass Suchergebnisse nach einem Ranking priorisiert werden. Ausgewählte Ergebnisse werden somit bei erneuter Suche in der Liste nach oben gereiht. Nicht mehr relevante Daten verlieren an Bedeutung und scheiden mit der Zeit wieder aus. Dadurch wird erreicht, dass die gesuchten Daten nach Verwendung und Verhalten des jeweiligen Benutzers sortiert werden.
Wenn Sie die KI-Suche allgemein oder nur für bestimmte Bereiche deaktivieren möchten, so kann dies über die gewohnten Schnellsuche Parameter eingestellt werden. Diese finden Sie unter Tools → Überblick über alle Tools-Parameter → BMD-System → Schnellsuche / KI-Suche.
| Die KI-Suche in der NTCS ist eine erweiterte Funktion der Schnellsuche, die automatisch aktiviert ist und das Suchverhalten des Benutzers lernt, um künftig relevantere Ergebnisse vorzuschlagen.
Funktionsweise: - Die KI-Suche basiert auf Suchstatistiken, die laufend erfasst und ausgewertet werden. - Sie priorisiert Suchergebnisse nach einem Ranking, das sich aus der bisherigen Nutzung ergibt. - Wenn ein Benutzer beispielsweise mehrfach denselben Datensatz auswählt, wird dieser bei zukünftigen Suchvorgängen automatisch an die oberste Position gereiht. - Weniger relevante oder nicht mehr benötigte Daten (z. B. abgeschlossene Projekte) verlieren mit der Zeit an Bedeutung und werden weiter unten gereiht. - Vorschläge, die von der KI als besonders relevant erkannt werden, sind in der Suchliste grün hinterlegt.
Einstellungen: - In den Schnellsuche-Einstellungen kann festgelegt werden, ob die KI-Suche - inaktiv ist, - nur in der Schnellsuche aktiv ist oder - sowohl in der Schnellsuche als auch in den Suchfenstern aktiv ist.
|
Hinweis | Die KI-Suche ist standardmäßig aktiviert und setzt die in Kapitel 2 beschriebenen Parameter außer Kraft!
|
Beispiel | Es gibt mehrere Mitarbeiter namens "Hauser". Davon sind für einen Anwender allerdings nur wenige relevant.
Durch die Auswahl des gewünschten Mitarbeiters (z. B. Hauser Philip) wird dieser beim nächsten Suchaufruf automatisch nach oben gereiht. Alle anderen Mitarbeiter mit dem Namen "Hauser" werden nach den relevanten Mitarbeitern angereiht.
Die grüne Hintergrundfarbe weist darauf hin, dass es sich um einen Vorschlag handelt, der für den Benutzer mehr gewichtet ist als andere Einträge in der Suchliste.
|
Die Lernrate, wie schnell eine getroffene Auswahl nach vorne gereiht werden soll, kann per Parameter gesteuert werden. Standardmäßig ist die Ausprägung der Lernrate auf "Mittel" eingestellt. Mit der Einstellung "Sehr hoch" wird die Such-Auswahl immer sofort an die erste Position gereiht.
| Die Geschwindigkeit, mit der die KI auf Benutzeraktionen reagiert, kann über diesen Parameter gesteuert werden. - Standardmäßig ist die Lernrate auf „Mittel“ eingestellt. - Mit der Einstellung "Sehr hoch" wird die Auswahl sofort an die erste Position gereiht. - Wenn eine Suchliste eine vom Benutzer festgelegte Sortierung hat, wird die KI-Suche nicht angewendet. |
Hinweis | Wenn die Suchliste eine vom Benutzer voreingestellte Sortierung aufweist, dann wird die KI-Suche nicht angewendet.
|
Hinweis
| Schnellsuchparameter, welche für das Paket CRM relevant sind, finden sich auch unter CRM → Stammdaten → CRM Parameter → CRM → Schnellsuche. Diese sind mit den Tools-Parametern synchronisiert. |
Über den Parameter Schnellsuche systemweit verfügbar (Tools → Überblick über alle Tools-Parameter → Einstellungen für BMD-System → Schnellsuche) kann die Schnellsuche NTCS-weit deaktiviert werden.
Unter Tools → Überblick über alle Tools-Parameter → Einstellungen für BMD-System → Schnellsuche finden sich die Parameter für die einzelnen Suchfenster: Jedes kann für sich allgemein oder benutzerbezogen auf inaktiv gestellt werden.
Die Schnellsuche kann generell und pro Suchfenster aktiviert werden. Über das Fernglas können die Sucheinstellungen adaptiert werden:

Durch Klick auf das Fernglas
gelangen Sie in folgendes Fenster:
Hier können Sie die jeweiligen Einstellungen für die Schnellsuche adaptieren:
| Aktiv | Hier entscheiden Sie, ob die Schnellsuche für den gewählten Bereich aktiviert werden soll. |
| KI-Suche | Entscheiden Sie hier, ob die KI-Suche inaktiv ist, nur in der Schnellsuche oder in der Schnellsuche und in den Suchfenstern aktiv ist. |
Nach Eingabe von … Zeichen
| In diesem Feld bestimmen Sie, ab wie vielen Zeichen der erste Suchvorgang gestartet wird.
|
Verzögerung in ms
| Wie viele Millisekunden nach dem eingegebenen Zeichen soll sich die Suche aktualisieren? Hier können Sie den Suchmechanismus an die eigene Schreibgeschwindigkeit anpassen.
|
Anzahl Einträge in Liste
| Ihre Eingabe in diesem Feld regelt, wie viele Treffer maximal angezeigt werden.
|
Über die
Feldauswahl in den einzelnen Masken kann die Schnellsuche je Feld aktiviert/deaktiviert werden.
Klicken Sie dazu auf der rechten Seite auf das Feld, dessen Schnellsuche Sie deaktivieren möchten und anschließend auf den Reiter Vorschlag.
Treffen Sie anschließend die gewünschte Einstellung in der Combobox.
| Schnellsuche: aktiviert | Die Schnellsuche ist für dieses Feld aktiv. |
| Schnellsuche: deaktiviert, für alle Einstellungen dieser Gruppe | Dies betrifft alle Feldauswahlspeicherungen, unabhängig von Speichername, Benutzer usw. Hier spielt es keine Rolle, ob die Feldauswahl im Anschluss global oder benutzerbezogen gespeichert wird.
|
| Schnellsuche: deaktiviert, für diese Einstellung | Dies betrifft nur die Feldauswahlspeicherung, die im Anschluss durchgeführt wird (also beispielsweise nur die globale, nur die benutzerbezogene ...) |
Speichern Sie die Feldauswahl wie gewohnt und gewünscht.
Auch im Eigenschaftendialog für Felder kann die Schnellsuche aktiviert bzw. deaktiviert werden. Diese sind im Bearbeitungsmodus über die rechte Maustaste → Feldeigenschaften aufrufbar. Die verfügbaren Optionen sind im Vorkapitel erklärt.