Grundlegende Informationen zum Exportieren von Buchungen finden Sie in der Onlinehilfe Buchungen exportieren.
Dieses Dokument beschreibt den Export von Stammdaten und Buchungen für die Factoring-Bank.
Factoring bedeutet, dass ein Unternehmen seine Forderungen durch eine Bank vorfinanzieren lässt. Die Bank stellt dem Unternehmen das Geld sofort bereit und holt sich dieses von den Kunden zurück. Somit stehen die liquiden Mittel dem Unternehmen früher und sicherer zur Verfügung.
Diese Schnittstelle bietet den Export der Daten in einem fixen von der Factorbank vorgegebenen Satzaufbau an.
Die Factoring-Schnittstelle ist nicht im FIBU-Basis-Paket enthalten. Die Einrichtung bzw. sämtlicher Supportaufwand in Verbindung mit Datenexporten ist nicht im Wartungsvertrag enthalten und somit kostenpflichtig.
Die hier erstellten Dateien müssen auf der Factoring-Homepage händisch upgeloadet werden.
Für Export-Schnittstellen wird ein Exportmodell benötigt. Dieses wird als Zipdatei ausgeliefert und muss in den Exportmodellen importiert werden.
Die Zipdatei erhalten Sie nach Erwerb der Lizenz auf Anfrage von unseren FIBU Supportmitarbeitern (
fibu@bmd.at).
Starten Sie für den Import der Zipdatei das Programm Finanzbuchhaltung → Import und Export → Buchungen exportieren und dort im Feld "Exportmodell" die F4-Funktion:
Im nachfolgenden Such-Fenster "Exportmodell" kann unter Extras → "Import" die Zipdatei der Export-Schnittstelle importiert werden.
Danach muss ein allgemeines Modell für die Schnittstelle vorhanden sein.
Dieser Datensatz kann mit F6 bearbeitet werden. Der Verzeichnispfad (Exportdatei) für die Export-Schnittstelle kann anschließend beliebig angepasst werden. Ein Dateiname wird automatisch vergeben.
Stammdatendatei: deb_JJJJMMTT.txt
OP-Datei: op_JJJJMMTT.txt
Sie haben die Möglichkeit, den Pfad mit Platzhaltern zu hinterlegen.
Folgende Platzhalter stehen zur Verfügung: Firmennummer $firmennr$, Fibu-Nummer $fibunr$, Jahr $jahr$.
Über den Menüpunkt "Extras" → "Export Parameter" können die Parameter zur Schnittstelle aufgerufen werden.
Folgende Parameter sind für die Schnittstelle vorhanden:

| Buchungen nicht kennzeichnen | Wird dieser Parameter auf 1 gesetzt, werden keine Buchungen markiert. (nur für Tests) |
| Buchungen- Kennzeichen | Hier kann eingestellt werden, ob die Buchungen beim nächsten Export nochmals mitexportiert werden sollen. Kennzeichnung der exportierten Buchungen erfolgt im Feld "Export-Datum". 0 = Export Datum wird nicht gesetzt 1 = Export Datum auf Buchung wird gesetzt |
Buchungssymbol für DB | Buchungssymbol für Drittbelastungen |
Dokumente-Kennzeichen | 0 = alle Dokumente (Standard - Export-Datum wird nicht gesetzt) 1 = nur neue Dokumente (Export-Datum auf Buchung wird gesetzt) 2 = keine Dokumente |
Export Format | Soll eine führende 0 vor die Kundennummer, Belegnummer oder vor dem Betrag übergeben werden, kann eine 1 in das jeweilige Datenfeld gesetzt werden. Kundennummer → Daten1 Belegnummer → Daten2 Betrag → Daten3 |
Export Stammdaten | 0 = Alle Konten werden exportiert 1 = Es werden nur Konten mit einer Buchung exportiert (inkl. Berücksichtigung letztes Export-Datum) 2 = Es werden nur Konten mit einer Buchung exportiert (ohne Berücksichtigung letztes Export-Datum)
|
Exportierende Buchungssymbole | Hier können die Buchungssymbole hinterlegt werden, die beim Export berücksichtigt werden sollen. Leer = Alle Buchungssymbole werden exportiert
|
Konten kennzeichnen | Hier kann eingestellt werden, ob die Stammdaten beim nächsten Export nochmals mitexportiert werden. Kennzeichnung der exportierten Buchungen erfolgt im Feld Export-Datum. 0 = Export Datum wird nicht gesetzt; 1 = Export Datum auf Konto wird gesetzt
|
Konto Zessionskennzeichen | Wenn hier ein Zessionskennzeichen hinterlegt wird, werden nur OPs von Kunden mit diesem Zessionskennzeichen berücksichtigt. |
Kundennummer | Eigene Kundennummer bei der Factor-Bank. |
Letztes Export-Datum | Hier wird nach jedem Export das Export-Datum zurückgespeichert |
Pfad | In diesen Pfad werden die Dokumente mit einem Unterordner (Dokumente<Datum>) abgelegt |
Valutadatum | 0 = Belegdatum wird für die Berechnung der Fälligkeit herangezogen. 1 = Valutadatum wird anstelle des Belegdatums für die Fälligkeit herangezogen.
|
Bei den Kundenstammdaten müssen folgende Felder befüllt sein.
Pflichtfelder: Nachname; Straße; Land; Postleitzahl; Ort
Der Export erfolgt über FIBU → Import und Export → Buchungen exportieren.
Im Fenster Export-Schnittstellen müssen zuerst die gewünschte Firma und FIBU und anschließend das Exportmodell gewählt werden.
| Firma | Firma, für welche der Export gestartet werden soll |
| FIBU | FIBU, für welche der Export gestartet werden soll. |
Exportmodell | Hier kann mit F4 das Factoring-Modell ausgewählt werden. |
Dateiname | Der Pfad der Datei wird automatisch vom Modell vorgeschlagen. |
Über "Exportieren" wird der Export gestartet.
Hier kann das Belegdatum eingegeben werden, bis zu welchem exportiert werden soll.
Standardmäßig wird das aktuelle Tagesdatum vorgeschlagen.
Nach Abschluss des Exports erscheint noch eine Meldung, ob der Export erfolgreich war oder nicht.
Falls ein Fehler auftreten sollte, kann dieser im Factoring.log File ausgelesen werden.
Hinweis | Wird in der Buchhaltung mit Fremdwährung gebucht und es werden alle Buchungen exportiert, kommt die Meldung, dass unterschiedliche Währungen bei den Buchungen vorkommen.
Bei Fremdwährungsbuchhaltungen bekommt der Kunde bei seiner Factoring-Bank pro Währung eine eigene Kundennummer. Es können deshalb mehrere Modelle für die einzelnen Währungen angelegt werden (auf dem Modell ist die entsprechende Kundennummer zu hinterlegen), sodass die Buchungen nach den jeweiligen Währungen getrennt exportiert werden können. Damit die richtigen Buchungen mit dem richtigen Modell exportiert werden, ist eine Einschränkung auf die Buchungssymbole notwendig.
|
OP-Datei
In diese Datei werden offene Posten exportiert.
Debitoren-Datei
In der Debitorendatei stehen alle Konten, die bebucht sind (je nach Parametereinstellung).
Soll ein Kunde nicht an die Factoring-Bank übermittelt werden, kann eine händische Sperre in den Kontenstammdaten am FIBU-Kontoreiter erfasst werden. Dieses Feld lautet „Export-Sperre“.
Automatische Sperren richten sich lt. Parametereinstellung und sind am Feld „Export-Datum“ ersichtlich.
Soll eine Buchung nicht an die Factoring-Bank übermittelt werden, kann eine händische Sperre am Buchungssatz erfasst werden. Dieses Feld lautet „Export-Sperre“.
(Im BMD 5.5 wurde dafür das "Freifeld 105" in der Buchung verwendet.)
Automatische Sperren richten sich lt. Parametereinstellung und sind am Feld „Export-Datum“ ersichtlich.
Hinweis | Log-Informationen: Details zur Ausführung und etwaigen Fehlern der Inhouse Factoring Export-Schnittstelle sind in den Logdateien (Tools → Administration → Protokolle → Logdateien) dem Factoring.log zu entnehmen. |