Diese Sprechblasen geben einen Hinweis zu dem Feld, das momentan markiert ist. Es handelt sich um Kurzhinweise, die angeben, wie das Feld zu befüllen ist bzw. in welche Programmteile es sich auswirkt.
Sie können diese Kurzhinweise mit der rechten Maustaste (in einem leeren Bereich des Eingabefensters) und der Funktion "Kurzhinweis immer anzeigen" deaktivieren oder aktivieren.
Entweder bei einem Feld im Modus des Zeilenweisen Bearbeiten auf den kleinen weißen Bereich mit der rechten Maustaste klicken und hier den Menüpunkt "Kurzhinweis immer anzeigen" aktivieren/deaktivieren:

Oder ein Feld in der Liste suchen, bei dem es Schaltflächen gibt, mit der rechten Maustaste auf die Schaltflächen klicken und so das Menü öffnen:

Die Feldauswahl bietet Ihnen zahlreiche Möglichkeiten, um eine Tabelle zu bearbeiten. Am rechten Fensterrand klicken Sie auf das 3-Punkt-Menü und die "Feldauswahl" oder drücken Sie Strg + F9.
In dieser Maske können Sie nun "Aktive Felder" sortieren, indem Sie diese mit den Pfeilen oder mittels Drag & Drop jeweils nach oben oder unten verschieben. Außerdem können Sie hier mit den Pfeilen links/rechts, durch das Anhaken der Felder im linken Bereich oder mittels Drag & Drop Felder hinzufügen bzw. entfernen. Weitere Formatierungen und Einstellungen können Sie in den Feldeigenschaften vornehmen. Dieser Bereich ist standardmäßig immer eingeklappt und kann bei Bedarf vorübergehend aufgeklappt werden.
Beachten Sie bei den Einstellungen unter "Feldeigenschaften", dass Sie bei der Bearbeitung tatsächlich auf jenes Feld den Fokus gesetzt haben, für das Sie etwas ändern möchten. Möchten Sie beispielsweise für das Feld "Abteilung" einen Vorschlagswert oder eine Farbe definieren, so müssen Sie tatsächlich auf der Zeile "Abteilung" auf der rechten Fensterhälfte stehen, wenn Sie unter Feldeigenschaften die entsprechenden Einstellungen treffen. Häufig benötigte Einstellungen für Felder sind in der FLEX-Oberfläche auch über die Fenster-Reiter verfügbar.
Für die Speicherung der Feldauswahl stehen drei Schalter zur Verfügung:
| Speichern (Benutzerbezogen) | Die Feldauswahl steht nur für Ihren Benutzer zur Verfügung. |
| Speichern (Global) – entsprechende Rechte vorausgesetzt | Die Feldauswahl gilt für alle Benutzer, die keine eigene, benutzerbezogene Feldauswahl oder die einer Layoutgruppe verwenden. |
| Speichern unter | Hier kann die Feldauswahl auch für eine Layoutgruppe gespeichert werden. Zudem können ein Basisfilter definiert, der Standardfilteroperator festgelegt und weitere Einstellungen vorgenommen werden. |
Zu diesem Thema möchten wir Sie auf das Lernvideo Wie kann ich ein neues Feld einfügen? hinweisen.
Bitte beachten Sie auch die Hilfe zum Thema Feldauswahl.
Werden in einer Eingabemaske mehrere Felder bzw. in einer Listenansicht mehrere Spalten temporär, ohne zu speichern, hinzugefügt, kann sich die NTCS die Kombination dieser Felder- bzw. Spaltengruppen merken. Wird zu einem späteren Zeitpunkt wieder eines dieser Felder (oder eine dieser Spalten) temporär hinzugefügt, wird die gespeicherte Kombination aller Felder (bzw. Spalten) automatisch hinzugefügt. Das Hinzufügen eines Feldes (bzw. einer Spalte) ergänzt dadurch auch alle anderen Felder bzw. Spalten der jeweiligen Gruppe.
Diese Funktion ist benutzer- und fensterbezogen und serienmäßig deaktiviert. Für die Verwendung muss unter TOOLS → Tools → Einstellungen → TOOLS Parameter → BMD System → Feldeinstellungen der Parameter "Feld-/Spaltengruppen" auf ">0" geändert werden.
Verwendet der Benutzer für verschiedene Tätigkeiten immer wieder unterschiedliche Kombinationen, können diese auch über den Kontextmenüpunkt "Felder hinzufügen“" ausgewählt werden.
In den Eingabemasken (z. B. Kundeneingabemaske) wird die Feldauswahl über das 3-Punkte-Menü oder durch einen Klick mit der rechten Maustaste aufgerufen. Hier können alle Einstellungen, unter anderem bezüglich des Layouts der Eingabemaske, vorgenommen werden.
In den Layouteinstellungen kann die Anzahl der Spalten der Eingabemaske (Spaltenanzahl) festgelegt werden. Des Weiteren können Einstellungen bezüglich der Schriftart für alle Felder vorgenommen werden.

Alle hier vorgenommenen Änderungen werden erst beim Speichern der Feldauswahl übernommen. Ohne Speichern werden sie beim Schließen des betreffenden Fensters verworfen.
Damit man Felder schneller erkennen bzw. auf deren Wichtigkeit hingewiesen werden kann, ist es möglich, Felder einer Eingabemaske farblich hervorzuheben. Dies ist über die Feldauswahl möglich.
Hier ein Beispiel, wie man auf die Felder "Straße", "Postleitzahl" und "Land" in der Kundeneingabemaske durch farbliche Abhebung vom Gesamtbild aufmerksam machen kann.
- Zuerst öffnen Sie die Kundenliste unter CRM und DMS → Stammdaten → Personen → Kunden
- Danach öffnen Sie einen beliebigen Kunden mit F2 "Ansehen"
- Nun steigen Sie bitte in die Feldauswahl dieser Eingabemaske ein:

- In der Feldauswahl selektieren Sie das gewünschte Feld. Liegen die Felder beisammen, wie im Beispiel: "Straße", "Postleitzahl" und "Land", ist eine Mehrfachauswahl (von-bis) mit gedrückter Umschalttaste möglich. Ein Klick auf "Hintergrundfarbe" öffnet die Farb-Auswahl.

Alternativ kann dieses Fenster auch über die "Feldeigenschaften" aufgerufen werden. In diesem Fall wird auch auf ein eventuell aktives "Multiselect" (Auswahl mehrerer Felder) hingewiesen.

- Im Fenster "Farbe" kann die Hintergrundfarbe festlegt werden:

Falls Ihnen keine Farbe der vorhandenen Auswahl zusagen sollte, können Sie mit der Funktion "Farbe definieren" eine andere Farbe generieren. Im Beispiel wird dies nun für die Felder "Straße", "Postleitzahl" und "Ort" durchgeführt und somit die Hintergrundfarbe Orange eingestellt.
- Nachdem Sie die gewünschten Einstellungen vorgenommen haben, können Sie diese Feldauswahl zunächst ohne Speichern übernehmen. Dabei erhalten Sie den Hinweis, dass die Feldeigenschaften vorerst nur temporär gültig sind.

Die Änderungen sind nun sofort in der Feldauswahl sichtbar.

- Wenn die Änderungen in der Feldauswahl zufriedenstellend sind, kann diese erneut aufgerufen und je nach Anforderung gespeichert werden. "Global" für alle Benutzer, für die Mitglieder einer "Layoutgruppe" oder für einen bestimmten "Benutzer".
Bitte beachten Sie auch die Hilfe zum Thema Feldauswahl.
Der Datentyp sagt grundsätzlich aus, welche Daten in welcher Länge eingegeben werden können. Es gibt drei verschiedene Arten von Datentypen:
- Alphanumerisch (z. B. A50) bedeutet, dass alle Zeichen (Zahlen, Buchstaben und Sonderzeichen) eingegeben werden können und das in der angegebenen Länge (bei A50 maximal 50 Zeichen).
- Numerisch (z. B. N4) bedeutet, dass ausschließlich Zahlen eingegeben werden dürfen und zwar nur bis zur angegebenen Länge (bei N4: maximal 4 Zahlen – höchstens 9999).
- Datum bedeutet, dass hier ausschließlich ein Datum eingegeben werden kann.
Der Vorteil eines Datentyps "Datum" liegt vor allem darin, dass dabei wie gewohnt mit der NTCS Kalenderansicht gearbeitet werden kann.
Es gibt viele verschiedene Freifelder, welche je nach Datentyp eingesetzt werden können. Wenn sie beispielsweise ein Freifeld benötigen, in das Sie ein Datum eintragen möchten, so bietet sich idealerweise ein Freifeld mit dem Datentyp "Datum" an.
Diese Informationen können bei der Suche nach einem passenden Freifeld sehr nützlich sein, da es wichtig ist, das richtige Freifeld für den richtigen Zweck auszuwählen.
Beachten Sie bitte bei der Wahl des entsprechenden Freifeldes, dass Sie immer jenes verwenden, das Ihnen ausreichend erscheint. Beispielsweise wählen Sie ein kurzes Freifeld (wie mit Datentyp A40), wenn Sie bereits wissen, dass in diesem Feld weniger Informationen eingegeben werden. Längere Freifelder (wie mit Datentyp A100) heben Sie am besten für jene Anwendungen auf, für die Sie tatsächlich mehr Inhalt benötigen.
Wenn Felder überlappen, verschoben oder einfach unförmig verteilt sind, so liegt es daran, dass die freie Layoutgestaltung aktiviert worden ist.
Zur freien Layoutgestaltung gelangt man grundsätzlich über einen Rechtsklick (in einem leeren Bereich) → freie Layoutgestaltung. Wurde die freie Layoutgestaltung nicht bewusst aktiviert, kann man sie durch das Speichern der Feldauswahl ohne Häkchen wieder deaktivieren.
Die Breite eines Eingabefeldes wird über die Feldauswahl der Eingabemaske gesteuert.
- Nutzen Sie in der Eingabemaske das 3‑Punkte-Menü oder die rechte Maustaste und öffnen Sie die Feldauswahl.
- Wechseln Sie in der Feldauswahl zum Reiter "Abmaße".
- Markieren Sie das benötigte Feld.
- Bei Eingabefeldbreite kann definiert werden, wie kurz bzw. lang das Eingabefeld dargestellt wird.
Mit der Option max. Zeicheneingabe kann zudem festgelegt werden, dass nur eine bestimmte Anzahl von Zeichen in diesem Feld eingegeben werden kann.
Die Änderungen werden erst übernommen, wenn die Feldauswahl gespeichert wird.
Der Menüpunkt "Datenverknüpfung (Expertenmodus)" ist nur in der Feldauswahl von Datentabellen verfügbar, die diese Funktionalität unterstützen.
Öffnen Sie in der jeweiligen Eingabemaske die Feldauswahl
(Strg + F9), so können Sie - wie folgt - ein Feld als Pflichtfeld kennzeichnen:
In der Maske selbst erkennen Sie ein von Ihnen definiertes Pflichtfeld an einem gelben Dreieck
. Ab nun kann ein Datensatz nur mehr gespeichert werden, wenn dieses Feld einen Eintrag erhält. Sollte dies nicht der Fall sein, werden Sie mit einer Hinweismeldung darauf aufmerksam gemacht.
Für Felder können sogenannte "Benutzerwerte" hinterlegt werden. Diese verwenden Sie, wenn Sie eine feste Auswahl an Ausprägungen zur Verfügung stellen möchten, aus der die einzelnen Benutzer nur auswählen müssen.
Beispielsweise soll ein Feld im Kundenstamm gepflegt werden, das darüber Auskunft gibt, ob dieser Kunde einen Newsletter erhalten möchte.
Dazu sollen im Feld die Ausprägungen "Ja", "Nein" und "Wichtige" zur Verfügung stehen. Damit niemand etwas anderes als diese Ausprägung einträgt, können Sie "Benutzerwerte" wie folgt hinterlegen.
- Die Feldauswahl öffnen (dazu klicken Sie z. B. im rechten Bereich des Fensters im 3-Punkt-Menü auf "Feldauswahl" oder drücken Sie Strg + F9).
- Auf den Reiter "Extras" wechseln.
- Das gewünschte Feld markieren (bei Bedarf z. B. ein freies "Vergleichsfeld" einfügen).
- Bei Nur Benutzerwerte erlauben ein Häkchen setzen:

Es öffnet sich automatisch das Fenster "Verwaltung" der Benutzerwerte. - Die benötigten Benutzerwerte neu erstellen (F5), bearbeiten (F6) bzw. löschen (F7).

- Die Verwaltung der Benutzerwerte schließen und die Feldauswahl am besten global speichern.
Bei künftigen Eingaben stehen nun die Benutzerwerte in Form einer Combobox zur Verfügung.
Wenn Sie eine Feldauswahl mit der Schaltfläche "Speichern (Benutzerbezogen)" ablegen, wird die ausgewählte Feldauswahl ausschließlich für den aktuellen User gespeichert.
Die globale Feldauswahl wird für das betroffene Fenster und den betroffenen Benutzer nicht mehr herangezogen. Stattdessen wird immer die benutzerbezogene Feldauswahl angezeigt.
Diese Einstellung kann in Einzelfällen beabsichtigt sein. Beispielsweise benötigen manche Administratoren eine andere Feldauswahl als alle anderen Benutzer. Das Speichern von benutzerbezogenen Feldauswahlen wird grundsätzlich jedoch nicht empfohlen.

Beispielsweise könnte es sonst durch verschiedene individuelle Feldauswahlen passieren, dass ein User bestimmte Felder gar nicht sieht, die aber für bestimmte Tätigkeiten nötig sind. Auch neue Funktionen oder Felder sind bei benutzerbezogenen Feldauswahlen nicht vorhanden.
Wenn diese benutzerbezogene Speicherung versehentlich stattgefunden hat, können Sie das schnell korrigieren. Rufen Sie dazu in der Feldauswahl-Maske im Menü unter "Extras" die Feldbeschreibungsliste auf.
In dem nun geöffneten Fenster finden Sie alle abgespeicherten Feldbeschreibungen. Die benutzerbezogenen Feldauswahlen erkennen Sie daran, dass der Benutzer, der diese gespeichert hat, im Feld "Benutzer" angezeigt wird.
Dieser Eintrag kann mit der Schaltfläche "Feldbeschreibung löschen (F7)" gelöscht werden. Wird dann das aktuelle Fenster geschlossen und neu geöffnet, wird wieder die globale oder Layoutgruppen bezogene Feldbeschreibungsliste geladen.
Die Feldauswahl bietet die Möglichkeit, alle Einstellungen des jeweiligen aktiven Fensters global, für eine Layoutgruppe und auch benutzerbezogen zu speichern.
Klicken Sie im 3-Punkt-Menü auf Feldauswahl
oder drücken Sie Strg + F9 um diese zu öffnen.
- Global: Wenn Sie die Feldauswahl für alle Benutzer speichern möchten, verwenden Sie "Speichern (Global)".
- Layoutgruppe: Mit "Speichern unter" besteht die Möglichkeit, im Feld "Layoutgruppe/Benutzer" zu definieren, welche Benutzergruppe als Layoutgruppe herangezogen werden soll.
Anschließend muss die Layoutgruppe bei allen Benutzern hinterlegt werden, für welche diese Layoutgruppe gelten soll. Unter TOOLS → Tools → Berechtigungen → Benutzer müssen dazu die einzelnen Benutzer ausgewählt und bearbeitet werden. Das Feld "Layoutgruppe/Benutzer" ist einzublenden, falls es nicht vorhanden ist.
- Benutzerbezogen: Wird die Schaltfläche "Speichern (Benutzerbezogen)" verwendet, gilt die Feldauswahl für den aktuellen Benutzer.
Die Schaltfläche "Speichern unter" bietet alle drei Möglichkeiten:

- Gibt es keine benutzerbezogene Feldauswahl, wird eine eventuell vorhandene Layoutgruppe verwendet.
- Ist der Benutzer für das Fenster keiner Layoutgruppe zugeordnet, wird die globale Feldauswahl verwendet.
Die Reihenfolge der Feldauswahl Priorität ist daher: Benutzerbezogen (vor) → Layoutgruppe (vor) → Global.
| Siehe auch:
Diese finden Sie unter www.bmd.com → Akademie → Shop → CRM/LEA |