Der Filter ermöglicht ein einfaches und intuitives Suchen und Filtern nach den gewünschten Datensätzen. Dabei werden verschiedene Arbeitsweisen unterstützt.
- Klassischer Filter

- Kompakter Filter

Zum einfachen Umschalten zwischen den beiden Modi dienen die blau/gelben Pfeile

.
Der kompakte Filter kann dabei (parametergesteuert) in drei Suchverhaltensweisen arbeiten:
- Klassische Standardsuche: durchsucht dieselben Felder wie der klassische Filter
- Kombinierte Suche mit Vorschau: durchsucht definierte Schlüsselwörter und ermöglicht eine Vorschau auf die ersten 10 Ergebnisse
- Kombinierte Suche ohne Vorschau: durchsucht definierte Schlüsselwörter
Im Folgenden erläutern wir Ihnen die Einstellungsmöglichkeiten und welche Resultate Sie jeweils damit erzielen.
Zum schnellen Suchen und Filtern dient der kompakte Filter. Hier können ein oder mehrere Suchbegriffe eingegeben werden:
Ob der kompakte Filter in Verwendung ist, erkennen Sie am schlichten Design der Filterleiste. Mit den blauen/gelben Pfeilen

auf der linken Seite des Filters können Sie bei Bedarf auf den
klassischen Filter umschalten. Die Entscheidung, welcher Filter angezeigt wird, wird
je Fenster gemerkt. Wenn Sie also auf den
klassischen Filter umschalten und das Fenster zu einem späteren Zeitpunkt erneut öffnen, so wird dieses sofort wieder mit der zuletzt verwendeten Einstellung geöffnet.
Filter-Ansicht | Wenn Sie den Vorschlag für die Filter-Ansicht beim ersten Fensterstart generell auf den kompakten Filter ändern möchten, so können Sie dies über den Parameter "Filter-Ansicht" machen:
TOOLS → Tools → Einstellungen → TOOLS Parameter → Gesamtsystem → (nur) Allgemeine Einstellungen → Filter → Filter-Ansicht
| Wählen Sie hier zwischen der kompakten und der klassischen Filter-Ansicht. |
|
Für den kompakten Filter können Sie wählen, welches Suchverhalten verwendet wird. Abhängig vom Suchverhalten ändern sich die Felder, auch
Schlüsselwörter genannt, die durchsucht werden.
Filter-Suchverhalten
Dieser Parameter aktiviert das gewünschte Suchverhalten, klassisch oder kombiniert. Definieren Sie, ob die kombinierte Suche mit oder ohne Vorschau erfolgen soll.
Menü TOOLS → Tools → Einstellungen → TOOLS Parameter → Gesamtsystem → (nur) Allgemeine Einstellungen → Filter → "Filter-Suchverhalten in kompakter Ansicht":
- Klassische Standardsuche: Durchsucht dieselben Felder wie der klassische Filter, allerdings im Modus "beinhaltet". Wird der Suchbegriff oder die Begriffskombination in der ersten Spalte gefunden, werden die weiteren Spalten nicht mehr durchsucht.
- Kombinierte Suche mit Vorschau: Durchsucht definierte Schlüsselwörter und ermöglicht eine Vorschau auf die ersten 10 Ergebnisse. Die Reihung der Suchergebnisse erfolgt aufgrund einer Gewichtung, wodurch relevantere Suchergebnisse zuerst angezeigt werden. Wird ein Suchbegriff beispielsweise mit "beginnt mit" gefunden, hat dieser eine höhere Gewichtung als ein Treffer mithilfe der Volltextsuche.

.
- Kombinierte Suche ohne Vorschau: Durchsucht definierte Schlüsselwörter.
Welche Felder mit welchem Filtermodus (beginnt mit/beinhaltet) durchsucht werden, ist von BMD vorgeben und kann nicht verändert werden. An einigen wenigen Stellen im Programm ist jedoch firmenbezogen eine Erweiterung möglich. Mehr Infos dazu finden Sie bei den
Schlüsselwörtern.
Hinweis | Bei der Verwendung der Ansicht "kompakter Filter" kann über den Parameter "Operator für neuen Filter" unter TOOLS → Tools → Einstellungen → TOOLS Parameter → Gesamtsystem → Filter dessen Startverhalten definiert werden: - 1 - Beginnend mit
- 2 - Beinhaltet
- 3 - ist gleich
- 4 - ist ungleich
| Dieser Operator wird vorgeschlagen, wenn ein Filter beim Öffnen eines Fensters leer ist. |
|
In der Feldauswahl ist es möglich, das Filterverhalten des kompakten Filters zu speichern.
Drei Optionen stehen hier zur Auswahl:
- laut Parametereinstellung
- Beginnend mit
- Volltextsuche
Achtung! | Diese Funktion befindet sich noch im Beta-Stadium und ist somit noch nicht im vollen Funktionsumfang verfügbar. Die kombinierte Suche ist überdies performanceintensiver als die Standardsuche!
|
Für die Suche geben Sie einen oder mehrere Begriffe in das Filterfeld ein und bestätigen mit Eingabe. Unerwünschte Begriffe können mit dem Vorzeichen Minus "-" aus der Suche ausgeschlossen werden.
Kundensuche
Die Eingabe "BMD -Steyr" zeigt alle Kunden, die "BMD", nicht aber "Steyr" beinhalten:
Bei der Anzeige in der Vorschau wird der als nächstes vorgeschlagene Einschränkungsbegriff stets fett markiert. Diese Funktionalität ist allerdings aus performance-technischen Gründen nicht in jedem Fenster aktiv, sondern nur in Fenstern, in denen häufiger gesucht wird (z. B.
Kundenliste,
Aufgaben …). Im folgenden Beispiel wird nach der Eingabe des Namens als nächster Einschränkungsbegriff der Ort vorgeschlagen:

Wenn mehrere Suchergebnisse in der Vorschau angezeigt werden, haben Sie mehrere Möglichkeiten, das gewünschte Ergebnis zu übernehmen:
Bewegen Sie sich mit den Pfeiltasten ↑ bzw. ↓ auf das gewünschte Ergebnis und übernehmen Sie es mit der Pfeiltaste
→ oder Eingabe

. Natürlich können Sie das gewünschte Ergebnis auch mit der Maus anklicken.
Bei der kombinierten Suche im kompakten Filter werden Schlüsselwörter verwendet. Ein Schlüsselwort stellt den Inhalt eines Datenfeldes dar und kann aus einem Wort oder einer Kombination aus Wörtern und Zahlen bestehen.
Welche Felder/Schlüsselwörter bei der Suche mit dem kompakten Filter durchsucht werden, sehen Sie im Filtermenü

unter

:
Klassische Standardsuche
| bzw. | Kombinierte Suche
|
|
Welche Felder als Schlüsselwörter verwendet werden und auch der dazugehörige Filtermodus (beginnt mit/beinhaltet), ist von BMD vorgeben und kann nicht verändert werden.
Diese sind pro Fenster von BMD fix festgelegt und im jeweiligen SQL-Text der Liste ersichtlich (Klick mit der rechten Maustaste aus die Titelleiste → Anzeige SQL-Text).
Beispiel SQL-Text mit Index-Schlüsselwörtern
| WHERE KDD.KDD_KEYWORD LIKE 'SCHLÜSSELWORT%' AND KDD.KDD_KDDID = C.PER_KWDID)
|
Beispiel SQL-Text ohne Index-Schlüsselwörter | WHERE (INS_INAME LIKE '%SCHLÜSSELWORT%' OR ADR_ORTSNAME LIKE '%SCHLÜSSELWORT%' OR ADR_STRASSE LIKE 'SCHLÜSSELWORT%' OR ADR_PLZ LIKE 'SCHLÜSSELWORT%' OR INS_IMATCHCODE LIKE '%SCHLÜSSELWORT%')
|
An manchen Stellen kann der Administrator eine Erweiterung der Schlüsselwörter einrichten. Damit werden dann zusätzliche Felder durchsucht. Auch diese Liste an Feldern ist von BMD vorgegeben und kann nicht individuell angepasst werden.
Achtung! | Performance im Auge behalten! Diese Erweiterung kann die Performance im Netzwerk beeinträchtigen und sollte daher nur bei passender Infrastruktur verwendet werden.
|
Rufen Sie im Menü TOOLS
→ Tools
→ Administration
→ Datenbank
→ Suchen
→ die
Schlüsselwörter auf:
Wählen Sie zunächst die gewünschte eigene Firma aus. Wählen Sie dann rechts z. B. Kunden/Lieferanten aus und klicken in der Menüleiste auf "Schlüsselwörter erstellen". Damit wird der gewünschte Suchindex erstellt und die erweiterten Schlüsselwörter sind nun in der jeweiligen Firma beim Filtern aktiv. Sie können das überprüfen, indem Sie in der Kundenliste im Filtermenü

auf "Info" klicken:
Hinweis | STB-Kanzleien sollten die erweiterten Schlüsselwörter nur bei Bedarf für die eigenen Firmen einrichten, aber nicht für die Mandantenfirmen, da hier die Datenqualität meist nicht entsprechend vorliegt.
|
Falls Sie feststellen, dass Sie die erweiterten Schlüsselwörter doch nicht benötigen oder die Performance bei der Suche leidet, können Sie Schlüsselwörter wieder löschen. Wählen Sie dazu die gewünschte Firma und rechts die Daten (z. B. Kunden/Lieferanten) aus. Klicken Sie dann in der gelben Menüleiste auf "Schlüsselwörter löschen".
Zum detaillierten Suchen und Finden von Daten steht Ihnen der klassische Filter zur Verfügung. Dieser kann sowohl mit einer einfachen Filterung als auch mit der erweiterten Filterkombination verwendet werden und dient dazu, die Datenliste durch definierte Vergleiche einzuschränken. Die Suche nach beispielsweise einem bestimmten Kunden erfolgt entweder im unteren Anzeigebereich über die Filterleiste
(wobei

,

und

Funktionsbuttons sind!) oder Sie verwenden die folgenden Schnellfilterfunktionen. Diese Funktionen gelten für
sämtliche Listendarstellungen in der NTCS!
Um einen Kunden z. B. nach seinem Namen zu suchen, klicken Sie in die Spalte "Nachname", drücken F4 und schreiben in das sich öffnende Feld den Beginn seines Namens:
Bestätigen Sie mit Eingabe

. Als Ergebnis werden alle Kunden angezeigt, die mit "Allinger" beginnen. Wie Sie unten in der Filterleiste sehen können, ist der eingegebene Text in das Suchkriterium und die angeklickte Spalte "Nachname" in "Suchen nach" übernommen worden:
Teil des Namens: Probieren Sie diese Schnellsuche noch einmal aus, nur geben Sie jetzt "%Allinger" ein, also
F4 → %Allinger. Eingabe

oder ein Klick auf

startet den Filter. Als Ergebnis erhalten Sie alle Kunden, bei denen "Allinger" irgendwo im Feld "Nachname" steht (z. B. Dr. Kurt Allinger GmbH). Diese Vorgangsweise ist dann interessant, wenn nach einer Datenübernahme aus BMD 5.5 der gesamte Kundenname (also Titel, Vorname, Nachname) im Feld "Nachname" steht und Einzelfirmen jetzt schwierig zu finden sind.
Beachten Sie die Anzeige in der Filterleiste - durch die Eingabe des Prozentzeichens ist der Suchmodus auf Volltextsuche umgestellt worden:
Wenn Sie genau nach einem bestimmten Text filtern möchten, markieren Sie diesen durch Anklicken und drücken Sie UMSCHALT + F4, z. B. in der Spalte "Ort" den Wert "Steyr". Dadurch werden alle Kunden im Ort Steyr angezeigt und die Filterleiste ändert sich wie folgt:
Sie können diese Schnellfiltervariante auch bei leeren Feldern ausführen. Dadurch wird - der Filter "Ist leer" gesetzt. Hilfreich ist dies unter anderem, um Lücken in den Stammdaten herauszufiltern, beispielsweise Kunden, die keine E-Mail-Adresse haben.
Beim Filtern über die Filterleiste (anstelle der oben angeführten Schnellfilterfunktionen) stehen Ihnen noch weitere Such-Modi zur Verfügung. Zum
Ändern des Suchmodus klicken Sie auf

.
Suchmodus | Ergebnis |
= ist gleich | Genaue Übereinstimmung. "Allinger GesmbH" im Suchfeld für den Namen listet alle Kunden auf, die genau "Allinger GesmbH" im Kundennamen aufweisen. |
<> ist ungleich | Alle Einträge, die ungleich dem Suchkriterium sind. |
& beginnt mit | Standardsuchmodus. "All" im Suchfeld für den Namen listet alle Kunden auf, die mit "All" beginnen. |
!& beginnt nicht mit | "All" im Suchfeld für den Namen listet alle Kunden auf, die nicht mit "All" beginnen. |
% beinhaltet | Volltextsuche. Dieser Suchmodus wird dann verwendet, wenn Sie nur einen Teil des Feldinhalts wissen, nach dem Sie suchen. |
!% beinhaltet nicht | "All" im Suchfeld für den Namen listet alle Kunden auf, die nicht "All" enthalten. |
> größer als | Alle Einträge, die größer als das Suchkriterium sind. |
>= größer gleich | Alle Einträge, die größer oder gleich dem Suchkriterium sind. |
< kleiner als | Alle Einträge, die kleiner als das Suchkriterium sind. |
<= kleiner gleich | Alle Einträge, die kleiner oder gleich dem Suchkriterium sind. |
=* ist leer | Alle Einträge, in denen dieses Feld leer ist (auch keine Leerzeichen). |
!* ist nicht leer | Alle Einträge, in denen dieses Feld nicht leer ist. |
endet mit | Alle Einträge, die mit dem Suchbegriff enden. |
endet nicht mit | Alle Einträge, die nicht mit dem Suchbegriff enden. |
? genaue Übereinstimmung Text1, Text2, … | Mit diesem Operator ist es möglich, nach mehreren Begriffen in einem Datenfeld zu filtern. Es wird dabei nach allen Begriffen, die durch Beistrich getrennt angegeben werden, gesucht. Beispiel: "Allinger, Burggasser" im Suchfeld für den Namen listet alle Kunden, bei denen genau einer der Texte enthalten ist. |
Volltextsuche mit Text1, Text2, … | Wie oben, nur mit Volltextsuche. Beispiel: "Allinger, Burggasser" im Suchfeld für den Namen listet alle Kunden, bei denen im Feldinhalt irgendwo entweder "Allinger" oder "Burggasser" enthalten ist. |
+ positioniert ab | Dieser Suchmodus springt ohne zu filtern zum ersten Feld, das mit dem Suchbegriff beginnt. Beispiel: Standard positioniert ab 202011 blättert die Kundenliste so auf, dass die Zeile mit der Kundennummer 202011 genau in der Mitte des Bildschirms ist. Dieser Suchmodus funktioniert nur, wenn Sie ein Kriterium eingeben, das in der Liste weiter hinten gereiht wird, also z. B. Cursor steht auf Kunden, der mit C beginnt, dann können Sie ein F eingeben, aber nicht umgekehrt. Detto bei Zahlen. Achten Sie auch auf die korrekte Groß- und Kleinschreibung. |
von-bis-Suche einfügen | Startet einen erweiterten Filter mit den Filtermodi "größer gleich" und "kleiner gleich". |
Selektionsfilter | Mit dem Selektionsfilter können per Checkbox gezielt Datensätze aus einer Liste ausgewählt werden:
Wählen Sie die gewünschten Daten und bestätigen Sie diese mit "Strg + Leertaste". Nach der Bestätigung der Schaltfläche am Filter werden nur noch die gewählten Datensätze angezeigt.
Hinweis | Der Selektionsfilter erleichtert die Arbeit mit Bildschirmlisten und Exporten enorm und kann auch für Vergleiche von zwei Datensätzen hilfreich sein. Er kann auch zusätzlich zur "bisherigen" Filterung gestartet werden.
|
|
Hinweise und Tipps
Beispiel | Möchten Sie eine Anzeige aller Kunden erhalten, die mit "A" beginnen, geben Sie im Kriterienfeld ein "A" ein und drücken Sie die Eingabe-Taste.
|
| Wenn Sie eine Tabelle erstmalig öffnen und filtern, werden von BMD vordefinierte Felder standardmäßig durchsucht. Beim Feldnamen ist  eingeblendet. Sie können sich die standardmäßig durchsuchten Felder anzeigen lassen, indem Sie den Mauszeiger über der Beschriftung des Kriterienfeldes stehen lassen. Meist handelt es sich dabei um die Nummer, den Matchcode und/oder die Bezeichnung.
Das bzw. die Standard-Felder für die Filterung können auch selbst verändert werden: Stellen Sie den Filter so ein, wie Sie ihn standardmäßig wünschen und wählen Sie dann im Filtermenü  die Funktion "Einstellungen als Standard speichern". Falls es sich dabei um eine Filterung mit mehreren Kriterien, also um einen erweiterten Filter handelt, muss dieser zuvor gespeichert werden. Diese Einstellung wirkt nur beim aktuellen Benutzer.
|
| Es gibt einen Parameter, der definiert, ob der Filter standardmäßig im Modus Beginnt mit oder Beinhaltet ist: TOOLS → Tools → Einstellungen → TOOLS Parameter → Gesamtsystem → Allgemeine Einstellungen → 21-Filter | Dieser Operator wird vorgeschlagen, wenn ein Filter beim Öffnen eines Fensters leer ist. |
Achtung! Der BMD TOOLS Support empfiehlt hier eine vorsichtige Verwendung: Wenn der Modus auf "Beinhaltet" gestellt wird, kann bei der Filterung in der Datenbank der Index nicht mehr verwendet werden, was die Filterung deutlich verlangsamen kann. Daher muss, wenn dieser Parameter auf "Beinhaltet" steht, die Performance gut im Auge behalten werden! Dies betrifft allerdings nicht die Suche mit dem kompakten Filter. Hier wird in jedem Fall mit Beinhaltet gesucht. |
| Die Volltextsuche mit "%" kann auch mehrfach innerhalb eines Feldes erfolgen, z. B. Suche im Nachnamen nach %huber%bau.
Als einzelnes Platzhalterzeichen im Filter fungiert der Unterstrich "_". Das Platzhalterzeichen kann zum Beispiel verwendet werden, wenn Begriffe mit Sonderzeichen gesucht bzw. gefiltert werden sollen, man das nötige Sonderzeichen aber nicht mit dem deutschen Tastaturlayout eingeben kann. Für die Suche nach "Ševčenkova" kann entsprechend "_ev_enkova" eingegeben werden. |
| Nach grau angezeigten Spalten kann nicht gefiltert werden, diese dienen nur der Anzeige.
|
| Bei der Filterung in Datumsfeldern erscheint rechts ein blaues Pfeilchen zur Vereinfachung für die Auswahl des Datums: |
| Durch die Eingabe des Wortteils ABS und der gesuchten Zahl kann auch nach dem Absolutwert einer Zahl gefiltert werden: Es funktionieren die Formate ABS 1000 oder ABS(1000). Dies ist praktisch, z. B. in der FIBU oder KORE bei der Suche nach einem bestimmten Betrag, egal ob aufwandsseitig oder ertragsseitig. Alternativ zur Eingabe ABS vor Filtereingabe können Sie die Option über die rechte Maustaste auf das Kriterienfeld → Suchfeld-Funktionen → Absolutwert einer Zahl (ABS) wählen.
|
| Im Filter gibt es die Suchfeldfunktion Text in Zahl umwandeln. Sie kann bei der Filterung nach Feldern behilflich sein, welche Zahlen beinhalten aber als alphanumerisch deklariert worden sind (wie z. B. Postleitzahl). Hiermit wird dann eine Filterung beispielsweise nach kleiner gleich und/oder größer gleich numerisch richtig ausgeführt.
|
| Über Berechtigungen und diesen Parameter kann geregelt werden, welche Felder in der Filterleiste erlaubt sind und nach welchen Feldern somit gesucht werden darf: TOOLS → Tools → Einstellungen → TOOLS Parameter → 4 Berechtigung → Allgemeine Einstellungen → 1 Berechtigung.
ACHTUNG: Diese Einstellung hat nur Auswirkungen auf das klassische Suchverhalten. Im Suchmodus "Smartfilter" findet dieser Parameter keine Anwendung. | Hat man keine Berechtigung zum Ändern der Spalten in Listen (Feldbeschreibung), so sind normalerweise auch nur die sichtbaren Felder der Liste im Filter möglich. Durch Setzen dieser Einstellung wird diese Einschränkung deaktiviert. Felder, auf denen man explizit keine Berechtigung hat, sind davon nicht betroffen und werden trotzdem vom Filter entfernt. Die dritte Variante "Immer nur ausgewählte Felder für Filter erlauben" bewirkt, dass immer nur jene Felder für den Filter zur Verfügung stehen, die derzeit sichtbar sind. |
|
Hinweis | Mit Filtermenü → Ansicht → Herkunft der Felder in Feldsuche anzeigen wird bei der Auswahl der Felder in Klammer die Herkunftstabelle/Ansicht angezeigt:
|
Nutzen Sie auch hier die Möglichkeit der Schnellfilterung mit F4 und der Volltextsuche mit %. Diese findet auch bei mehrzeiligen Einträgen das gewünschte Ergebnis.
Hinweis
| Auch die Chronik im Kundenstamm und die Notiz, die bei allen Daten verfügbar ist, können mittels Volltextsuche durchsucht werden! Wählen Sie einfach das gewünschte Feld in der Filterleiste aus und geben Sie im Kriterienfeld ein Prozentzeichen und den gewünschten Text ein. |
Wenn Sie innerhalb einer Filterung die Suche
weiter einschränken möchten, können Sie im Filtermenü

auf

klicken. Klicken Sie dann in die nächste Spalte, nach der Sie filtern möchten, drücken Sie F4 und geben Sie das gewünschte Kriterium ein. Es wird automatisch ein erweiterter Filter mit der Verknüpfungsart "und" erstellt.
Falls z. B. das zweite Kriterium nicht zum gewünschten Sucherfolg geführt hat, können Sie es mit

auch wieder zurücksetzen. Das erste Kriterium bleibt dann erhalten.
Um die Filterung
dauerhaft in allen Datentabellen additiv einzustellen, gibt es den Parameter "Additive Suche":
TOOLS → Tools → Einstellungen → TOOLS Parameter → Gesamtsystem → Allgemeine Einstellungen → Gesamtsystem
| Ist der Parameter auf "Ja" eingestellt, dann werden beim Suchen in der Liste immer alle Filter addiert, z. B. Suche nach Ort A, dann nach Ort B, dann nach Name C == Suche nach (Ort = A oder Ort = B) and (Name = C). Ansonsten wird immer nur nach dem aktuellen Wert gesucht! |
Ist dieser Parameter auf
Ja eingestellt, dann werden beim Suchen in der Liste immer alle Filter addiert, z. B. Suche nach Ort A, dann nach Name B => Suche nach Ort = A UND Name = B.
Durch diese Funktion, die nur im "Klassischen Modus" verfügbar ist, kann man den Inhalt einer Spalte mit dem Inhalt einer anderen Spalte vergleichen. Wählen Sie dazu die erste Spalte und den gewünschten Vergleichs-Filter aus und klicken Sie anschließend auf das Burger-Menü rechts vom Suchfeld

, um die zweite Spalte auszuwählen:
In diesem Beispiel mit Kundenhaupt- und -untergruppen werden nur noch Einträge angezeigt, die gemäß dem "ist ungleich"-Operator unterschiedliche Werte aufweisen.
Wenn Sie nach
mehr als einem Kriterium filtern möchten, klicken Sie rechts in der Filterleiste auf

. Dadurch wird eine weitere Zeile für ein Filterkriterium eingefügt. Falls das nicht funktioniert, haben Sie beim "Feldnamen" noch die Standard-Filterung aktiv. Wählen Sie stattdessen gezielt ein Feld aus, in dem Sie filtern möchten:
Befüllen Sie die neue Filterzeile nach Bedarf und achten Sie auch auf den Suchoperator rechts (und, oder, und nicht, oder nicht). Drücken Sie Eingabe

, um den Filter zu starten.
Beim erweiterten Filter ist auch interessant, dass durch die Nutzung des Spezialfeldes Eingabe auch mehrere Felder mit dem gleichen Suchtext durchsucht werden können:
Die
Spezialfelder "BMD Benutzer", "Heute", "Eingabe", "Makro" können über das schwarze Pfeilchen

nach dem Suchtext ausgewählt werden.
Achtung! | Das Spezialfeld "Heute" funktioniert in gespeicherten Filtern, kann jedoch nicht in Basisfiltern verwendet werden!
|
Einzelne Bestandteile des erweiterten Filters können über die rechte Maustaste → Entfernen wieder gelöscht werden (STRG + UMSCHALT + ENTF).
Im erweiterten Filter können mit Klammern auch Vorrangregeln für Verknüpfungen von Feldern gesetzt werden, sinnvoll z. B., wenn mehrere Bedingungen wie in folgendem Beispiel miteinander verknüpft werden sollen:
Um mehrere Filterkriterien in Klammer zu setzen, halten Sie die UMSCHALT-Taste gedrückt und klicken dann die gewünschten Kriterien der Reihe nach an. Über die rechte Maustaste finden Sie dann die Funktion "In Klammern setzen".
Erweiterte Filter können im Filtermenü

auch
gespeichert werden. Alle gespeicherten Filter finden Sie im Filtermenü

unter

. Dort können einem Filter auch eine User-ID sowie Datenbesitzergruppen für das Ansehen und Bearbeiten dieses Filters zugeordnet werden.
Um einen gespeicherten Filter wieder zu
laden, klicken Sie links vom Kriterienfeld auf

und wählen den gewünschten Filter aus. Sobald ein gespeicherter Filter aktiv ist, wird links das schwarze Pfeilchen

umrahmt dargestellt:
Mit Filtermenü
→ Ansicht
→ Nur ein Vergleich pro Zeile kann der erweiterte Filter so konfiguriert werden, dass nur eine "Bildschirmzeile" verwendet wird und die Kriterien nebeneinander bzw. bei Platzmangel untereinander angezeigt werden.
Das Minus
links vom Kriterienbereich bewirkt, dass ein mehrfacher Filter
ausgeblendet wird:
Durch einen Klick auf
wird der Filter wieder
angezeigt.
Mit Filtermenü
→ Ansicht
→ Nur ein Vergleich pro Zeile kann der erweiterte Filter so konfiguriert werden, dass nur eine "Bildschirmzeile" verwendet wird und die Kriterien nebeneinander bzw. bei Platzmangel untereinander angezeigt werden.
Das Minus

links vom Kriterienbereich bewirkt, dass ein mehrfacher Filter ausgeblendet wird:

Durch einen Klick auf

wird der Filter wieder angezeigt.
und | Beide Kriterien müssen zutreffen. |
oder | Eines der Kriterien muss zutreffen. |
und nicht | Das erste Kriterium muss zutreffen UND das zweite darf nicht zutreffen. (Umgangssprachlich könnte dieses Kriterium auch in ein ABER NICHT übersetzt werden.) |
oder nicht | Das erste Kriterium muss zutreffen ODER das zweite nicht. Eine ODER NICHT Kombination ist eher unüblich, weil auf das NICHT meistens verzichtet werden kann, indem im Vergleich der umgekehrte Operator gewählt werden kann (<> statt =). Eventuell macht es bei geklammerten Vergleichen Sinn, da sonst in vielen Vergleichen die Operatoren umgedreht werden müssten. |
Drag & Drop
Um einen Vergleich innerhalb des Filters zu verschieben, klicken Sie auf den grauen Bereich am Beginn des Vergleichs und ziehen ihn an die gewünschte Position. Dabei erscheint ein roter Pfeil, der die aktuelle Position anzeigt.

Die Reihenfolge von Vergleichen ist nur dann entscheidend, wenn zwischen den Vergleichen die Operatoren "Und" und "Oder" gemischt verwendet werden. Dabei gilt, der Operator "Und" bindet die Vergleiche stärker.
Beispiel:
Vergleich 1 und Vergleich 2 oder Vergleich 3 entspricht (Vergleich 1 und Vergleich 2) oder Vergleich 3
Damit umfangreich erstellte Filterkombinationen nicht zu viel Platz auf dem Bildschirm einnehmen, lassen sich Filter auch einklappen. Der entsprechende Schalter findet sich in den Filteroptionen.
Es wird dann nur noch der Text "Filter aktiv" angezeigt, und alle anderen Zeilen des Filters werden ausgeblendet.
Mit der Filteroption "Filter vollständig anzeigen" werden die eingeklappten Filter wieder sichtbar gemacht.
Erweiterte Filter können im Filtermenü

auch gespeichert werden. Alle gespeicherten Filter finden Sie im Filtermenü

unter

. Dort können einem Filter auch eine User-ID sowie Datenbesitzergruppen für das Ansehen und Bearbeiten dieses Filters zugeordnet werden.
Um einen gespeicherten Filter wieder zu laden, klicken Sie links vom Kriterienfeld auf

und wählen den gewünschten Filter aus. Sobald ein gespeicherter Filter aktiv ist, wird links das schwarze Pfeilchen

umrahmt dargestellt:
Wenn ein Fenster bereits mit einer bestimmten Filterung geöffnet werden soll, so kann ein Basisfilter in der Feldauswahl hinterlegt werden. Dafür muss der gewünschte Filter zuerst über die Filteroptionen gespeichert werden, um ihn anschließend über die Feldauswahl zu hinterlegen (dieser kann benutzerbezogen oder global gespeichert werden).
Hinweis | Beim gewünschten Filter darf das Suchkriterium <Standard> nicht verwendet werden. Andernfalls steht der gespeicherte Filter bei der Auswahl des Basisfilters nicht zur Verfügung. |
Hinweis | Ein benutzerbezogener Filter steht nur Ihnen zur Verfügung. Wählen Sie bei der Speicherart Global, wenn Sie möchten, dass der Filter von allen verwendet werden kann.
|
Schritt 1 - Speichern der gewünschten Filterung
Eine Demonstration anhand des Fensters "Kontaktpersonen" (Stammdaten → Personen → Kontaktpersonen). Möchte man alle inaktiven Kontaktpersonen ausblenden, so kann man einen Basisfilter hinterlegen, der das Feld "Kontaktende" prüft.
Einstieg in das Fenster "Kontaktpersonen". Im Filter unten wird ausgewählt, wie in Zukunft bereits beim Einstieg in das Fenster gefiltert sein soll:
Somit wird nur nach aktiven Kontakten gefiltert. Dieser Filter wird nun mit dem schwarzen Pfeilchen links unter einem beliebigen Namen gespeichert (Speichern unter - Speicherart global).
Schritt 2 - Hinterlegen der Filterung in der Feldauswahl
Anschließend muss der gespeicherte Filter in der Feldauswahl des Fensters als Basisfilter hinterlegt werden, damit er bei jedem Fensterstart angewendet wird. Dazu wird die Feldauswahl aufgerufen:

Rechts unten in der Feldauswahl "Speichern unter" auswählen:
1. im Feld "Basisfilter" den abgespeicherten Filter auswählen.
2. Speicherart "global" wählen.
Beim nächsten Einstieg in das Fenster wird der Basisfilter geladen. Dies macht sich vor allem dadurch bemerkbar, dass das schwarze Pfeilchen in der Filterleiste gelb hinterlegt ist:
Die Filterleiste ist frei, um weitere Filterungen vorzunehmen.
Um den Basisfilter dauerhaft zu entfernen, wiederholen Sie Schritt 2 und leeren das Feld "Basisfilter" in der Feldauswahl.
Um den Basisfilter kurzfristig zu deaktivieren, klicken Sie auf das gelb hinterlegte schwarze Pfeilchen und wählen "Basisfilter aktiv".
Beispiel | Erstellen Sie in den Aufgaben einen Filter, der im Feld Betreff mit Telefonanruf: beginnt und speichern Sie diesen: 
Rufen Sie die Feldauswahl der Aufgabenliste auf und wählen Sie dort Speichern unter… Wählen Sie bei Basisfilter den hinterlegten Filter aus. Wenn Sie die Feldauswahl benutzerbezogen speichern, gilt sie nur für Sie, wählen Sie beim Gültigkeitsbereich Global, wenn der Filter für alle gelten soll:

In der Aufgabenliste wird im Filtermenü ganz oben angezeigt, dass ein Basisfilter geladen worden ist, und das Filtermenü ist bei aktivem Basisfilter gelb gefärbt :

Durch die temporäre Deaktivierung des Basisfilters werden wieder alle Datensätze gelistet: Klicken Sie im Filtermenu auf Basisfilter aktiv, um den Filter temporär zu deaktivieren. Das Filtermenü sieht dann so aus: .
Beim nächsten Start der Aufgaben ist der Basisfilter wieder aktiv.
|
Hinweis | Wenn Sie einen gespeicherten Filter wieder löschen möchten, rufen Sie im Filtermenu die Funktion  auf, dort finden Sie die Funktion für das Löschen!
Falls Sie den Filter auch als Basisfilter verwendet haben, wird er dort natürlich auch gelöscht!
|
Hinweis | Bei Basisfiltern muss immer ein dezidiertes Filterfeld verwendet werden, ein Filter mit kann nicht als Basisfilter ausgewählt werden. Das Eingabe-Feld kann nicht verwendet werden.
|
Um eine aktive Filterung wieder zu deaktivieren, haben Sie folgende Möglichkeiten:
- rechts neben dem Kriterienfeld auf
klicken, - im Filtermenü
(links in der Filterleiste) die Funktion
aufrufen, - die Tastenkombination ALT + Links drücken,
- oder Sie löschen den Inhalt des Kriterienfelds.
Die allgemeinen Berechtigungen für den Filter befinden sich unter TOOLS → Tools → Berechtigungen → Berechtigungen.
Dort finden Sie die Filter-Berechtigungen unter TOOLS → Tools → Weitere Tools-Funktionen → Fenster → Filterfunktionen:
Mittels Berechtigungen und folgenden Parametern kann geregelt werden, welche Felder in der Filterleiste eines Fensters erlaubt sind und nach welchen Feldern somit gesucht werden darf:
TOOLS → Tools → Einstellungen → TOOLS Parameter → Berechtigung → Allgemeine Einstellungen → Berechtigung.
| Hat man keine Berechtigung zum Ändern der Spalten in Listen (Feldbeschreibung), so sind normalerweise auch nur die sichtbaren Felder der Liste im Filter möglich. Durch Setzen dieser Einstellung wird diese Einschränkung deaktiviert. Felder, auf denen man explizit keine Berechtigung hat, sind davon nicht betroffen und werden trotzdem vom Filter entfernt. Die dritte Variante "Immer nur ausgewählte Felder für Filter erlauben" bewirkt, dass immer nur jene Felder für den Filter zur Verfügung stehen, die derzeit sichtbar sind. |
Ausprägungen:
Nein
Nur in der Liste eingeblendete (= sichtbare) Felder (bzw. Spalten) werden im Filter angezeigt.
Ja
Alle Felder werden im Filter angezeigt. Felder, die über das Berechtigungssystem gesperrt wurden, sind davon nicht betroffen und werden trotzdem nicht angezeigt.
Immer nur ausgewählte Felder für Filter erlauben
Es stehen nur jene Felder im Filter zur Verfügung, die derzeit sichtbar sind.
Berechtigung über erweiterte Fensterrechte ermitteln
Felder sind ersichtlich, wenn sie in den erweiterten Fensterrechten erlaubt sind (Tools → Fenster-Filterfunktionen: Alle Felder für Filter laden).
Soll ein Benutzer einen Filter nicht global speichern dürfen, so kann über die Berechtigungsverwaltung gesteuert werden, dass dieser einen Filter nur benutzerbezogen speichern darf. Dafür muss folgende Berechtigung gesperrt werden:
Diese Funktion befindet sich nicht direkt in der Filterleiste, kann aber in jedem Fenster über
rechte Maustaste → Extras aufgerufen werden und stellt ebenfalls eine Sortierungsmöglichkeit dar. Wichtig ist, dass, bevor die Funktion

aufgerufen wird, das Feld selektiert wird, nach welchem gesucht werden soll.
Beispiel | Wird diese Funktion angestoßen, teilt sich der Bildschirm. Im unteren Bereich öffnet sich das Fenster für mehrfach vorkommende Werte. Durchgeführt am Feld "Ort" im Kundenstamm könnte das Ergebnis folgendermaßen aussehen:
 Die mehrfach vorkommenden Werte lassen sich mit den Plus- bzw. Minus-Symbolen in der Baumstruktur aus- und einklappen.
|
Bei der Eingabe eines Suchwertes in bestimmten NTCS Suchfeldern (beispielsweise eines Ortes im Personenstamm oder eines Kunden im Kundennavigator) ist eine Suche mit Vorschlagswerten möglich, genannt Schnellsuche. Durch die Eingabe von x Buchstaben (kann per Parameter definiert werden) erscheinen x mögliche Ergebnisse in einem Suchfenster unterhalb, die übernommen werden können.

Eine detaillierte Dokumentation finden Sie unter
Schnellsuche.
Oft gestellte Fragen und Antworten zum Thema Filter finden sich in diesem Dokument:
FAQ Filter