
Grundlegende Informationen zum Thema Personalinformation finden Sie unter
Erste Schritte.
Wird das Ausbildungsmanagement des Personalinformationssystems verwendet, so können die Termine für konkrete Ausbildungen an die zugeordneten Teilnehmer per E-Mail versendet werden. Im Anhang werden automatisch eine oder mehrere ICS-Dateien mitgesendet, welche Informationen wie Datum, Uhrzeit und Veranstaltungsort beinhalten. Diese Dateien kann der Teilnehmer anschließend in jeden Kalender importieren, der ICS Dateien unterstützt (z. B. Microsoft Outlook).
Grundlegend kann zwischen zwei unterschiedlichen Versandarten gewählt werden:
- E-Mail im Hintergrund
- Standardbrief
Der
E-Mail Versand im Hintergrund verwendet als Absender die Standard-Maileinstellungen des Users, der den Termin versendet. Der Mailtext basiert auf einer HTML-Vorlage, die in einem eigenen PI-Parameter hinterlegt wird. Der Versand erfolgt immer im Hintergrund.
Alternativ können die Termine via
Standardbrief versendet werden. Der Vorteil ist, dass in den Briefeinstellungen ein individueller Absender-E-Mail-Account hinterlegt werden kann. Als Mailtext wird eine HTML-Briefvorlage verwendet. Weiters können alle bekannten Funktionalitäten des Standardbriefs - wie z. B. der Anhang von Dateien - genutzt werden.
Unabhängig von der Versandart muss je nach Ausbildungsdauer entschieden werden, wie die
Tage an die ICS-Dateien übergeben werden.
In diesem Hilfethema werden zunächst die notwendigen Voreinstellungen näher erklärt, anschließend folgt im Kapitel 5 der gesamte
Ablauf des Terminversands.
Standardmäßig werden im Betreff des E-Mails die Ausbildungsbezeichnung sowie das Datum mitgegeben. Damit auch der Mailtext automatisch vorgeschlagen wird, muss eine HTML-Vorlage angelegt werden.
Der Einstieg erfolgt im Paket PI unter Stammdaten → HTML-Vorlagen → PI Workflowtext-Vorlagen. Mit der Funktion Neu (F5) wird eine neue Vorlage angelegt:
Nach Bestätigung mit "OK" öffnet sich der
HTML-Editor, in dem der Mailtext erfasst wird. Am Reiter "Einfügen" steht unter anderem die Funktion "fx Feld" zur Verfügung, mit welcher z. B. Datenfelder der Ausbildung eingefügt werden können.
Mit der Funktion "Übernehmen" (F2) wird die Vorlage gespeichert. Wird ein Betreff abweichend vom BMD Standard gewünscht, so kann dieser mit der Funktion "Betreff bearbeiten" (STRG + F8) individuell angepasst werden.
Anschließend wird die HTML-Vorlage in folgendem PI-Parameter hinterlegt:
Paket PI → Stammdaten → Einstellungen → Allgemeine PI-Parameter → Allgemeine Einstellungen → Pkt. 6 Ausbildungsadministration → "HTML-Vorlage für Termin als E-Mail versenden"
Für den ICS-E-Mail-Versand im Hintergrund kann kein spezieller Absender-Account hinterlegt werden. Der Absender wird von den allgemeinen E-Mail-Einstellungen ermittelt:
Tools → Überblick über alle Tools-Parameter → Pkt. 1 Gesamtsystem → Pkt. 8 Standard-E-Mail
Achtung! | Änderungen an den Standard-E-Mail-Einstellungen können auch eine Auswirkung auf den Mailversand anderer Pakete bzw. Funktionen der NTCS haben. |
Vorbereitend für den Versand per Standardbrief muss eine HTML-Briefvorlage angelegt werden.
Der Standardbrief Ausbildungen wird im Paket PI unter Ausbildungen → Standardbrief aufgerufen.
Um eine neue HTML-Briefvorlage anzulegen, muss ein Briefordner

ausgewählt sein. Dann kann mit Rechtsklick auf den Briefordner eine
neue HTML-Vorlage 
angelegt werden. Zusätzlich steht die Funktion in der gelben Menüleiste unter "Briefvorlagen und Ordner" zur Verfügung. Der Titel der HTML-Vorlage kann entweder sofort oder auch nachträglich mit der Funktion "Umbenennen (F2)" geändert werden.
Mit Rechtsklick auf die Vorlage wird diese mit der Funktion "Briefvorlage bearbeiten (F6)" geöffnet. Alternativ kann sie auch mit einem Doppelklick geöffnet werden. Nun wird der gewünschte Mailtext im
HTML-Editor erfasst. Am Reiter "Einfügen" steht unter anderem die Funktion
fx Feld zur Verfügung, mit welcher z. B. Datenfelder der Ausbildung eingefügt werden können. Der fertige Text wird mit "Übernehmen (F2)" gespeichert.
Als Mailbetreff wird automatisch der Titel der HTML-Vorlage übernommen. Ist ein individueller Betreff gewünscht, so kann mit Rechtsklick auf die HTML-Vorlage in den Briefeinstellungen ein Makro definiert werden.
Mit der F8-Funktion im Feld "Betreff" wird der Makro-Editor geöffnet:
Mit F5 wird eine neue Berechnungszeile angelegt. Nun können mit den Makro-Funktionen "Fließtext (Wert)" sowie "Datenfelder (fx Funktion)" eingefügt werden. Die einzelnen Teile werden mit "+ Hinzufügen Berechnung" verbunden. Zuletzt muss die Berechnungszeile mit einem Klick auf den Titel als Endergebnis definiert werden.
Beispiel | Der Mailbetreff soll folgendermaßen aufgebaut sein:
Ausbildungsbezeichnung (Beginndatum-Endedatum) z. B. Erste Hilfe Grundkurs (15.06.2020 - 19.06.2020)
Demnach kann das Makro in dieser Form aufgebaut werden:
|
Hinweis | Der BMD Support unterstützt Sie gerne im Zuge eines Fernwartungstermins bei der Umsetzung Ihres gewünschten Betreff-Makros. |
Generell werden Standardbriefe vom E-Mail-Account des eingeloggten Users versendet. Ist dies nicht gewünscht, so kann in den Briefeinstellungen der HTML-Vorlage ein eigener E-Mail-Account definiert werden.
Im Paket Tools unter Zugangsdaten
→ E-Mail-Accounts wird dieser angelegt. Anschließend wird er mit Rechtsklick auf die HTML-Vorlage in den
Briefeinstellungen hinterlegt:
Hinweis | Ob ein E-Mail im Vordergrund oder im Hintergrund versendet wird, kann erst im Sendevorgang entschieden werden. |
Unabhängig von der Versandart muss je nach Ausbildungsdauer entschieden werden, wie die Tage an die ICS-Dateien übergeben werden. Diese Information wird direkt beim Aufruf der Funktion "Termin versenden" in den Versandeinstellungen mitgegeben.
Achtung! | Zu beachten ist, dass es von der Software des Kalenders abhängt, ob ICS-Dateien einzeln oder gesammelt zum Kalender hinzugefügt werden können. Können die Dateien nur einzeln in den Kalender importiert werden, so sollte das bei der Einstellung der Tage beachtet werden, da dies für den Teilnehmer einen erhöhten Aufwand darstellen kann.
|
Für den ersten und für den letzten Tag der Ausbildung wird anhand des Beginn- und Endedatums je ein Termin ermittelt.
Ansicht im E-Mail:
Ansicht im Kalender:
Hinweis | Diese Variante eignet sich für mehrtägige bzw. zeitlich längere Ausbildungen, da damit nicht der gesamte Kalender blockiert wird. |
Es wird ein durchgehender Termin erzeugt.
Ansicht im E-Mail:
Ansicht im Kalender:
Für jeden Ausbildungstag wird ein eigener Termin erzeugt. Gibt es zwischen den Ausbildungstagen Lücken, wird dies berücksichtigt.
Ansicht im E-Mail:
Ansicht im Kalender:
Hinweis | Die Ausbildungstage werden am Tabreiter "Tage" der Ausbildung verwaltet. Folgender PI-Parameter für die Ausbildungsadministration entscheidet, ob die Tage verwendet bzw. automatisch erstellt werden:
| Legt fest, in welcher Form die Ausbildungstage beim Speichern der Ausbildung erstellt werden.
0 - Automatisch: Es wird für jeden Kalendertag innerhalb des Ausbildungszeitraums ein Ausbildungstag erstellt.
1 - Serie: Beim Speichern der Ausbildung öffnet sich die Serienfunktion. Diese ermöglicht zu wählen, wie das Intervall der Ausbildungstage aussehen soll.
2 - Dialog: Beim Speichern der Ausbildung kommt ein Dialog, der die Auswahl zwischen "Automatisch", "Serieneinstellung" und "Nicht erstellen" anbietet.
3 - Nie: Es werden keine Ausbildungstage beim Speichern der Ausbildung erzeugt. |
Wird nicht mit den Ausbildungstagen gearbeitet, werden die Tage bei der Einstellung "Alle" zwischen Beginn- und Endedatum automatisch errechnet.
|
Hinweis | Weicht der Ausbildungsort einzelner Tage vom Ausbildungsort der Ausbildung ab, so wird der Ort der Tage verwendet und der Ort der Ausbildung fungiert als Rückfallsebene.
|
Die Funktion Termin versenden wird am Teilnehmer stehend mit der Rechten Maustaste gestartet. Es ist auch möglich, mehrere Teilnehmer derselben Ausbildung mit gedrückter STRG-Taste zu markieren und dann den Terminversand zu starten.
In den Versandeinstellungen können nun nachträglich noch weitere
Teilnehmer mit F8 hinzugefügt oder abgeändert werden. Unter
Versandart wird entweder
E-Mail im Hintergrund oder
Standardbrief gewählt. Die Einstellung
ICS-Datei erstellen muss auf "Ja" stehen, damit die Termindateien automatisch in das E-Mail übernommen werden. Die Combobox
Tage entscheidet, wie die Ausbildungstage an die ICS-Dateien übergeben werden.
Ist die Versandart E-Mail im Hintergrund gewählt worden, so wird mit "Übernehmen" sofort ein automatischer Hintergrundversand gestartet.
Die Versandart Standardbrief öffnet mit "Übernehmen" den PI Standardbrief und übernimmt die ausgewählten Teilnehmer als Adressaten. Im linken Bereich der Briefvorlagen wird die zuvor definierte HTML-Vorlage markiert. Mit dem Button "Druck/Versand" wird der E-Mail Versand gestartet.
In den E-Mail-Einstellungen muss nun noch "Brief einbetten" gewählt werden, damit die HTML-Vorlage als Mailtext verwendet wird. Weiters wird hier angegeben, ob die E-Mails im Vordergrund oder im Hintergrund versendet werden. Zusätzlich kann bei Bedarf z. B. ein Anfahrtsplan angehängt werden.
Mit der Schaltfläche "OK" wird der Versand gestartet.
Der Teilnehmer kann die Termine nun mit einem Doppelklick auf den Anhang beispielsweise in den Microsoft Outlook Kalender übernehmen.