In diesem Dokument werden einige Sonderfunktionen und die dafür notwendigen Einstellungen angeführt.
Diese Beschreibung beinhaltet Informationen für den Betrieb der Kasse und einer Onlinebankomatkasse (B-Kasse).
Grundsätzlich wird zwischen 4 Schnittstellenprotokollen unterschieden:
- EPS42/EPS48 (dieses Protokoll wird mit Ende 2023 eingestellt)
- ZVT
- hobex fds
- Telekurs MDP
- TIM-API
- TIM-Server
Für das Protokoll EPS42 / EPS48 muss der Dienst "BMD CashClientSVC" installiert werden, unabhängig davon, ob es sich um eine lokale oder eine Terminalsserverinstallation handelt.
Hinweis
| Wird die Kasse in einer Cloud-/RDP-Umgebung betrieben und das Zahlungsterminal über eine serielle Schnittstelle angesprochen, muss der Dienst "BMD CashClientSVC" zwingend bei allen Schnittstellen (mit Ausnahme TIM-API und TIM-Server) installiert und am Kassenstamm aktiviert werden.
Sollte eine Firewall installiert sein, so kann es notwendig sein, dass die Firewall so konfiguriert wird, dass eine Kommunikation über den verwendeten Port (Standard: 1877) erlaubt ist. |
Überprüfung Dienst
Im Windows über die Computerverwaltung → Bereich "Dienste" können Sie überprüfen, ob der Dienst "BMD CashClientSVC" bereits installiert ist.
Installation des Dienstes
Fehlt der Dienst, kann dieser wie folgt manuell installiert bzw. gestartet werden:
- Im Windows Startmenü die BMDNetClient.exe starten.
- Bei einer Serverinstallation muss die Exe über den Server gestartet werden (z. B. \\server\BMDNTCS_PGM\BMDNetClient.exe).
- Bei einer Einzelplatz- bzw. lokalen Installation wird die Exe über die lokale Freigabe gestartet (z. B. \\PC-Name\BMDNTCS_PGM\BMDNetClient.exe).
- Unter "Optionen" wählen Sie den Punkt "Bankomatdienste installieren" aus und mit "Aktualisieren" starten Sie die Installation.
Hinweis
| Wird der Dienst nicht über die BMDNetClient.exe installiert und gestartet, sondern z. B. manuell über die Windowseingabeaufforderung, ist der Dienst beim Neustart des Computers nicht mehr verfügbar. Die Konfiguration erfolgt mit einer "INI-Datei" (BMDCashClientService.ini - zu finden im BMD Software-Verzeichnis, welche in verschiedene Sektionen geteilt ist. Einstellungen in diesen Sektionen erfolgen nicht manuell, sondern aus der NTCS Anwendung (Test der Bankomateinstellung bzw. Start der Kassenerfassung). |
Im Reiter Geräte im Kassenstamm werden im Bereich "Bankomat" und "Allgemein" die Einstellungen für die Bankomatkasse hinterlegt.

Windows-Dienst Adresse | Handelt es sich um eine lokale Installation, kann die IP 127.0.0.1 eingegeben werden - mit dieser IP ist immer der lokale PC erreichbar. Handelt es sich um eine Remoteinstellung, muss die tatsächliche lokale IP-Adresse des Kassen-PC's eingegeben werden.
An die IP-Adresse wird noch die Portnummer mit einem ":" getrennt angeführt (Standard: 1877). Kann die Nummer aus irgendwelchen Gründen nicht verwendet werden, muss in der oben angeführten "INI-Datei" die Portnummer geändert werden.
Wichtig: Nach dieser Änderung muss der PC neu gestartet oder der Dienst "BMD CashClientSVC" manuell beendet und neu gestartet werden. |
| Bankomat | Auswahl des Bankomatprotokolls. |
| Anschluss | Hier wird definiert, über welchen Anschluss der Bankomat angesprochen werden soll. Es muss immer ein serieller (COM) Anschluss sein, mit Ausnahme des ZVT- und TIM-Protokolls, hier ist auch ein Anschluss über LAN möglich. |
| Bits pro Sekunde | Muss mit dem Zahlungsterminal übereinstimmen (Standard: 1200). Nur bei seriellem (COM) Anschluss relevant. |
| Parität | Muss mit dem Zahlungsterminal übereinstimmen (Standard: keine). Nur bei seriellem (COM) Anschluss relevant. |
| Datenbits | Muss mit dem Zahlungsterminal übereinstimmen (Standard: 8). Nur bei seriellem (COM) Anschluss relevant. |
Stoppbits | Muss mit dem Zahlungsterminaal übereinstimmen (Standard: 2). Nur bei seriellem (COM) Anschluss relevant. |
| Flusssteuerung | Muss mit dem Zahlungsterminal übereinstimmen (Standard: keine). Nur bei seriellem (COM) Anschluss relevant. |
| Windows-Dienst verwenden | "Ja" wenn es sich um das EPS42/EPS48-Protokoll verwendet wird, oder es sich um eine Cloud-/RDP-Verbindung handelt und das Terminal seriell angeschlossen ist. |
| Bankomat Konfiguration | Dabei handelt es sich um die ZVT-Schnittstellenkonfiguration, welche je Anbieter unterschiedlich gestaltet ist. Es kann hier unter anderem eingestellt werden, ob die Kasse den Belegdruck des Zahlungsterminal übernimmt oder ähnliches. |
| Passwort | Verlangt das Zahlungsterminal ein eigenes Passwort, ist dieses hier zu hinterlegen. |
Die Ausdrucke für Kartenzahlungen erfolgen am Report für den Kassenbeleg. Dafür muss auf diesem Report im Band "Zahlungsarten" das Feld "Bankomattext" eingefügt werden.
Außerdem müssen das Band "Bankomatjournal" und dort das Feld "Bankomatjournalzeilen" eingefügt werden.
Vor allem bei Bondruckern (Epson) müssen diese Felder über die gesamte Druckbreite angelegt werden!
Für den Ausdruck des Bankomatjournal (ist nur auf Anforderung vom Bankomatanbieter notwendig) wurde ein eigener Standard-Report erstellt, der ebenfalls installiert werden muss.
Warenwirtschaft → Stammdaten → Kassen → Kassenzahlungsarten
Zahlungsarten mit folgenden Kassenzahlungsfunktionen sind für die Bankomatschnittstelle relevant:
Bankomatkarte Standard, Kreditkarte Standard, Kreditkarte mit Trinkgeld, Kreditkarte mit Genehmigungsnummer, Kreditkarte mit Kartennummerneingabe.
Hinweis | Welche Zahlungsarten tatsächlich verwendet werden können, hängt vom Vertrag mit dem Bankomatanbieter ab.
|
Der Zahlungsdienstleister PAYONE GmbH (vormals SIX Payment Services) stellt aktuell 2 Terminal-Protokolle zur Verfügung:
- EPS42/EPS48
- TIM (Till Integration Module)
Beim EPS42/EPS48-Protokoll wird zwischen Bankomat- und Kreditkarte unterschieden. Die neuen "Debit"-Karten sind keine Bankomat-, sondern Kreditkarten und die Zahlung muss somit als "Kreditkartenzahlung" an das Terminal geschickt werden.
Dieses Protokoll wird mit Ende 2023 eingestellt und es steht danach nur noch das TIM-Protokoll zur Verfügung.
Haben Sie ein bestehendes Terminal mit diesem Protokoll muss dieses in der Regel getauscht oder kann gegebenenfalls von PAYONE umgestellt werden. Nähere Informationen erhalten Sie direkt von PAYONE.
Das neue TIM-Protokoll unterscheidet nicht zwischen Bankomat- und Kreditkarte. Es wird nur der Zahlungsbetrag übertragen und das Terminal erkennt den Kartentyp selbstständig.
Zusätzlich wird beim TIM-Protokoll noch zwischen 2 Kommunikationsvarianten unterschieden:
- TIM-API: Die Kommunikation erfolgt aus der NTCS direkt mit dem Terminal.
- TIM-Server: Die Kommunikation erfolgt über den Windows-Dienst "Worldline-SIX Payment Services TIMmpd", der von PAYONE zur Verfügung gestellt wird. Der TIM-Server kommt zur Anwendung, wenn die Kasse über eine Cloud (z. B. BMD Cloud, Server-RDP-Session etc.) gestartet wird.
Vorhandene und bereits im Einsatz befindliche Terminals müssen zeitgleich mit den Anpassungen in der NTCS umgestellt werden. Wird das Terminal vorab umgestellt oder werden die Einstellungen in der Kasse vorab getroffen, funktioniert die Kartenzahlung in der Kassenerfassung nicht mehr.
Hinweis | Vor einer Umstellung sollte auf jeden Fall ein Bankomatabschluss durchgeführt werden. |
Es muss sichergestellt sein, dass die fix hinterlegte IP-Adresse am Terminal bzw. die IP-Adresse des Kassen-PCs über das Netzwerk bzw. über die Session, in der die NTCS läuft, erreichbar ist. Die Kommunikation erfolgt in diesem Fall über das TIM-API-Protokoll.
Bei der BMD Cloud muss in den meisten Fällen die Variante "TIM-Server" zum Einsatz kommen. Bisher kam hier der Dienst "BMD CashClientService" zur Anwendung. Dieser wird nun durch den TIM-Server von PAYONE abgelöst.
Achtung! | Ohne entsprechende Hardware-Firewall kann aus der Cloud nicht auf das lokale Netzwerk zugegriffen werden! |
Am Terminal muss das TIM-Protokoll aktiviert werden. Zusätzlich muss das Terminal auf LAN eingestellt und eine fixe IP-Adresse hinterlegt werden. Die Portnummer 7784 sollte am Terminal nicht umgestellt werden.
Diese Einstellungen werden durch den Support von PAYONE vorgenommen. Der BMD Support hat keinen Zugriff auf die Einstellungen des Terminals.
Die "TIM-Server"-Dienstanwendung wird von PAYONE zur Verfügung gestellt und muss lokal am Kassen-PC installiert werden. Die Kommunikation erfolgt über den Port 8137 und dieser darf durch eine Firewall nicht blockiert werden.
Installation:
- Die Dienstanwendung steht unter https://ftp.bmd.com/ntcs/BMDCashTIM_Server/ als Download zur Verfügung.
- Zipdatei "Setup TIM V3.4.5.0.zip" in ein beliebiges Verzeichnis entpacken.
- Die Batchdatei "BMD Install_Worldline_TIMmpd.bat" ist als Administrator auszuführen.
Die BMD Integrator-ID wird nur zur Information angzeigt. Diese ID hat BMD von PAYONE zur Verfügung gestellt bekommen.
Connection type 1 - TID: Im nächsten Schritt erfolgt die Eingabe der Terminal-ID (8 stellige TID).
Connection type 2 - Broadcast: Die Terminal-ID wird direkt im Kassenstamm hinterlegt.
Connection type 3 - Fix IP: Die fixe IP des Terminals wird im nächsten Schritt eingegeben. Voraussetzung dafür ist, dass es sich bei der am Terminal hinterlegten IP tatsächlich um eine fixe IP handelt, die sich auf keinen Fall ändern darf.
Connection type 4 - Serial: Ist derzeit noch nicht integriert.
Die Abfrage "Select Host IP Adress" ist mit dem Wert 1 zu bestätigen.
Durch die Installation wird die Dienstanwendung "Worldline-SIX Payment Services TIMmpd" installiert und zusätzlich werden für die Kommunikation erforderliche Windows-Firewall-Regeln erstellt.
Bei dieser Variante wird über die Dienstanwendung "Worldline-SIX Payment Services TIMmpd" mit dem Terminal kommuniziert.
Folgende Einstellungen sind am Kassenstamm im Reiter "Geräte" zu hinterlegen:
| Bankomat | Hier wird das TIM-Server-Protokoll hinterlegt. |
| Anschluss | Hier muss die fixierte IP-Adresses vom Host-/Kassen-PC hinterlegt werden, auf dem die Dienstanwendung "TIM-Server" installiert worden ist. Format: IP-Adresse |
| Terminal-ID | Die Terminal-ID (8-stellige TID) muss nur hinterlegt werden, wenn bei der Installation der Dienstanwendung die Opition "Connection type 2 - Broadcast" ausgewählt worden ist. Bei Auswahl der Option "Connection type 1 - TID" oder "Connection type 3 - Fix IP" kann dieses Eingabefeld leer bleiben. |
Bei dieser Variante wird direkt über die fix am Terminal hinterlegte IP-Adresse und über den Port 7784 mit dem Terminal kommuniziert. Die TIM-API kommt hauptsächlich zur Anwendung, wenn die Kasse über das lokale Netzwerk bzw. lokal gestartet wird.
Folgende Einstellungen sind am Kassenstamm im Reiter "Geräte" zu hinterlegen:
| Bankomat | Hier wird das TIM-API-Protokoll hinterlegt. |
| Anschluss | Hier muss die fixierte IP-Adresse vom Terminal hinterlegt werden. Format: LAN:IP-Adresse |
| Terminal-ID | Hier wird die entsprechende Terminal-ID (8-stellige TID) hinterlegt. |
Hinweis | Wird das TIM-API-Protokoll verwendet, darf die Windows-Dienstanwendung "TIM-Server" nicht installiert werden bzw. der Dienst nicht aktiv sein. |
Um diese Funktion nutzen zu können, muss am Terminal die Funktion "Gastro" aktiviert werden und eine Zahlungsart mit der Zahlungsfunktion "Kartenzahlung mit Trinkgeld" in den
Kassenzahlungsarten angelegt werden.
Wird nun eine Zahlung direkt am Terminal mit dem Zahlungstyp "Kartenzahlung mit Trinkgeld" an das Terminal gesendet, kann direkt am Terminal der gewünschte Trinkgeldbetrag eingegeben werden.
Der Trinkgeldbetrag wird auf der Bonzahlung im Feld "Trinkgeld" gespeichert. Eine Auswertung kann über die
Bonzahlungen oder über den
Auswertungsdesigner erfolgen. Eine Verbuchung in der Fibu erfolgt nicht.
Diese Funktion wird aktuell noch nicht zur Verfügung gestellt.
Sind alle Einstellungen am Terminal und im Kassenstamm vorgenommen worden, können diese im Kassenstamm getestet werden.
Warenwirtschaft → Stammdaten → Kassen → Kassen → Funktionen → Bankomatverbindung testen
Mit der Funktion "Netzwerkverbindung prüfen" erfolgt ein Test, ob die hinterlegte IP-Adresse erreichbar und eine Kommunikation möglich ist.
Ist die Verbindung in Ordnung und es kann auf die hinterlegte IP-Adresse zugegriffen werden, erscheint folgende Hinweismeldung.
Wenn die folgende Meldung angezeigt wird, kann keine Verbindung hergestellt werden und es sind die unten angeführten Punkte zu klären.
- Prüfen Sie die IP-Adresse auf Richtigkeit.
- Prüfen Sie die Firewall-Einstellungen, diese können ebenfalls einen erfolgreichen Test verhindern.
- Der Port 8137 darf ein- und ausgehend nicht blockiert werden.
Ist der Netzwerkverbindungstest erfolgreich gewesen, kann noch ein Funktionstest durchgeführt werden. Bei diesem Test erfolgt bereits eine Kommunikation laut Schnittstellenprotokoll.
Es erscheint kurz folgendes Fenster und schließt sich, wenn es keine Fehler gibt.
Sollte ein Fehler auftreten, bleibt das Fenster mit einem entsprechenden Hinweis offen.
Mit der Funktion "Netzwerkverbindung prüfen" erfolgt ein Test, ob die hinterlegte IP-Adresse erreichbar und eine Kommunikation möglich ist.
Kann auf das Terminal mittels hinterlegter IP-Adresse zugegriffen werden, erscheint folgende Meldung.
Kann keine Verbindung zum Terminal hergestellt werden, erscheint folgende Meldung und die unten angeführten Einstellungen sind zu prüfen.
- Prüfen Sie die IP-Adresse auf Richtigkeit.
- Prüfen Sie, ob die Firewall-Einstellungen einen erfolgreichen Test verhindern.
- Der Port 7784 darf ein- und ausgehend nicht blockiert werden.
Ist der Netzwerkverbindungstest erfolgreich gewesen, kann auch noch ein Funktionstest durchgeführt werden. Bei diesem Test erfolgt bereits eine Kommunkation laut Schnittstellenprotokoll.
Es erscheint kurz folgendes Fenster und schließt sich, wenn es keine Fehler gibt.
Sollte ein Fehler auftreten, bleibt das Fenster mit einem entsprechenden Hinweis offen.
Das neue TIM-Protokoll unterscheidet nicht zwischen Bankomat- und Kreditkarte. Es wird nur der Zahlungsbetrag übertragen und das Terminal erkennt den Kartentyp selbstständig.
Die vorhandenen Zahlungsarten sind entsprechend anzupassen.
Warenwirtschaft → Stammdaten → Kassen → Kassenzahlungsarten
Im ersten Schritt ist die Zahlungsart "Bankomat" zu bearbeiten und im Feld "Status" dieser auf "gesperrt" zu stellen.
Im zweiten Schritt kann die Bezeichnung der Zahlungsart "Kreditkarte" auf z. B. "Kartenzahlung" geändert werden. Die Funktion ist auf "Kreditkarte Standard" einzustellen.
Hinweis | Es kann natürlich auch weiterhin mit unterschiedlichen Zahlungsarten gearbeitet werden (z. B. Zahlungsbuchungen von Bankomatkarten und Kreditkarten sollen in der FIBU auf unterschiedliche Konten erfolgen). Die Funktion der Zahlungsarten ist jedoch unbedingt auf "Kreditkarte Standard" einzustellen, da mit der Funktion "Bankomat Standard" ein Bonstorno nicht möglich ist. |
Gemäß der Spezifikationen muss nach dem Starten der Kassenerfassung eine Resetphase von 60 Secunden eingehalten werden. In dieser Zeit darf keine Bankomattransaktion gestartet werden.
 | Nach Auswahl der Zahlungsart und Bestätigung des Betrags wird automatisch der Zahlungsvorgang gestartet. Da es nicht gestattet ist, Retourgeld zu geben, wird der Betrag automatisch auf den Restbetrag begrenzt. Dieses Fenster wird in der Kassenerfassung angezeigt, während auf der B-Kasse der Zahlungsvorgang läuft. |
 | Ist der Zahlungsvorgang abgeschlossen, wechselt die Anzeige auf Grün. Diese Anzeige bleibt so lange erhalten, bis entweder mit der Taste [ESC] oder [Schließen] bestätigt wird. Danach erfolgt automatisch der Bondruck. |
 | Tritt bei der Zahlung ein Fehler auf, wechselt die Anzeige auf Rot. Die Fehlermeldung, die angezeigt wird, stammt von der B-Kasse. Die Kasse hat keinen Einfluss auf diese Meldungen. Diese Anzeige bleibt so lange erhalten, bis entweder mit der Taste [ESC] oder [Schließen] bestätigt wird.
Danach wechselt die Anzeige wieder zur Bonzahlung und man kann entweder die Zahlung wiederholen oder eine andere Zahlungsart aussuchen. |
 | Nach dem Start der Kassenerfassung muss eine Resetphase von 60 Sekunden eingehalten werden, wenn man in dieser Zeit versucht eine Bankomatzahlung zu starten wird die Fehlermeldung "Resetphase!" angezeigt.
Wenn die Kassenerfassung innerhalb der vorgegebenen Zeit keine korrekte Antwort erhält oder die Verbindung zur B-Kasse unterbrochen wird, dann wird die Meldung "Kein Ergebnis!" angezeigt.
In diesem Fall muss unbedingt die Anzeige der B-Kasse kontrolliert werden. Sollte dort angezeigt werden, dass die Zahlung erfolgreich war, dann muss die Option [Manueller Abschluss] ausgewählt werden. Wurde die Zahlung von der B-Kasse nicht durchgeführt, dann hat man die Wahl zwischen [Abbruch] und anschließender Auswahl einer anderen Zahlungsart, oder mit [Zahlung Wiederholen] erneut die Bankomatzahlung starten. Hier muss vom Anwender sehr sorgfältig vorgegangen werden, weil es sonst zu doppelten Abbuchungen kommen kann!
Tritt während einer Bankomatzahlung ein Stromausfall auf oder kommt es zu einem Totalabsturz der NTCS, wird nach dem Neustart der Kassenerfassung versucht, die Bankomatzahlung fortzusetzen. Der Ablauf ist dabei wie folgt: Der bei der Bankomatzahlung aktive Bon wird automatisch in der Kassenerfassung angezeigt, während der 60 Sekunden Resetphase erwartet die Kassenerfassung eine Antwort von der B-Kasse. Kommt diese nicht, dann wird die Meldung "Kein Ergebnis!" angezeigt. |
Zusätzlich zum Kassenabschluss muss auch ein Bankomatabschluss durchgeführt werden. Der Bankomatabschluss muss auf jedem Kassen-PC erfolgen, an dem eine B-Kasse angeschlossen ist. Der Bankomatabschluss kann entweder über den Touchscreen oder im Fenstermenü der Kassenerfassung gestartet werden.
Ist der Bankomatabschluss korrekt durchgelaufen, wechselt die Anzeige auf Grün, der angezeigte Betrag entspricht der Summe der Bankomatzahlungen seit dem letzten Abschluss.
Außerdem wird ein Bericht (entsprechend der Spezifikation) gedruckt. Der Ausdruck erfolgt auf dem Bondrucker, auch wenn dieser nicht als primärer Drucker eingestellt ist. Nur wenn kein Bondrucker konfiguriert ist, wird der Belegdrucker verwendet.
Der Bankomatabschluss beinhaltet 2 Summen TES und T-K. Die TES Summe wird von der B-Kasse ermittelt, die T-K Summe wird von der Kassenerfassung ermittelt.
Diese beiden Summen sollten gleich sein. PayLife bietet aber auch die Möglichkeit, Zahlungen mit Zeitverzögerung durchzuführen,
bekannt aus der Werbung: "Bezahlen Sie jetzt, wir buchen erst in 30 Tagen von ihrem Konto ab".
In diesem Fall stimmen TES und T-K nicht überein, da beim Ermitteln der TES Summe die Verzögerungszeit berücksichtigt wird.
Erst beim Bankomatabschluss werden die Kontobuchungen vom Bankomatanbieter frei gegeben.
Wird kein Bankomatabschluss durchgeführt, erhält der Anwender auch keine Gutschriften vom Bankomatanbieter.
Bei Unklarheiten in der Abrechnung mit dem Bankomatanbieter, kann es vorkommen, dass dieser die Bankomat-Journaldaten zur Klärung anfordert.
Das Bankomatjournal kann über ein eigenes Fenster aufgerufen werden. Die für den Bankomatanbieter relevanten Daten erhält man, wenn man in der Combobox "nur Journal" auswählt. Der Ausdruck muss mit der standardisierten Berichtsvorlage erfolgen. Bei der Kreditkartenzahlung kann keine Selektion der eigentlichen Kreditkarte erfolgen. Welche Kreditkarte die B-Kasse akzeptiert, hängt allein vom Vertrag mit dem Bankomatanbieter ab, darauf hat die Kassenerfassung keinen Einfluss.
Kreditkartenzahlungen laufen analog zu Bankomatzahlungen.
| Die angezeigten Meldungen weichen (der Spezifikation entsprechend) ein wenig von den Meldungen der Bankomatzahlung ab.Der Ausdruck des Kreditkartenbelegs (das ist der Beleg, den der Kunde unterschreibt) erfolgt auf dem Bondrucker, auch wenn dieser nicht als primärer Drucker eingestellt ist. Nur wenn kein Bondrucker konfiguriert ist, wird der Belegdrucker verwendet. |
| Tritt beim Lesen der Kreditkarte an der B-Kasse mehrfach ein Fehler auf, wird in der Kassenerfassung automatisch ein Dialog angezeigt, wo die Kartendaten manuell erfasst werden können. Tritt beim Ausdruck des Belegs ein Fehler auf, so kann der Kreditkartenbeleg (nur von der letzten Zahlung) nochmal gedruckt werden. Im Fenstermenü der Kassenerfassung dient dazu die Funktion "Belegwiederholung". |
| Optional zur Standard-Kreditkartenzahlung sind auch Zahlungen mit Eingabe einer Genehmigungsnummer, mit sofortiger manueller Eingabe der Kreditkartendaten und mit Trinkgeldnachtrag verfügbar. Bei der Zahlungsart Kreditkarte mit Trinkgeldnachtrag läuft die eigentliche Zahlung wie bei Standard-Kreditkartenzahlung ab. Zusätzlich ist es jedoch möglich, im Nachhinein das Trinkgeld zu erfassen, dazu ist die Funktion "Trinkgeldnachtrag (Touchscreen)" zu verwenden.
Ob diese Varianten verwendet werden können, hängt auch vom Vertrag mit dem Bankomatanbieter ab.
|
Auch für die Kreditkarten muss ein eigener Abschluss durchgeführt werden. Dieser kann wie der Bankomatabschluss entweder per Touchscreen oder über das Fenstermenü in der Kassenerfassung gestartet werden. Es wird wieder ein Bericht entsprechend der Spezifikation gedruckt.
Der Ausdruck erfolgt wie beim Bankomatabschluss primär am Bondrucker.
Für den Fall eines Ausfalls der Verbingung zum Server kann ein Notbetrieb der Kasse eingestellt werden.
Für den Notbetrieb muss lokal am Kassen-PC die aktuelle Datenbank und BMDNTCS.EXE vorhanden sein.
Zu empfehlen ist ein DB-Backup am Server zu erstellen und dieses Backup anschließend mit dem lokalen "SQL-Server-Management-Studio" über "Restore - Database" wieder anzuhängen.
Am Desktop wird eine eigene Verknüpfung mit der lokalen BMDNTCS.EXE für den Notbetrieb erstellt. Bei dieser Verknüpfung werden die Datenbank und der User als Kommandozeilen-Parameter hinterlegt.
Beispiel | C:\PROGRAMME\BMD\BMDNTCS.EXE und im Anschluss mit einem Leerschritt /DBALIAS=NOTBETRIEB /USERID=NOTBETRIEB /PWD=NOTBETRIEB /FUNC=MCS_FRMKASSENERFASSUNG_CREATE |
Damit wird sichergestellt, dass es für den Anwender eine einfache Möglichkeit gibt, den Notbetrieb zu starten.
Für den Notbetrieb der Kasse muss ein eigener NTCS-User erstellt werden (Tools → Administration → Berechtigung → Benutzer). Dieser ist auch der User, der bei der Verknüpfung am Desktop hinterlegt ist.
Dieser wird in folgendem Parameter hinterlegt:
| | Ist dieser User angemeldet, dann wechselt die Kasse in den Notfallbetrieb. |
Im Kassenstamm ist im Reiter Funktionen im Feld "Import/Export Pfad" ein Verzeichnis zu hinterlegen, in welches die Bons des Notbetriebs gespeichert werden. Dieses Verzeichnis sollte sich unbedingt lokal am Kassen-PC befinden.
Die lokale Datenbank für den Notbetrieb sollte so oft wie möglich automatisch aktualisiert werden. Mit diesem Datenstand (z. B. Artikelstammdaten, Preise, Kunden, Gutscheine etc.) wird im Notbetrieb gearbeitet.
Die lokale BMDNTCS.EXE muss zumindest nach jedem Server-Update (auch bei Patches) aktualisiert werden!
Hinweis
| Beide Installationen (Server und Kassen-PC) müssen denselben Versionsstand haben! Dafür sind Batches vorzusehen, die automatisch ablaufen, damit der Anwender nicht darauf vergessen kann und kein Arbeitsaufwand entsteht. |
Einkäufe, die ein Mitarbeiter tätigt, können mit einer eigenen Zahlungsart "Lohn" bezahlt werden. Per Export werden diese Daten in eine CSV-Datei für die Lohnabrechnung zur Verfügung gestellt.
Die benötigte Zahlungsart "Lohn" muss als Kassenzahlungsfunktion "Lohnverrechnung" eingetragen werden. Um einen Bon mit einer solchen Zahlungsart abschließen zu können, ist zwingend in der Kassenerfassung am Bonkopf ein Mitarbeiter zu erfassen. Über die Kassen-Lohn-Schnittstelle erfolgen die Anzeige und der Export aller Bonzahlungen, die mit der Zahlungsart "Lohn" abgeschlossen wurden.
Für Zahlungen von Bons durch Mitarbeiter, die über die Lohnverrechnung abgerechnet werden sollen, steht bei der Anlage einer Kassenzahlungsart die spezielle Kassenzahlungsfunktion "Lohnverrechnung" zur Verfügung.
Hinweis
| Ein Bon kann nur mit einer Kassenzahlungsart mit Kassenzahlungsfunktion Lohnverrechnung abgeschlossen werden, wenn in der Kassenerfassung in den Kopfdaten ein Mitarbeiter angegeben wurde. Neben der Kassenzahlungsfunktion Lohnverrechnung ist bei Verbuchung des Kassenabschlusses in einer BMD 5.5 Fibu die Angabe der Kontonummer für die Zahlungsart verpflichtend.
Für Zahlungen, die über die Lohnverrechnung abgerechnet werden, ist dazu ein Verrechnungskonto (Klasse 2) in der BMD 5.5 Fibu anzulegen und bei der Zahlungsart anzugeben. Dieses Verrechnungskonto wird dann bei einem Kassenabschluss bebucht, wenn Zahlungen mittels Lohn vorhanden sind. Beim Einspielen der Mitarbeiterzahlungen in den BMD 5.5 Lohn ist dieses Verrechnungskonto anzugeben.
So gleicht sich das Verrechnungskonto nach Durchführung der Lohnabrechnung wieder aus. |
Bereich Warenwirtschaft → Stammdaten → Einstellungen → WWS Parameter → Einstellungen für Kasse → Kasse-Lohn-Schnittstelle
| | Definition des Dateinamens für den Export.
Hinweis $MAFirmenNr kann als Platzhalter für die Mitarbeiterfirma verwendet werden. Dafür muss der Export dann aber auch auf eine Mitarbeiterfirma eingeschränkt werden. |
| | Definition einer Lohnart, die für den Export herangezogen werden soll.
Hinweis Das Feld "Lohnart" steht in der Kasse-Lohn-Schnittstelle zur Verfügung. Beim Import der Zahlungen in den BMD 5x Lohn muss eine Lohnart verpflichtend übergeben werden. Hierbei handelt es sich um einen numerischen Wert. |
| | Definition eines Vorschlagswertes für die Drop-Down-Auswahl im Fenster "Kasse-Lohn-Schnittstelle".
1 - Details (Zahlungen): Jede Zahlung eines Mitarbeiters wird als eigener Datensatz angezeigt bzw. exportiert. Die Anzahl der Datensätze enspricht somit der Anzahl der mittels "Lohn" getätigten Zahlungen. 2 - Summe je Mitarbeiter: Die Zahlungen eines Mitarbeiters werden kumuliert und somit nur ein Datensatz je Mitarbeiter angezeigt bzw. exportiert. Die Anzahl der Datensätze enspricht somit der Anzahl der Mitarbeiter, die mittels "Lohn" (ein oder mehrere Male) bezahlt haben.
|
| | Definition des Speichernamens jener Feldauswahl, die für den Export verwendet werden soll.
Hinweis: Wird keine Feldauswahl angegeben, so wird die Feldauswahl des Fensters "Kasse-Lohn-Schnittstelle" für den Export verwendet. |
| | Definition, ob die Spaltenüberschriften lt. Feldauswahl mit exportiert werden sollen. |
| | Definition, welches Trennzeichen für den Export verwendet werden soll.
Hinweis: Wird kein Trennzeichen eingetragen, so wird standardgemäß ";" als Trennzeichen verwendet. |
| | Definition jener Mitarbeiternummern, die für den Export nicht herangezogen werden sollen.
Hinweis Die Mitarbeiternummern werden mit ";" (ohne leer) getrennt erfasst. Beispiel: 145;146;147 Der Lohn-Buchungsstatus auf der Zahlung (Feld MCA_BOZ_LOHNBUCHSTATUS) wird beim Export immer auch für jene Datensätze (Mitarbeiter) gesetzt, die in diesem Parameter vermerkt sind. |
Hinweis
| Die Kassen Parameter können auch im Fenster "Kasse-Lohn-Schnittstelle" (Bereich Warenwirtschaft → Kasse → Verspeicherung → Funktionen → Kasse-Lohn-Schnittstelle) im Menü "Extras" mit dem Befehl "Firmenbezogene Einstellungen Kasse" bzw. "Globale Einstellungen Kasse" aufgerufen werden. |
Damit ein Bon mit einer Kassenzahlungsart mit Kassenzahlungsfunktion "Lohnverrechnung" abgeschlossen werden kann, ist zwingend in der Kassenerfassung in den Kopfdaten der Mitarbeiter zu erfassen. In der Kassenerfassung in den Kopfdaten ist dazu das Feld "Mitarbeiter" einzublenden.
Hinweis
| Sollen die Zahlungen über den Lohn exportiert und in den BMD LOHN importiert werden, dann müssen die Mitarbeiternummern des Lohnprogrammes mit den Mitarbeiternummern der NTCS übereinstimmen. |
Bereich Warenwirtschaft → Kasse → Verspeicherung → Menü "Funktionen" → Kasse-Lohn-Schnittstelle
In diesem Fenster werden alle Bonzahlungen angezeigt, die mit einer Zahlungsart mit Kassenzahlungsfunktion "Lohnverrechnung" abgeschlossen worden sind.
In den Einstiegsfeldern kann ausgewählt werden, mit welchen Daten das Fenster angezeigt werden soll.
Nachdem festgelegt wurde, welche Datensätze angezeigt werden sollen, können die gewünschten Datensätze geladen werden.
Mittels der Combobox-Auswahl im rechten oberen Bereich kann der Detailliertheitsgrad der angezeigten Daten gesteuert werden.
Für den Export ist eine spezielle Auswahl und Reihenfolge von bestimmten Feldern notwendig. In der Funktion "Feldauswahl" (siehe auch Parameter Kasse-Lohn-Schnittstelle) kann eine spezielle Feldauswahl für die Erzeugung der Exportdatei angegeben werden.
Wird keine spezielle Feldauswahl für den Export hinterlegt, dann hat jede Änderung der Feldauswahl des Fenster Kasse-Lohn-Schnittstelle eine direkte Auswirkung auf den Export der Daten. Auch unterschiedliche benutzerbezogene Feldauswahlen hätten einen unterschiedlichen Aufbau der Exportdatei zur Folge.
Im Fenster "Kasse-Lohn-Schnittstelle" können die gewünschten Spalten für den Export eingestellt werden. Wird die Feldauswahl global gespeichert, z. B. mit dem Speichernamen "Lohn", so kann diese auch für den Export hinterlegt werden. Der Speichername ist dann im Parameter "Feldauswahl" zu hinterlegen.
Hinweis
| Wird eine Feldauswahl angegeben, die dann zum Zeitpunkt des Exports nicht vorhanden ist, so erfolgt beim Export eine Fehlermeldung. |
Ein monatlicher Import der Lohndaten aus der NTCS Kasse je Mitarbeiter ist mit dem Programm "LV060" im BMD 5.5 LOHN möglich.
Zu diesem Zweck muss die Exportdatei und Importdatei eine CSV-Datei mit Trennung Strichpunkt sein.
Hinweis
| Satzaufbau: Monat; Firmennummer; Personalnummer;[leer];Lohnart; [leer]; [leer];Einbehalt;
Die Reihenfolge der Felder bzw. der Satzaufbau ist zwingend!
Bei [leer] ist kein Wert zu übergeben, die ";" davor und danach müssen jedoch zwingend in der Importdatei vorhanden sein. Dies erreicht man durch Leerfelder, die in der Kassen-Lohn-Schnittstelle mittels Formeln erzeugt werden (neue Formel, Name vergeben, keine Formel angeben).
Monat, in welcher die Zahlung über die Lohnverrechnung abgerechnet werden soll. Das ist entweder der Monat, in der die Bonzahlung getätigt wurde bzw. der Folgemonat. Mittels Formel und der Funktion "month" unter Angabe des Feldes "Datum (Lohn)" kann der Monat der Bonzahlung ermittelt werden.
Mittels Formel unter Angabe eines fixen Wertes kann die Firmennummer für das Exportfile erzeugt werden.
Die Personalnummer entspricht der Mitarbeiternummer der Zahlung. Voraussetzung ist, dass die Personalnummer des BMD 5.5 LOHN mit den Mitarbeiternummern in der NTCS übereinstimmen. Der Einbehalt entspricht dem Betrag. |
Es werden alle offenen Daten export, wie im Fenster "Kasse-Lohn-Schnittstelle" angezeigt. Nach dem Export wird der Lohnbuchungsstatus der Datensätze auf "gebucht" gesetzt.
Ein Datensatz kann mit dem Befehl "Export" nur einmalig exportiert werden. Für einen erneuten Export bereits exportierten Datensätze steht die Nachermittlung zur Verfügung.
Hinweis
| Der Exportbefehl wird aus folgenden Gründen unter gewissen Umständen ausgegraut und steht dann nicht zur Verfügung:
Bei der Eingabe der Daten in den Einstiegsfeldern das bei einem Export das Von-Datum nicht befüllt sein. So wird sichergestellt dass alle gewünschten Daten exportiert werden können.
Die Eingabe muss über die Einstiegsfelder so erfolgend, dass nur offene Datensätze angezeigt werden. So wird sichergestellt dass keine Daten doppelt exportiert werden.
In der Combobox-Auswahl muss dieselbe Anzeigeart eingestellt sein, wie im Parameter "Exportart" angegeben ist. So wird sichergestellt, dass die Daten nicht versehentlich mit einem falschen Detailliertheitsgrad exportiert werden.
Ist der Export der Datensätze über den Befehl "Export" aus einem der genannten Gründe nicht möglich, aber trotzdem erwünscht, so steht dafür die Nachermittlung zur Verfügung! |
Der Befehl Nachermittlung dient zum erneuten Export der Daten bzw. zum Export von offenen und bereits exportierten Daten im gewünschten Detailliertheitsgrad. Für den laufenden Export der Daten ist der Befehl "Export" zu verwenden.
Bei der Nachermittlung werden die Daten gemäß der aktuellen Anzeige im Fenster Kasse-Lohn-Schnittstelle exportiert.
Hinweis
| Im Gegensatz zum Befehl "Export" wird der Lohnbuchungsstatus bei der Nachermittlung nicht gesetzt. Es können sowohl offene als auch bereits exportierte Daten mittels der Nachermittlung exportiert werden. Die Einschränkungen des Befehls "Exports" gelten nicht für die Nachermittlung.
|
Ein monatlicher Import des Einbehalts je Mitarbeiter ist mit dem Programm "LV060" im BMD 5.5 LOHN möglich.
Detaillierte Informationen über den notwendigen Satzaufbau sind im Bereich Feldauswahl zu finden. Hinweis | Folgende Punkte sind im BMD 5.5 LOHN bei der verwendeten Lohnart bzw. bei der Parametrisierung des Imports im Programm "LV060" zu überprüfen:
- Die im Parameter "Lohnart" angegebene Lohnart muss im BMD LOHN korrekt angelegt sein.
- Das bei der Zahlungsart Lohn angegebene Konto (= Verrechnungskonto) ist bei der Lohnart zu verwenden.
- Beim Kassenabschluss werden alle Zahlungen von Mitarbeitern mittels Lohn auf dieses Konto gebucht.
- Durch die Lohnverrechnung sollte dieses Konto anschließend wieder ausgeglichen werden.
- Wird je Zahlung eines Mitarbeiters ein Datensatz exportiert ("Details (Zahlungen)"), dann ist die Lohnart "addierend" einzustellen und es werden alle Datensätze des jeweiligen Mitarbeiters beim Import addiert.
- Ist "nicht addierend" eingestellt und es befinden sich mehre Datensätze für einen Mitarbeiter im Importfile, dann wird nur der Betrag des letzten Datensatzes importiert und nicht die Summe aller Datensätze des Mitarbeiters.
- Es ist die Vorzeichendrehung einzustellen, da Zahlungen positiv und Storno-Zahlungen bzw. Gutschriften negativ übergeben werden.
- Ist keine Vorzeichendrehung bzw. ein festes Vorzeichen eingestellt, so kann dies zu falschen Werten in der Lohnabrechnung führen.
|
Mittels der MDE-Schnittstelle können Bonpositionen in die NTCS Kassenerfassung importiert werden, es stehen zwei unterschiedliche Varianten zur Verfügung.
Über eine MDE-Art mit Verarbeitungsart "Kassenbewegung extern" können Kassenumsätze eines bestehenden Kassensystems in die Kasse übernommen werden. Es werden dazu automatisch beim Import der Daten abgeschlossene Bons erzeugt.
Die Intention dahinter ist, dass die Kassenumsätze von einem anderen bereits im Einsatz befindlichen Kassensystem geliefert und in die NTCS importiert werden. Für diese Kassenumsätze werden automatisch Bons in der NTCS erzeugt. In der Kasse werden nur mehr Korrekturbons bzw. Bons für Ein- und Auszahlungen erfasst. Danach erfolgt eine Kontrolle und je Tag kann ein Tagesabschluss erstellt und anschließend verbucht werden. Der Hauptzweck dieser Vorgehensweise liegt darin, dass Statistikinformationen in der NTCS vorhanden sind und dass bei Kassenabschluss automatisch die notwendigen Erlösbuchungen für die BMD Fibu erzeugt werden.
Vorraussetzungen und Auswirkungen in der NTCS Kasse
Im Zusammenhang mit dieser Variante kann nur die Kassenabschlussart "Tagesabschluss, ohne Saldoführung" verwendet werden. Es gelten die für diese Kassenabschlussart angeführten Einschränkungen.
Zusätzlich zu den automatisch über die MDE-Schnittstelle erzeugten Bons können Bons für Ein- und Ausgaben bzw. Korrekturen manuell erfasst werden.
Der Kassenabschluss erfolgt nicht über das Programm "Kassenabschluss", sondern es kann jeder einzelne Tag, für den Bons vorhanden sind, über das Fenster "Verspeicherung" im Menü "Funktionen" mit dem Befehl "Tagesabschluss" abgeschlossen werden.
Je nach Parametereinstellung kann automatisch bei bzw. manuell nach dem Kassenabschluss Lager, Statistik und die Fibu gebucht werden.
Warenwirtschaft → Stammdaten → Lager → MDE-Arten
Es ist die Verarbeitungsart "Kassenbewegung extern" zu verwenden. Weiters müssen die Felder Bezeichnung, Importart, Verzeichnis, Dateifilter, Dateibehandlung, Sicherungsverzeichnis sowie Feldauswahl befüllt werden.
Unter Feldauswahl ist die Fehlauswahl gemeint, die für den Import verwendet werden soll.
Diese Feldauswahl ist unter Warenwirtschaft → Lager → Diverses → Mobile Datenerfassung → Menü Extras → "Import Textdatei - Daten" einzustellen und mit einem neuen Speichernamen abzuspeichern. Dieser Speichername ist dann im Feld Feldauswahl bei der MDE-Art anzugeben.
Hinweis | Für den Import sind zumindest die folgenden Fehler verpflichtend zu berücksichtigen: Buchungsdatum, Kassennummer, Artikelnummer, Menge, Wert
Die Angabe der Zahlungsart im Importfile ist nicht möglich! Es werden durch den MDE-Import automatisch Bons erzeugt, die mit der ersten Zahlungsart abgeschlossen werden, die bei der jeweiligen Kasse hinterlegt ist.
|
Warenwirtschaft → Lager → Diverses → Mobile Datenerfassung
Der Import kann manuell oder automatisiert über die Mobile Datenerfassung erfolgen.
Werden jeweils nur die Umsätze eines Tages und einer Kasse importiert, dann wird dafür nur ein Bon erzeugt. Befinden sich Datensätze mehrerer Tage bzw. Kassen im Importfile, dann kann dies aufgrund der Importlogik zu mehreren automatisch erzeugten Bons je Tag und Kasse führen.
Nach dem Import sind die erzeugten Bons sofort in der Bonübersicht ersichtlich.
Über die Funktion "Import Bondaten" bzw. "MDE-Import" können Kassenpositionen mittels CSV-Datei über eine Schaltfläche in der Kassenerfassung importiert werden. Es können beispielsweise Dateien von einem Fremdsystem (z. B. Versandprogramm) direkt in die Kassenerfassung übernommen werden.
Import Bondaten
Nach Auswahl der Importdatei kann eine dazugehörige Feldauswahl definiert werden. Es kann nur eine Feldauswahl definiert werden!
Gibt es mehrere unterschiedliche Files muss die Variante "MDE-Import" bevorzugt werden.
MDE-Import
Es muss eine MDE-Art ausgewählt werden. Über die Funktion können mehrere unterschiedliche Files durch mehrere Schaltflächen mit der jeweiligen MDE-Art übernommen werden.
Für den Import bzw. die dafür hinterlegte Feldauswahl muss zumindest die Artikelnummer im Importfile vorhanden sein.
Handscanner dienen zum berührungslosen Scannen eines Strichcodes mit einem optischem Verfahren.
Handscanner werden je nach Modell entweder am Tastaturanschluss vor der Tastatur oder an einem USB-Port angeschlossen. Beide Modelltypen simulieren eine Tastatureingabe. Wird eine Artikelnummer, Kundennummer, Mitarbeiternummer mittels eines solchen Gerätes gescannt, dann muss sich der Fokus in der NTCS auf dem entsprechenden Feld befinden. Der gescannte Wert wird, analog zu einer manuellen Tastatureingabe, immer an die aktuelle Position des Cursors übergeben.
Sollen Ausweise von Mitarbeitern gescannt und der Wert ins Feld Mitarbeiter übernommen werden, so steht zusätzlich zur Möglichkeit des Scannens der Mitarbeiternummer,
auch die Möglichkeit zur Verfügung eine Ausweisnummer zu verwenden, wobei die Ausweisnummer dann eben von der Mitarbeiternummer abweichen kann.
Kartenlesegeräte bieten die Möglichkeit eine Karte berührungslos zu lesen, wobei die Karte einen RFID-Chip enthält und die Identifizierung mit Hilfe von elektromagnetischen Wellen durchgeführt wird. Es kommen dabei Karten mit RFID-Chips des Unternehmens Legic (sogenannte Legic-Cards) in Verbindung mit Kartenlesegeräten (die z. B. vom Unternehmen Kaba angeboten werden) zum Einsatz.
Vom Unternehmen Kaba werden Geräte sowohl mit seriellem als auch mit USB-Anschluss angeboten.
Hinsichtlich der Einsatzmöglichkeiten bzw. der notwendigen Einstellungen in der NTCS unterscheiden sich diese zwei Anschlussvarianten.
Serielle Kartenlesegeräte (Legic-Card) werden über die serielle Schnittstelle (RS232) direkt am Rechner angeschlossen. Die Kommunikation der NTCS mit dem Kartenlesegeräte wird über die Zeitwirtschaft eingerichtet und von der Kasse dann mitverwendet. Solche Geräte dienen zum Scannen von Ausweisen von Mitarbeiten.
Das Kartenlesegerät ist zuerst in der Zeiterfassung zu aktivieren und zu konfigurieren.
Bereich Zeiterfassung → Stammdaten → Einstellungen → Allgemeine CRM Parameter → Zeiterfassung → Buchungsprogramm
| Erfassung von Buchungen mit Lesegeräten aktivieren (Kartenleser, Fingerprint ...).
Wenn dieser Parameter aktiviert wird, so wird nach Auswahl des Kommens, Gehens etc. nach Einlesen der Ausweisnummer in die BMD Zeitbuchungsmaske ein zusätzliches Enter mitgegeben, sodass nicht nochmals bestätigt werden muss.
Achtung: Die Ausprägung "Ja, nur Lesegeräte" ist nur ganz bestimmten Geräten vorbehalten, die direkt an die Software angebunden sind und nicht via Cursorfill eine Eingabe liefern. |
| Hinterlegen Sie hier die Nummer der COM-Port-Schnittstelle die verwendet werden soll, wenn es sich um ein Lesegerät handelt, das an der seriellen Schnittstelle angeschlossen ist. |
| Geben Sie hier Stellenanzahl bzw. die Zeichen-Länge von Ausweisen an, die von einem Comport-Lesegerät geliefert wird. |
Für die Kommunikation mit dem Kartenlesegerät über die serielle Schnittstelle werden standardmäßig derzeit folgende Einstellungen verwendet:
BaudRate: 9600, Parity: Even, DataBits: 7, StopBits: 1
Die Werte von Baudrate usw. können auch durch eine INI-Datei verändert werden. Diese muss im BMD Programmverzeichnis\INI liegen. Name dieser Datei ist "BMDZEITCOMPORT" + Computername.
Weiters sind unter Bereich Zeiterfassung → Stammdaten → Ausweise für die Mitarbeiter Ausweise anzulegen.
In der Kasse ist im Kassenstamm die Einstellung "Kartenleser (Zeit)" auf "Mitarbeiter" zu setzen. Dies führt dazu, dass der vom Kartenlesegerät empfangene Ausweisnummer an die Kassenerfassung weitergereicht und dort der zugehörige Mitarbeiter automatisch ins Feld "Mitarbeiter" in den Kopfdaten eingetragen wird. Der Fokus muss dabei nicht auf dem Feld "Mitarbeiter" liegen. Alternativ kann die Ausweisnummer auch manuell ins Feld "Mitarbeiter" eingegeben werden.
Die F4-Funktionalität ruft eine Liste der Mitarbeiter (nicht der Ausweise) auf.
Serielle Kartenlesegeräte (Legic-Card) werden über die USB-Schnittstelle am Rechner angeschlossen. Über den mitgelieferten Treiber simulieren USB-Geräte eine Tastatureingabe. Der entsprechende Treiber ist zu installieren. Das Kartenlesegerät ist nicht in der Zeiterfassung zu aktivieren und zu konfigurieren.
Wird eine Artikelnummer, Kundennummer, Mitarbeiternummer etc. mittels eines solchen Gerätes gescannt, dann muss sich der Fokus in der NTCS auf dem entsprechenden Feld befinden. Der gescannte Wert wird, analog zu einer manuellen Tastatureingabe, immer an die aktuelle Position des Cursors übergeben.
Sollen Ausweise von Mitarbeitern gescannt und der Wert ins Feld "Mitarbeiter" übernommen werden, so kann zusätzlich zum Scannen der Mitarbeiternummer auch eine Ausweisnummer zu verwendet werden, wobei die Ausweisnummer dann eben von der Mitarbeiternummer abweichen kann.
Unter Zeitwirtschaft → Stammdaten → Ausweise sind dann für die Mitarbeiter Ausweise anzulegen. Weiters ist im Kassenstamm die Einstellung "Kartenleser (Zeit)" auf "Mitarbeiter" zu setzen.
Die Kassenprovisionsermittlung baut auf den WWS Stammdaten Vertreter, Provisionstabellen und Provisionstabellenmanagement auf. Zur Einrichtung von Vertretern, Provisionsstabellen etc. siehe Skriptum für NTCS Provisionen.
Die Ermittlung von Provisionen in der Kasse ist in den Parametern zu aktivieren und festzulegen, wann die Provisionsermittlung erfolgen soll (Bonabschluss, Kassenabschluss oder manuell nach Kassenabschluss). Weiters ist in den Parametern festzulegen, ob die Kassenprovisionsermittlung neben den Vertretern auch für den Verkäufer erfolgen soll.
In der Kassenerfassung stehen bei den Kopfdaten die Felder Vertreter 1 - 4 und der Verkäufer zur Verfügung.
Eine Liste aller ermittelten Kassenprovisionen kann in der Bonübersicht unter "Funktionen" aufgerufen werden. Die Kassenprovisionen können über die Bildschirmliste ausgedruckt bzw. in Excel exportiert werden. Anmerkung: In der Vertreterabrechnung sind die Kassenprovisionen derzeit (noch) nicht enthalten.
Provisionen können auch manuell (nach)erfasst werden. Dazu in der Bonübersicht am Reiter "Bonpositionen" bzw. im Fenster "Bonpositionen" mit der rechten Maustaste auf eine Bonposition klicken und "Kassenprovision" auswählen. Es werden dann die automatisch ermittelten bzw. bereits manuell erfassten Kassenprovisionen zu dieser Position angezeigt. Hier können zur dieser Bonposition Provisionen manuell erfasst bzw. diese bearbeitet bzw. gelöscht werden.
Manuell erfasste Kassenprovisionen erhalten das Erstellkennzeichen "manuelle Eingabe", automatisch ermittelte Kassenprovisionen erhalten das Erstellkennzeichen "Ermittlungsprogramm".
Automatisch ermittelte Provisionen können nicht bearbeitet oder gelöscht werden.
Die NTCS Kasse bietet die Möglichkeit, Barcodes mit Übergabe von Menge oder Preis zu verwenden.
Unter Präfix versteht man in diesem Fall die ersten beiden Stellen im EAN-Code. In der EAN 13 gibt es die Präfixe 20 bis 29.
Die Präfixe werden von der GS1 vergeben und festgelegt.
Nachfolgend aufgelistet sind die momentan aktuellen Präfixe.
| Präfix | Anwendung | Beispiel |
| 20 | Eigene Artikelnummer als Strichcode | 20 0000000020 P |
| 21 | Gewicht im Strichcode Handel | 21 00020 00120 P |
| 22 | Preis im Strichcode Handel | 22 00020 00002 P |
| 23 0 | Preis im Strichcode Industrie | |
| 24 | Preis im Strichcode Handel | 24 00020 00123 P |
| 25 | Derzeit nicht in Verwendung | |
| 26 | Derzeit nicht in Verwendung | |
| 27 0 | Gewicht im Strichcode Industrie | |
| 28 | Stück im Strichcode Handel | 28 00020 00002 P |
| 29 0 | Stück im Strichcode Industrie | |
Hinweis | Im Bereich Warenwirtschaft sollte der folgende Parameter auf deaktiviert werden. WWS Parameter → Stammdatenverwaltung → EAN → 1 - EAN-Prüfung bei Neuanlage
Am Artikelstamm werden die ersten 7 Stellen vom Instorecode eingegeben. Damit kann keine gültige Prüfziffer ermittelt werden.
Am Artikelstamm werden die ersten 7 Stellen im Feld EAN Code eingegeben, also das Präfix und die Artikelnummer mit 5 Stellen. Für Instorecode sind Artikelnummern mit max 5 Stellen erforderlich. In diesem Fall ist die Artikelnummer 20.
In der Kasse wird statt des Feldes "Artikelnummer" das Feld "Barcode" benötigt. Gibt man jetzt den Instorecode 2100020001204 ein, hat das folgende Auswirkung: Die Artikelnummer 20 wird ermittelt und ein Gewicht von 120 Gramm.
Gleiches gilt für Menge, Stück und Preis. Zu beachten sind auch Vorkomma und Nachkomma im Code.
Für die Auflösung ist der Befehlsatz unter Stammdaten/Diverse zuständig. Dieser ist im Standard schon richtig voreingestellt. |
In der Kassenerfassung ist es möglich, bestimmte Funktionen mit einer Berechtigung zu belegen. Die Kassenberechtigungen können direkt in der Kassenerfassung sowie im Kassenstamm im Menüeintrag "Extras" unter "Berechtigungen setzen" aufgerufen werden.
Dazu sind folgende Schritte notwendig:
- Verschiedene Berechtigungsgruppen (z. B. Shopleitung, Kasse etc.)
- Jeder Kassier muss als NTCS User angelegt und mit einem beliebigen Passwort (vorzugsweise numerisch für eine schnellere Eingabe über Touch) versehen werden.
- Zuordnung der NTCS User in der jeweiligen Berechtigungsgruppe
- Zuordnung der User-ID im Mitarbeiterstamm (ohne die Zuordnung erfolgt keine Passwortabfrage!)
- In den Kassenparametern muss im Parameter "Benutzerrechte" ein beliebiger User hinterlegt werden, der lt. Berechtigungen am wenigsten Rechte in der Kasse hat.
Hinweis
| Durch einen Kassierwechsel wird automatisch der NTCS User in der Kassenerfassung geändert. Das heißt, die NTCS muss nicht mit dem jeweiligen Kassier-Login gestartet werden. Es wird in diesem Fall empfohlen die NTCS automatisch (Single Login) mit einem allgemeinen User (z. B. Kasse1) zu starten.
Die Passwortabfrage erfolgt automatisch bei jeder Funktion, für die der hinterlegte User keine Berechtigung hat. Die Passwortabfrage erfolgt auch dann, wenn ein Kassier angemeldet ist, der die Berechtigung besitzt. Damit wird vermieden, dass durch einen übersehenen Kassierwechsel auf einmal alle Funktionen verfügbar sind. |
Um einen unberechtigter Kassierwechsel zu vermeiden, empehlen wir Folgendes:
- Beim Verlassen des Kassenplatzes die Kasse über eine Schaltfläche "Kasse sperren"zu sperren. Für die neuerliche Anmeldung muss der Kassier seine Mitarbeiternummer und das dazugehörige Passwort (lt. NTCS User) eingeben.
- Bereits beim Kassenstart die Passwortabfrage aktivieren (Parameter "Kassier Eingabe).
Multifunktionale Chipkartensysteme von InterCard integrieren alle Kartenfunktionen in einem System und auf einer einzelnen Karte (z. B. Schlüssel zu Gebäuden, Abrechnungs- oder Zahlkarte für Kopierer, Kantine etc.).
Mit dieser Schnittstelle stellt die Kasse den Bezahlvorgang mittels Chipkarte von InterCard zur Verfügung.
Die Konfiguration der Anbindung wird über die Kassenstammdaten gesteuert. Es wird dort die Hinterlegung von Schnittstelle und Terminal-ID des InterCard-Kartenlesers vorgenommen. Über die Kasse getätigte Zahlungen werden fix von der "Hauptbörse" der Karte abgebucht. In der NTCS werden lediglich die Zahlungsfunktionen der Kasse genutzt. Andere Service- oder Verwaltungsfunktionen sind nicht Bestandteil dieser Erweiterung.
Die Kommunikation mit dem InterCard-Kartenleser erfolgt unter Einsatz der icswterm.dll. Diese DLL wird durch die Firma InterCard zur Verfügung gestellt und ist kein Bestandteil der NTCS.
Um die Schnittstelle zu aktivieren, müssen am Kassen-PC Verzeichnisse laut Vorgabe von InterCard definiert werden. Dort werden die Dateien und Ordner von InterCard abgelegt. Die notwendigen Dateien werden von InterCard auf einem USB-Stick zur Verfügung gestellt und sind auf das jeweilige Unternehmen abgestimmt. Das Lesegerät für die Chipkarten wird ebenfalls von der Firma InterCard zur Verfügung gestellt.
Dieses Entwicklungs-Kit ist so konfiguriert, dass lokale Daten in das Verzeichnis C:\ProgramData\InterCard geschrieben werden.
Es werden folgende Unterverzeichnisse vorausgesetzt (siehe auch Verzeichnis-Template):
- C:\ProgramData\InterCard\data
- C:\ProgramData\InterCard\DoNotTouch
Falls die angegebenen Dateipfade für die Transaktionen (Schattendatei, unverschlüsselte Datei) nicht existieren, werden diese - falls die Berechtigungen vorliegen - von der DLL angelegt.
Folgende Dateien müssen in das Verzeichnis C:\ProgramData\InterCard\DoNotTouch abgelegt werden:
Die Sperrlistendatei sperrlst.dat im Verzeichnis C:\ProgramData\InterCard\data muss zumindest als leere Datei vorhanden sein, da sonst eine Fehlermeldung erzeugt wird.
Im Kassenstamm im Reiter "Geräte" sind die Einstellungen für die InterCard vorzunehmen.
Folgende Felder sind für die InterCard zu befüllen:
- Anschluss: lt. Geräte-Manager
- Verzeichnis: lt. Vorgabe von InterCard hier zu hinterlegen.
Hinweis
| Der Windows-Dienst hat aktuell noch keine Funktion. |
Für die InterCard ist eine eigene Kassenzahlungsart anzulegen, welche dann im Bezahlvorgang ausgewählt werden kann.
Für die Kassenerfassung kann im Touchscreenkonfigurator eine eigene Schaltfläche für das Auslesen der Infos von der InterCard angelegt werden. Damit kann z. B. das aktuelle Guthaben auf der Karte ausgelesen werden.
Es muss der aktuelle Druckertreiber (den aktuellen Treiber finden Sie direkt bei Epson unter
Download - POS - Epson (epson-biz.com)) installiert werden. Nach der Installation wird der Drucker automatisch unter den Windows-Druckern angezeigt.
In den Kassenstammdaten bei Anschluss "Printer:" den Namen des Druckers eintragen, dafür kann auch F4 zur Suche verwendet werden. Alternativ kann auch über eine Freigabe gedruckt werden. Dazu muss eine Druckerfreigabe eingerichtet werden und in den Kassenstammdaten bei Anschluss "File:" der PC-Name und der Freigabename des Druckers eingetragen werden (z. B. FILE:\PC_KASSE01\Bondrucker). Ansonsten sind beim Druckertreiber keine besonderen Einstellungen notwendig.
Beim Modell TM-T20II muss bei Bedarf die Papierbreite angepasst werden. Dazu muss in den erweiterten Einstellungen des Druckertreibers unter "Drucksteuerung" die Papierbreite auf "80mm - 42 Spalten" eingestellt werden.
Wird ein Logo am Bonreport benötigt, muss dieses direkt auf den Drucker geladen werden.
Hinweis
| Ein hinterlegtes Logo direkt im Report wird vom Bondrucker nicht erkannt und somit nicht gedruckt. |
Das Logo wird direkt in den Druckereinstellungen des Windows-Druckers unter "Erweiterte Einstellungen" hinterlegt. Bei älteren Treiber sind die Logoeinstellungen unter "Hilfsprogramme/EPSON Flash Logo" zu finden.
Format
Um ein gutes Druckergebnis zu bekommen, sollte das Logo mit den Eigenschaften 2-färbig (schwarz/weiß) als BMP oder JPG mit 500 Pixel Breite zur Verfügung stehen.
Keycode
Für ein Logo, das am Bonanfang gedruckt werden soll, muss der Key-Code 48/48 verwendet werden. Soll es am Bonende gedruckt werden, muss der Key-Code 48/49 verwendet werden.
Die Kassenlade wird mittels RJ12-Kabel direkt mit dem Bondrucker verbunden. Dazu ist keine Installation oder Einstellung in den Kassenstammdaten notwendig. Über die Kassenzahlungsarten kann gesteuert werden, ob die Kassenlade geöffnet wird.
Wird die Kassenlade nicht direkt am Bondrucker angeschlossen, erfolgt der Anschluss über einen USB-Kassenladenöffner. Durch die Installation des Treibers erhält man eine virtuelle COM-Schnittstelle, welche in den Stammdaten der Kasse in den Anschlusseinstellungen für die Kassenlade hinterlegt wird.
Hinweis
| Öffnet sich die Kassenlade beim Bondruck nicht automatisch, überprüfen Sie bitte Folgendes:
Kassenlade ist direkt am Bondrucker angeschlossen: - Überprüfen Sie die Kabelverbindungen und stecken Sie diese ggf. aus und wieder ein.
- Überprüfen Sie auch den Bondrucker auf dessen Funktionalität. Da die Kassenlade beim Ausdruck eines Bons geöffnet wird, könnte es auch daran liegen, dass der Bondrucker nicht ordnungsgemäß funktioniert bzw. angeschlossen ist.
Kassenlade wird über USB-Kassenladenöffner angesteuert: - Überprüfen Sie in Windows im Geräte-Manager, ob die im Kassenstamm hinterlegte COM-Schnittstelle verfügbar ist.
- Prüfen Sie, ob der aktuellste Treiber für die virtuelle COM-Schnittstelle installiert ist.
- Prüfen Sie die Kabelverbindungen und stecken Sie diese ggf. aus und wieder ein.
- Überprüfen Sie auch den Bondrucker auf dessen Funktionalität. Da die Kassenlade beim Ausdruck eines Bons geöffnet wird, könnte es auch daran liegen, dass der Bondrucker nicht ordnungsgemäß funktioniert bzw. angeschlossen ist.
Für beide Anschlussarten steht in den Kassenstammdaten die Funktion "Kassenlade testen" zur Verfügung. Führen Sie diesen Test durch. Ist der Test erfolgreich und die oben angeführten Punkte sind von Ihnen ebenfalls überprüft worden, kann davon ausgegangen werden, dass es sich um einen Hardwarefehler handelt. |
Für die Installation wird ein Treiber benötigt (TMUSB610a bzw. aktuelle Treiber finden Sie direkt bei Epson unter
Download - POS - Epson (epson-biz.com)). Dieser Treiber simuliert eine serielle Schnittstelle, in den Kassenstammdaten muss bei Anschluss "COM" und die Nummer der Schnittstelle eingetragen werden.
Wird das USB-Display am PC angeschlossen, erhält man im Geräte-Manager ein unbekanntes Gerät. Für dieses Gerät nun die Treibersoftware aktualisieren und den Installationsort des Treibers auswählen. Nach der Installation erscheint ein weiteres unbekanntes Gerät → Vorgang der Treiberaktualisierung wiederholen.
Wurden beide Geräte aktualisiert, erhält man unter Anschlüsse nun eine serielle Schnittstelle (im Regelfall COM4). Über diese kann nun das Display im Kassenstamm angesprochen werden.
Handscanner werden in der Regel über USB am PC angeschlossen. Da es sich um ein reines Eingabegerät (wie Tastatur) handelt, sind keine Installationen notwendig. Barcodescanner werden im Normalfall mit einer Konfiguration ausgeliefert, die alle gängigen Barcodetypen (EAN8, EAN13, Code39 etc.) unterstützt.
Der Scanner sollte nach dem Scannvorgang automatisch ein "ENTER (CR)" mitschicken. Ist dies nicht der Fall bzw. schickt der Scanner einen anderen Befehl (z. B. "TAB"), kann dies mittels Handbuch entsprechend konfiguriert werden.
Durch die Zertifizierung beim BEV (Bundesamt für Eich- und Vermessungswesen) verfügt die Kasse über einen gültigen Prüfschein. Mit diesem ist es möglich, eine preisrechnende, nichtselbsttätige Waage in die Kassenerfassung zu integrieren.