Um
Auswertungsdaten aus der NTCS Warenwirtschaft zu erhalten, steht der Auswertungsdesigner mit seinen vielzähligen und individuellen Auswertungsmöglichkeiten zur Verfügung.
Neben der Möglichkeit, die BMD Standardauswertungen zu nutzen, können auch Auswertungen angepasst und/oder selbst entworfen werden.
Grundsätzlich werden die Auswertungen im Auswertungsdesigner verwaltet. Die konkrete Auswertung wird aber meistens mithilfe sogenannter Smart-Interfaces, welche dem Benutzer vordefinierte Filterabfragen stellen, an anderen passenden Stellen im Programm gestartet. Die Anwender der Auswertung erhalten somit ein einfach gehaltenes Abfragefenster und nicht die Einstellungen zur Auswertung selbst, welche somit vor
unbefugtem Zugriff geschützt wird.
BMD stellt viele Standardauswertungen zur Verfügung. Sind im Auswertungsdesigner noch keine Auswertungen vorhanden, können diese importiert werden. Der Import kann über folgende Varianten durchgeführt werden:
- Im Fenster Auswertungsdesigner: Über das Fenstermenü → Funktionen → Import/Export → Standardauswertungen importieren.
- Über Standards importieren: Diese Funktion ist zu finden im Paket WWS → Stammdaten → Einstellungen → Standards importieren. Nachdem die Firma ausgewählt ist, können beim Punkt "Auswertungen" über
(F8) die jeweiligen Auswertungen ausgewählt werden, die importiert werden sollen.

Da Standardauswertungen programmintern gekennzeichnet sind, ist es ausgeschlossen, dass durch einen Import selbst entworfene Auswertungen überschrieben oder gelöscht werden. Standardauswertungen selbst können nur mit Filter gestartet, jedoch nicht verändert werden.
Im
Auswertungsdesigner (Bereich Warenwirtschaft
→ Auswertungen
→ Auswertungsdesigner) werden die Auswertungen erstellt und verwaltet. Im Neuanlage- oder Bearbeitungsmodus einer Auswertung ist der
Spaltendesigner das wesentliche Element zur Gestaltung des Auswertungsaufbaus. Zudem stehen hier Datenfiltermöglichkeiten und Optionen zum Layout zur Verfügung.
Jede Auswertung (rechts) ist einem Auswertungstyp (links) zugeordnet. Auswertungstypen werden von BMD zur Verfügung gestellt und sind unveränderbar. Diese Auswertungen sind mit einem Häkchen in der Spalte "BMD" gekennzeichnet. An ihnen erkennt das Programm, welche Daten benötigt werden. So unterscheidet sich die Datenermittlung von Auswertungstyp zu Auswertungstyp. Je Auswertungstyp können beliebig viele Auswertungen angelegt werden.
Folgende Auswertungstypen stehen zur Verfügung:
| Statistik | Daten der verspeicherten Wareneingänge und Ausgangsrechnungen bilden die Basis. |
Artikel | Daten der Artikel bilden die Basis für die Auswertung. |
Person | Daten der Personen bilden die Basis für die Auswertung. |
Stücklistenpositionen Stammdaten | Stücklistenpositionen aus den Stammdaten bilden die Basis. Dabei können ausgewertet werden: - Stücklistenkopf
- Stücklistenpositionen
- Artikel
|
| Rechnungspositionen | Daten der verspeicherten Rechnungen bilden die Basis. |
Abgabenpositionen - Rechnung | Abgabenpositionen der verspeicherten Rechnungen bilden die Basis. |
Erfassungsprovisionen | Hier bilden die erfassten Provisionen in den Aufträgen die Basis für die Auswertung. |
Vertreterabrechnung | Daten der bereits erstellten Vertreterabrechnungen bilden die Basis. |
Warenausgangskosten | Hier bilden die erfassten Warenausgangskosten die Basis für die Auswertung. |
Lieferscheinpositionen | Daten der verspeicherten Lieferscheine bilden die Basis. |
Gebindeverwaltung | Auswertung des aktuellen Gebindesaldos je Kunde, Lieferant bzw. Spedition. |
Auftragspositionen | Hier bilden die erfassten Aufträge die Basis für die Auswertung. |
Angebotspositionen | Hier bilden die erfassten Angebote die Basis für die Auswertung. |
Rechnungsprovisionen | Hier bilden die Vertreterprovisionen von verspeicherten Aufträgen die Basis für die Auswertung. |
Verleihjournal | Hier bildet das Verleihjournal die Basis für die Auswertung. |
Artikel-VK-Preisinfo | Hier bilden die Artikelstammdaten sowie die VK-Preis- und Rabatttabellen die Basis für die Auswertung. |
| Hier bilden die Artikelstammdaten sowie die EK-Preis- und Rabatttabellen die Basis für die Auswertung. |
Bestellpositionen | Hier bilden die erfassten Bestellungen die Basis für die Auswertung. |
Ankaufspositionen | Hier bilden die erfassten Ankäufe die Basis für die Auswertung. |
Produktionspositionen | Hier bilden die erfassten Produktionsaufträge (PPS) die Basis für die Auswertung. |
Anfragepositionen | Hier bilden die erfassten Anfragen die Basis für die Auswertung. |
Abgabenpositionen - Wareneingang | Hier bilden die Abgaben von verspeicherten Wareneingängen die Basis für die Auswertung. |
Wareneingangspositionen | Hier bilden die erfassten Wareneingänge die Basis für die Auswertung. |
Ankaufsrechnungspositionen | Hier bilden die Ankaufsrechnungspositionen die Basis für die Auswertung. |
Warenbeschaffungskosten (alt) | Hier bilden die Warenbeschaffungskosten (alt) die Basis für die Auswertung. |
Warenbeschaffungskosten | Hier bilden die Warenbeschaffungskosten die Basis für die Auswertung. |
Lagerbestandsliste | Der aktuelle Lagerbestand kann hier ausgewertet werden. |
Lagerjournal | Getätigte Zu- und Abgänge können über das Lagerjournal ausgewertet werden. |
Inventurliste | Hier können bereits verbuchte Inventuren ausgewertet werden. |
Lagerkontomonatswerte | Hier bilden die Lagerkontomonatswerte die Basis für die Auswertung. |
Bonpositionen | Hier bilden die erstellten Bons in der Kasse die Basis für die Auswertungen. |
Bonkopf | Hier bilden die erstellten Bons in der Kasse die Basis für die Auswertung. |
Bonzahlungen | Hier bilden die bei der Zahlung verwendeten Kassenzahlungsarten in der Kasse die Basis für die Auswertung. |
Kassen Ein- und Auszahlungen | Hier bilden die getätigten Ein- und Auszahlungen in der Kasse die Basis für die Auswertung. |
Gutscheinkopf | Hier bilden die Gutscheine die Basis für die Auswertung. |
Kundenkartei | Hier bildet die Kundenkartei die Basis für die Auswertung. |
Rechnungspositionen inkl. Kundenkartei | Hier bildet die Kundenkartei mit den Umsätzen der Artikel und den dazugehörigen Rechnungspositionen die Basis für die Auswertung. |
Budget | Hier bilden die geplanten Einnahmen und Ausgaben die Basis für die Auswertung. |
Dispoliste | Geplante Zu- und Abgänge können über die Dispoliste ausgewertet werden. |
| Produkte | Hier bilden die Produkte die Basis für die Auswertung. |
| Stückliste | Hier bilden die Stücklisten die Basis für die Auswertung. |
In den Auswertungstypen können Sie mit der Funktion "Standard-Kopfzeile/Standard-Fußzeile"

eine Standard-Kopfzeile bzw. Standard-Fußzeile hinterlegen.
Folgende Felder stehen Ihnen im Bereich des Auswertungsdesigners zur Verfügung:
Das wesentliche Element der Auswertungsgestaltung ist der
Spaltendesigner. Diesen erreichen Sie über das Feld "Spaltendesigner" im Bearbeitungsmodus einer Auswertung oder über die Funktion "Spaltendesigner" im
Auswertungsdesigner.
Zuerst ist die Sortierung festzulegen, indem im Spaltenbaum unter - Sortierung - passende, sinnvoll kombinierte Sortierkriterien gewählt werden. Die Anordnung der Kriterien spielt insofern eine Rolle, da zuerst nach dem an der ersten Stelle stehenden Kritierium sortiert wird. Verfeinert wird die Sortierung mit jedem nachfolgenden Kriterium.
Dann sind dem Programm die gewünschten Datenspalten bekanntzugeben, indem diese ebenfalls aus dem Spaltenbaum Daten ausgewählt werden. Auf demselben Weg können auch, falls für eigene Berechnungen erforderlich, die Spezialspalten aus dem Spaltenbaum Spezial in die Übersicht geholt werden.
Für jede Spalte ist anschließend das Format einzustellen und es sind, falls gewünscht, spezielle Spaltenoptionen zu vergeben.
Die Auswahl der Sortierung und die Definition des Sortierkriteriums selbst (über die Optionen) haben zum Teil erhebliche Auswirkungen auf die Aussagekraft und die Lesbarkeit der Auswertung, da sie das Bild der Auswertungstabelle mitbestimmen. Daher kann es zweckmäßig sein, dieselbe Auswertung einmal mit einer gröberen, übersichtlicheren Sortierung anzulegen und ein zweites Mal mit einer detaillierteren, informativeren Sortierung.88882222
Hinweis | Eine Beschreibung zu den nützlichen Funktionen im Spaltendesigner finden Sie in unserem Hilfesystem in der Fensterhilfe Spaltendesigner im Bereich "Funktionen".
|
Die Datenmenge, welche in die Auswertung fließt, wird mithilfe von Filterfeldern eingeschränkt.
Filterfeldern begegnet man mehrfach im Programm. Ist es gewünscht, die Auswertung fix mit Einschränkungen auf bestimmte Merkmale starten zu lassen, ist es sinnvoll, diese bereits im Bearbeitungsmodus der Auswertung einzustellen.
Bei den Filterfeldern ist zu beachten, dass es manche mit Mehrfachauswahl von Filterkriterien gibt - erkennbar am Symbol

.
Die Filterfelder können beliebig miteinander kombiniert werden und ergänzen sich.
Ein Auszug aus den Filterfeldern:
| Firma | Es können bereits im Auswertungsdesigner fixe Definitionen der Filterfelder vorgenommen werden.
Hinweis | Um im Feld "zugeordnete Firmen" mittels F4-Funktion eine Firma aus der Firmengruppe auswählen zu können, muss hier die gewünschte Firmengruppe eingegeben werden. |
Achtung! | Wird keine Firma definiert und aus dem Auswertungsdesigner aufbereitet, so werden ALLE Firmen verwendet! |
|
| Filter | In diesem Filterfeld können eine oder mehrere miteinander kombinierte Filterbedingungen erstellt werden, welche im Auswertungsergebnis berücksichtigt werden. Mit der Funktion F8  wechselt man in die Filterdefinition, um die Filterbedingungen zu erfassen. Im gelben Menü kann definiert werden, ob der Feldsuchdialog aufgeklappt oder zugeklappt geöffnet werden soll. Fix vordefinierte Filter für die Auswertung. Wird ohne Eingabe eines Wertes gefiltert, so kann der Wert beim Aufruf der Auswertung aus dem Smart-Interface (Feldauswahl → Feld Filter) eingetragen werden andernfalls ist der Filter nicht veränderbar. |
Makrofilter | Mithilfe dieses Filterfeldes über ein Makro Filter definiert werden. Damit kann per Makro gesteuert werden, ob eine Datenzeile erhalten bleibt oder nicht. Mit der Funktion F8  öffnet sich der Makro-Editor. |
Makrofilter auf Aggregat | Mithilfe dieses Filterfeldes über ein Makro Filter definiert werden. Damit kann per Makro gesteuert werden, ob eine Ausdruckszeile erhalten bleibt oder nicht. Mit der Funktion F8  öffnet sich der Makro-Editor. |
Periode:
| Periode von-bis | Fixe Vorgabe von Perioden |
| Vergleichsperiode 1 von-bis | Fixe Vorgabe von Vergleichsperioden |
Vergleichsperiode 2 von-bis | Fixe Vorgabe von Vergleichsperioden |
Hinweis | Datensätze, die in den Sortierspalten keine Werte aufweisen (z. B. Kunde ist keiner Kundengruppe zugeordnet, die Auswertung wird jedoch nach Kundengruppen sortiert), können über folgendes Feld in der Auswertung ausgenommen werden:
| Mit dem Feld "Sortierungen ohne Zuordnung drucken" kann je Auswertung gesteuert werden, ob Datensätze, welche in den Sortierspalten keine Sortierwerte aufweisen, angezeigt werden oder nicht. Im Standard ist das Feld aktiviert.
Beispiel LEA Auswertung "Zeilenstatistik Lohnabrechnung" | Die Auswertung zeigt diverse Kennzahlen zur Zeilenstatistik. Als Sortierspalten sind hier nur Bezugsjahr und Bezugmonat vorgesehen. Mit der aktivierten Einstellung "Sortierungen ohne Zuordnung drucken" werden alle Daten gedruckt, unabhängig davon, ob sie in den beiden Sortierspalten Sortierwerte enthalten oder nicht.
Ist die Einstellung "Sortierung ohne Zuordnung drucken" deaktiviert, werden Daten, die keine Sortierwerte in den Sortierspalten aufweisen, nicht mehr angedruckt. Somit werden nur Leistungen angedruckt, die sowohl Bezugsjahr als auch Bezugsmonat aufweisen.  |
|
Zusätzlich zu der Einschränkung im Ausdruck wird damit auch der Vorschlag im Showprogramm im Fenstermenü → Ansicht → Datensätze ohne Zuordnung anzeigen gesteuert.
Ist das Feld "Sortierung ohne Zuordnung drucken" auf "Nein" eingestellt, ist im Showprogramm die Ansicht der Datensätze ohne Zuordnung deaktiviert. Diese kann bei Bedarf manuell über das Fenstermenü → Ansicht → Funktion "Datensätze ohne Zuordnung anzeigen" aktiviert werden.
|
Die Befüllung der Filterfelder in diesem Bereich ist nur sinnvoll, wenn diese Filterung dauerhaft sein und bei jedem Aufruf die Datenmenge beeinflussen soll.
Ausnahme: Beim Testen einer Auswertung, oder wenn die Eingabe in die Filterfelder anschließend nicht gespeichert wird, kann die Filterung auch an dieser Stelle eingestellt werden.
Der erste Schritt des Layouts (= Aussehen der Tabelle) wurde bereits mit dem Einstellen der Spalten und der Vergabe eines passenden Formates im
Spaltendesigner vorgenommen. Weitere Tabellenoptionen sowie Formatoptionen, die den gesamten Ausdruck betreffen, werden im Bearbeitungsmodus der Auswertung eingestellt.
Da man bei einer Auswertung nicht nur auf die Richtigkeit der Daten, sondern auch auf die Darstellung der Daten Wert legt, ist es notwendig, sich die möglichen Optionen in den Layoutfeldern durchzusehen, ob eine/mehrere davon für ein "schöneres" Erscheinungsbild sinnvoll eingesetzt werden können.
Folgende Aufstellung der Gestaltungshilfen soll Ihnen einen Überblick über die wichtigsten Einstellungsmöglichkeiten geben.
| autom. Spaltenbreite | Es ist empfehlenswert, im Feld "Autom. Spaltenbreite" eine der "Ja"-Optionen zu wählen, da das Programm in diesen Fällen bereits für eine automatische Anpassung der Spaltenbreiten sorgt.
Folgende Ausprägungen stehen zur Verfügung: - Nein (nur Mindestvorspann)
- Ja (mit Mindestvorspann)
- Ja (ohne Mindestvorspann)
|
| Reportdesign | Über dieses Feld kann ein eigener Report für die Auswertung hinterlegt werden. Einen eigenen Report für eine Auswertung anzulegen ist jedoch nur in seltenen Fällen zu empfehlen, da komplexe Einstellungen und auch eine aufwändige Wartung notwendig sind. Überprüfen Sie zuvor, ob Sie die Gestaltung der Auswertung über die weiteren Optionen realisieren können.
| Hinweis |
Das Reportdesign im Auswertungsdesigner ist zwar der "üblichen" Reportgestaltung in der NTCS ähnlich, birgt aber einige abweichende Herausforderungen. (Beispielsweise müssen sämtliche Spalten bereits im Spaltendesigner enthalten sein, bevor der Report gestaltet wird, da neue Spalten nicht automatisch berücksichtigt werden.) |
|
| Formularkopf/-fuß-Druck | Hier kann definiert werden, ob ein Formularkopf oder -fuß angedruckt werden soll. Die Einstellung hat jedoch nur dann eine Auswirkung, wenn im Feld "Formularkopf" und "Formularfuß" ein entsprechender Report hinterlegt ist.
Folgende Ausprägungen stehen zur Verfügung: - Nur Kopfbaustein
- Nur Fußbaustein
- Kopf- und Fußbaustein
- Keine
|
| Formularkopf | Hier können Sie einen Report für den Formularkopf hinterlegen. |
| Formularfuß | Hier können Sie einen Report für den Formularfuß hinterlegen. |
| Ausdruck/Linien | Über dieses Feld wird definiert, ob beim Ausdruck der Auswertungen auch Linien gedruckt werden sollen.
Folgende Ausprägungen stehen zur Verfügung: - laut Standard (alle Linien werden gedruckt)
- vertikale und horizontale Linien
- nur vertikale Linien
- nur horizontale Linien
- Keine Linien
|
| Nullzeilen unterdrücken | Gibt es in der Auswertung Daten (z. B. Artikel), die keine Werte im definierten Auswertungszeitraum haben, kann über diese Einstellung gesteuert werden, ob diese Daten angedruckt werden.
Folgende Ausprägungen stehen zur Verfügung: - Standard lt. Parameter (Standardausprägung)
- Nullzeilen nicht unterdrücken
- Nullzeilen unterdrücken
|
| Sortierung ohne Zuordnung drucken | Über dieses Feld kann definiert werden, ob Datensätze, die keinem Sortierkriterium (z. B. Warenhauptgruppe) zugeordnet sind, gedruckt werden sollen. |
| Kopfzeilen nach Seitenumbruch drucken | Definiert, ob nach einem Seitenumbruch die Kopfzeile wieder gedruckt werden soll. |
| Exporteinstellung | Mit F8  können individuelle Exporteinstellungen für die Auswertung hinterlegt werden.
Beim Aufruf der Funktion "Export" aus der Auswertung selbst bzw. aus dem Auswertungsdesigner werden die hinterlegten Einstellungen vorgeschlagen und können manuell angepasst werden.
Wird die Auswertung über Stapel exportiert, so gelten jene Einstellungen, die auf der Auswertung hinterlegt sind (ohne Abfrage). |
| Formatierte Werte exportieren | Werden im Spaltendesigner spezielle Formatierungen hinterlegt, kann über diese Funktion definiert werden, ob die Formatierungen auch beim Export übernommen werden sollen (z. B. Datumsformatierung, Zahlenformatierung etc.).
Folgende Ausprägungen stehen Ihnen zur Verfügung: - Standard (nur hinterlegte Datumsformate werden exportiert)
- Nein
- Ja
|
| Schriftgröße automatisch verkleinern | Dieses Feld bietet eine komfortable Einstellungsmöglichkeit hinsichtlich der idealen Spaltenbreite der Auswertung. Es ist in Kombination mit dem Feld "automatische Spaltenbreite" anzuwenden. Weist dieses Feld eine der "Ja"-Ausprägungen auf, wird bei aktivem Feld "Schriftgröße automatisch verkleinern" die Schriftgröße der vordefinierten Spalteninhalte im Verhältnis zu den Spalten laut Spaltendesigner gedruckt. |
| Summenzeichen drucken | Wird in der Auswertung die Gesamtsumme angedruckt, kann über dieses Feld definiert werden, ob die Summenzeichen gedruckt werden sollen. |
Die erstellten Auswertungen stehen nicht nur im Auswertungsdesigner, sondern auch an anderen Stellen für einen schnellen, sinnvollen Aufruf zur Verfügung. Da der Auswertungsdesigner für Administratoren konzipiert ist (siehe Kapitel "Schutz einer Auswertung"), gibt es noch eine Reihe von Aufrufen bzw. Funktionen, die dem Anwender helfen sollen, die passende Auswertung in der richtigen Form (Bildschirm, Ausdruck, Datenexport etc.) zu erhalten.
Programmstellen mit Zugriff auf die Auswertungen:
Stammdaten
- Artikelstamm (Artikel- und Kundenstatistik über das Kontextmenü oder einen eigenen Reiter unter den Artikeldetails)
- Kundenstamm (Kundenstatistik)
Verkauf
- Rechnungen (unter "Ausdruck" im Menü)
- Angebote (unter "Ausdruck" im Menü)
- Aufträge (unter "Ausdruck" im Menü)
- Navigatoren (sofern die Auswertung für die Navigatoren definiert ist)
- Auswertungen
Lager
Einkauf
- Bestellungen (unter "Ausdruck" im Menü)
- Auswertungen
Ausgabeformen:
Unter Warenwirtschaft → Tools → Administration → Stapelverarbeitung → Stapeldefinition können Stapelauswertungen eingerichtet und gestartet werden. Eine Stapelauswertung ist eine Zusammenfassung von Smart-Interfaces, die in der täglichen Arbeit immer wieder gemeinsam gestartet und benötigt werden. Somit kann mit einer Filterfelder-Abfrage zeitgleich ein Start mehrerer Smart-Interfaces (unabhängig welcher Auswertungstyp) erfolgen.
Gestaltungshilfe
Eine vordefinierte Stapelauswertung ist im Auswertungsstand nicht vorgesehen. Diese ist somit individuell zu erstellen.
Wird eine neue Stapelauswertung erstellt, ist zwingend eine Bezeichnung zu vergeben und eine Feldauswahl einzustellen (zur Verfügung stehen alle Smart-Interface-Filterfelder). In der Feldauswahl wird wie beim Smart-Interface bestimmt, welche Filterfelder beim Start der Stapelauswertung erscheinen sollen.
Dabei ist besonders zu beachten, dass eine Filterfeld-Auswahl nur für jene Smart-Interfaces der Stapelauswertung gilt, welche auch dasselbe Filterfeld im ursprünglichen Smart-Interface zugeordnet haben.
Im Anschluss die gewünschten Smart-Interfaces mit der Funktion "Auswertungen" zuordnen.
Die Auswertungen werden in der Reihenfolge, wie sie im Stapel definiert sind, gestartet (siehe Spalte "Reihenfolge"). Zur Ansicht geöffnet wird die zuletzt gestartete Auswertung, zum Umschalten auf die anderen Auswertungen wird am besten die Schnellstartleiste genutzt.
Der
Bildschirmausdruck wird über die Funktion "Ausdruck"

gestartet. Hier erhält der Anwender die Möglichkeit, eine Auswahl zwischen der Vorschau (= Bildschirmausdruck) oder dem Drucken (= Papierdruck) zu treffen.
Bei Auswahl von "Vorschau"

erscheint die Auswertung als Bildschirmausdruck. An dieser Stelle kann die Auswertung wie jeder BMD Report als Ausdruck, E-Mail-Anhang etc. weiterverwendet werden.
Der
Ausdruck am Drucker wird ebenfalls über die Funktion "Ausdruck"

gestartet. Hier erhält der Anwender die Möglichkeit, eine Auswahl zwischen der Vorschau (= Bildschirmausdruck) oder dem Drucken (= Papierausdruck).
Bei Auswahl von "Drucken"

wird der Druck am Drucker angestoßen.
Das
Showprogramm zu einer Auswertung erhält man über die Funktion
Showprogramm 
. Es bietet eine grafische Darstellung der Auswertungsdaten in Diagrammform, wobei am Bildschirm die Filterung bis in die Details hinein möglich ist.
Hinweis
| Eine Anleitung für das Arbeiten mit der Showprogramm-Ansicht einer Auswertung finden Sie in unserem Hilfesystem in der Fensterhilfe Showprogramm.
|
Das
Organigramm zu einer Auswertung erhalten Sie über die Funktion
Organigramm 
. Es bietet eine grafische Darstellung der Auswertungsdaten in Organigrammform, wobei am Bildschirm eine Einschränkung auf gewisse Details möglich ist.
Hinweis
| Eine Anleitung für das Arbeiten mit der Organigramm-Ansicht einer Auswertung sowie den Funktionen finden Sie in unserem Hilfesystem in der Fensterhilfe Organigramm.
|
Das
Exportieren von Auswertungsdaten ist über die Funktion "Export"

möglich. Der Anwender kann wählen, ob die Daten in eine Textdatei, in eine Exceldatei, in eine HTML-Datei, in eine XML-Datei oder in eine Showprogramm-Datei übergeben werden sollen.
In der Zieldatei können die Daten weiter bearbeitet, sortiert etc. werden.
Es besteht die Möglichkeit, Auswertungen in einen
Bericht zu integrieren. Der Aufruf ist im Bereich Tabelle
→ Vorgefertigte Tabelle
→ Warenwirtschaft
→ Auswertungen zu finden.
Eine Anleitung für das Einfügen von Tabellen in Berichten finden Sie in unserem Hilfesystem im Thema
Berichte.
Je
Auswertungstyp gibt es einen eigenen gleichlautenden Menüpunkt, von wo aus die Auswertungen ebenfalls gestartet werden können. Allerdings wird vor der eigentlichen Auswertung ein Smart-Interface gestartet, welches eine beliebige Anzahl von Filterfeldern beinhaltet.
Das Smart-Interface wird sozusagen vor eine bestehende Auswertung gelegt. Damit kann man die Auswertung einerseits für den Anwender mit bestimmten, selbst wählbaren Filterfeldern praktikabel aufrufen lassen und andererseits die Auswertung selbst vor unbefugtem Zugriff schützen (siehe Kapitel "Schutz einer Auswertung"). Die Anwender des Smart-Interface sehen damit nur das Abfragefenster, aber nicht die Einstellungen zur Auswertung selbst, welche ja im Auswertungsdesigner getroffen worden sind.
Das Fenster
Auswertungen (Paket WWS
→ Auswertungen) bietet eine Übersicht über alle Smart-Interfaces - wie im Auswertungsdesigner - nach Auswertungstypen getrennt. Hier können die Smart-Interfaces nicht nur aufgerufen, sondern auch erstellt und verwaltet werden.
Für BMD Standardauswertungen existieren bereits Standard-Smart-Interfaces, welche sofort verwendet werden können. Je Auswertung können beliebig viele Smart-Interfaces angelegt werden.
Wird ein neues Smart-Interface erstellt, ist zwingend eine Bezeichnung zu vergeben, die Auswahl der Auswertung welche zugrunde liegt zu treffen und eine Feldauswahl (siehe Datenfilterung) einzustellen. In der Feldauswahl wird bestimmt, welche Abfragefenster beim Start des Smart-Interface erscheinen sollen.
Hinweis
| Eine Beschreibung zu den nützlichen Feldern eines Smart-Interface finden Sie in unserem Hilfesystem in der Fensterhilfe "Feldbeschreibung Smart-Interface" im Bereich "Smart-Interface".
|
Der wesentliche Zweck des Smart-Interface ist, dem Anwender eine Möglichkeit zur Datenfilterung zu geben, um genau zur benötigten Auswertung zu gelangen. Die Feldauswahl der Filterfelder erreicht man über

(F8-Funktion) bei "Feldauswahl" im Bearbeitungsmodus eines Smart-Interface.
In der linken Leiste befinden sich alle verfügbaren Filterfelder, welche nach rechts übernommen werden können. Die rechte Auswahl an Filterfeldern wird anschließend in das Smart-Interface übernommen.
Bei den Filterfeldern ist zu beachten, dass es manche mit Mehrfachauswahl von Filterwerten gibt - erkennbar am Symbol.
Die Filterfelder können beliebig miteinander kombiniert werden und ergänzen sich.
Neben der generellen Einstellung der Feldauswahl im Smart-Interface gibt es auch die Möglichkeit, eine eigene Feldauswahl für das Showprogramm zu hinterlegen. So können Sie die Feldauswahl der Einstiegsfelder im Smart-Interface und der Einstiegsfelder im Showprogramm separat voneinander einstellen, ohne ein zweites Smart-Interface anlegen zu müssen.
Es ist sinnvoll, auf die Reihenfolge der Filterfelder zu achten und diese sinnvoll zu kombinieren.
Speziell bei den Perioden- bzw. Leistungsdatumfeldern ist zu beachten, dass diese im Smart-Interface in der richtigen Reihenfolge angeordnet sind - zuerst das betreffende Von-Feld und anschließend das dazugehörige Bis-Feld. Ansonsten kommt es durch das Auto-Vervollständigen zu unerwünschten Filtereingaben.
Zu beachten ist, dass die Auswahl von Filterwerten im Smart-Interface gegenüber der Auswahl von Filterwerten direkt in der Auswertung (im Auswertungsdesigner) vorrangig ist. Das gilt jedoch nur für Filterfelder, welche dem Anwender auch tatsächlich im Smart-Interface zur Verfügung gestellt wurden.
- Motiv 1 - Auswertungsschutz: Die Auswertung selbst soll nicht verändert werden können.
- Motiv 2 - Datenschutz: Gewisse Auswertungsdaten dürfen nur von bestimmten Mitarbeitern aufgerufen werden.
Für beide Motive gibt es Einstellungen und Optionen; alle Optionen können auch miteinander kombiniert eingesetzt werden.
Programmberechtigungen → Sperre Auswertungsdesigner
Durch die Verwendung von Smart-Interfaces ist es möglich, dass die Anwender nur Auswertungen starten (und daher nicht abändern) können. Das Programm "Auswertungsdesigner" wird dabei generell für diese Anwender über die normalen Berechtigungen gesperrt. Nur Administratoren sollten Zugriff auf den Auswertungsdesigner erhalten, um die Auswertung selbst mitsamt deren Einstellungen vor Zugriff zu schützen.
Ein Nebeneffekt des Smart-Interface ist, dass die Anwender durch die voreingestellten Filterfelder mit möglichst wenig Aufwand den Start einfach und schnell durchführen können.
Programmberechtigungen → Sperre Smart-Interfaces
Auch die Smart-Interfaces können vor Abänderung durch normale Anwender geschützt werden. Zu diesem Zweck gibt es je Auswertungstyp wiederum die Möglichkeit, die Bearbeitung über normale Berechtigungen zu sperren und nur das Ansehen (und damit den Start) des Smart-Interface zuzulassen.
Achtung: Über das Fenster
Auswertungen wäre ein Zugriff trotzdem noch möglich. Daher ist es sinnvoll, in diesem Fall auch die Auswertungen sperren zu lassen.
Hinweis | Weitere Einschränkungen der Berechtigungen sind unter dem Punkt "Auswertungen - weitere Funktionen" im Berechtigungsbaum möglich.
|
Datenbesitzergruppen
Sowohl bei den Auswertungen als auch bei den Smart-Interfaces ist es möglich, auf die Datensätze Datenbesitzergruppen (Ansehen und Bearbeiten) zu hinterlegen. Damit können einzelne Auswertungen für bestimmte Personenkreise gesperrt werden.
Jene Personen, die mittels Datenbesitzergruppen vom Ansehen der Auswertung ausgeschlossen sind, sind in weiterer Folge auch nicht dazu berechtigt, eine Auswertung zu starten.
Feld "Eingabe Smart-Interface"
Mithilfe des Feldes "Eingabe Smart-Interface" ist es möglich, die Auswahl "Alle" für ein Smart-Interface-Filterfeld zu unterbinden. Das Feld ist am Auswertungstyp im Auswertungsdesigner zu finden. Soll die Auswahl "Alle" unterbunden werden, ist die Ausprägung "Eingabe 'Alle' ist nicht zulässig" zu verwenden.
Auswertungen können auch für ausländische Kunden in einer Fremdsprache übersetzt ausgedruckt werden. Nähere Informationen finden Sie im Spezialthema
Fremdsprachige Auswertungen.
Allgemein