Inhalt
Um zum Beispiel einen neuen Kunden anzulegen, klicken Sie in der Eingabemaske "Kunde" auf das Symbol "Neu"

. Geben Sie beim Feld "Firma" die Nummer Ihrer Firma (meist 1) ein. Die
Personennummer kann manuell vergeben oder mit dem "Nächste Nummer"-Symbol

laut den Nummernkreis-Einstellungen automatisch übernommen werden. Drücken Sie
Tab oder
Enter, um die Eingaben im oberen Bereich abzuschließen. Sie befinden sich nun im Bearbeitungsmodus des neuen Kunden.
In den
Bearbeitungsmodus von Daten kommen Sie über das Bleistift

Symbol. Der Bearbeitungsmodus wird rechts oben durch die verwendbaren Schaltflächen
Speichern und
Verwerfen sowie den Hinweis
(Bearbeiten) angezeigt.
Das fokussierte Feld wird standardmäßig hellgelb hinterlegt. Diese Farbeinstellung kann unter TOOLS
→ Tools
→ Einstellungen
→ Menüeinstellungen
→ Darstellung benutzerbezogen angepasst werden.
Sie können jeweils die Felder bearbeiten, die angezeigt werden. Welche Felder in welcher
Reihenfolge angezeigt werden, können Sie in der
Feldauswahl 
(rechte Maustaste oder 3-Punkte-Menü) bestimmen.
Falls in einem Feld ein Sonderzeichen eingegeben werden muss, das nicht einfach auf der Tastatur gefunden werden kann, steht über die rechte Maustaste → Sonderzeichen (Umschalt + F6) direkt eine Tabelle der verfügbaren Sonderzeichen zur Verfügung.
Wird ein bestimmtes Zeichen häufiger verwendet, kann die Eingabe in NTCS auch direkt erfolgen. Halten Sie dazu die Alt-Taste gedrückt und geben Sie den bei der Vorschau angegebenen Zahlencode ein. Die Zahleneingabe muss dabei über den externen Ziffernblock der Tastatur erfolgen!
Achtung! | Information aus dem Paket LOHN: Es gibt Hinweise darauf, dass die ÖGK derzeit nicht mit internationalen Schreibweisen umgehen kann. Für ELDA-Übermittlungen sind nur diese Sonderzeichen erlaubt:
|
Mit der Tab- oder Eingabe-Taste gelangen Sie in das nächste Feld.
Bei einigen Feldern stehen
Spezialfunktionen zur Verfügung:
Mit der
F4-Taste oder dem Suche-Symbol

können Sie nach verfügbaren Werten für ein Feld suchen, z. B. bei der Anrede oder beim Titel.
Mit der
F8-Taste oder dem Multifunktions-Symbol

kann ein
Bearbeitungsfenster oder eine
spezielle Funktion gestartet werden.
Ansichtsmodus: Über die rechts unten dargestellten
Navigationsschaltflächen Pfeil nach oben 
und
Pfeil nach unten 
können Sie zum vorigen Datensatz bzw. zum nächsten Datensatz gelangen. Wird der schwarze Pfeil grau, sind Sie entweder beim ersten oder letzten Datensatz angelangt. Eine mögliche Filterung einer Liste wird dabei berücksichtigt.
In das Auswahl-Feld

gelangen Sie, indem Sie wiederholt die
Tab- oder
Eingabe-Taste oder einmal die
ESC-Taste drücken.
Sie können dort auch ein nicht angezeigtes Feld hinzufügen, in dem Sie die
Feldnummer oder den
Feldnamen eingeben und die Eingabe-Taste drücken bzw. mittels der Funktion F4

ein Feld aus der Liste auswählen.
Werden in einer Eingabemaske mehrere Felder bzw. in einer Listenansicht mehrere Spalten temporär, ohne zu speichern, hinzugefügt, kann sich die NTCS die Kombination dieser Felder- bzw. Spaltengruppen merken. Wird zu einem späteren Zeitpunkt wieder eines dieser Felder (oder eine dieser Spalten) temporär hinzugefügt, wird die gespeicherte Kombination aller Felder (bzw. Spalten) automatisch hinzugefügt. Das Hinzufügen eines Feldes (bzw. einer Spalte) ergänzt dadurch auch alle anderen Felder bzw. Spalten der jeweiligen Gruppe.
Diese Funktion ist benutzer- und fensterbezogen und serienmäßig deaktiviert. Für die Verwendung muss unter TOOLS → Tools → Einstellungen → TOOLS Parameter → BMD System → Feldeinstellungen der Parameter "Feld-/Spaltengruppen" auf ">0" geändert werden.
Verwendet der Benutzer für verschiedene Tätigkeiten immer wieder unterschiedliche Kombinationen, können diese auch über den Kontextmenüpunkt "Felder hinzufügen“" ausgewählt werden.
Möchten Sie die Bearbeitung abschließen, können Sie die Tastenkombination STRG + S bzw. die Schaltfläche Speichern verwenden.
Sie können auch im Feld "Auswahl"

die
Eingabe-Taste drücken, um die getätigten Eingaben abzuspeichern.
Drücken Sie im Feld "Auswahl" die ESC-Taste, so erhalten Sie ein Auswahlfenster, in dem Sie die getätigten Eingaben speichern oder verwerfen können.
Hinweis
| Der Gesamtsystem-Parameter Eingabefenster immer nach Bearbeiten schließen regelt, wie sich das System beim Speichern oder Verwerfen eines Datensatzes verhält:
| Steuert das Verhalten des Eingabefensters beim Speichern oder Verwerfen eines Datensatzes. Je nach Fenster kann es jedoch erforderlich sein, diesen Parameter zu übersteuern, sodass dessen Einstellung nicht überall zum Tragen kommt.
0 - Nein: Beim Speichern oder Verwerfen wird das Eingabefenster nicht geschlossen, wenn man einen Datensatz zuerst mit Ansehen (F2) öffnet und daraus eine Neuanlage (F5) oder Bearbeitung (F6) startet.
1 - Ja: Beim Speichern oder Verwerfen wird das Eingabefenster immer geschlossen.
|
|
Im folgenden Kapitel geht es um Funktionen zu Arbeitserleichterungen bei der Erfassung von Daten.
Für die schnelle Erfassung von Datensätzen können Sie in den
verschiedenen Programmbereichen (Post, Termine, Aufgaben, Fristen, Telefonprotokoll, BMD DMS)
diverse Betreff-Texte speichern. Diese Standardisierung ermöglicht Ihnen ein einfaches Suchen und Finden.
Besonders im
DMS oder auch in der
Post kommt dies häufig zum Einsatz:
Mit dem Disketten-Symbol

können Sie neue Betreff-Texte speichern, mit der Funktion F4

können Sie die Liste der bisher gespeicherten Texte aufrufen.
In einigen Fenstern wie dem
Terminkalender oder der
Tageserfassung, aber auch bei der Eingabe in einem
Datumsfeld, können Sie in folgendem Bildschirmbereich das gewünschte Datum auswählen.
In Datumsfeldern lässt sich mit F4 der BMD Kalender als Unterstützung für die Suche öffnen.
Ein Klick auf den Monat oder das Jahr ermöglicht einen raschen Wechsel in einen anderen Zeitbereich. Mit den Pfeilen oben wechseln Sie jeweils in den Vormonat oder in den Folgemonat. Ein Klick auf das rote Rechteck unten neben Heute führt Sie immer zum aktuellen Datum. Ein Leerzeichen in einem Datumsfeld bringt übrigens auch immer das aktuelle Tagesdatum!
Werktage werden schwarz, Samstage, Sonn- und Feiertage rot dargestellt. Der aktuelle Tag ist mit einem roten Rahmen gekennzeichnet. Der selektierte Tag wird blau umrahmt dargestellt. Links sehen Sie vertikal die jeweilige Kalenderwoche, oben horizontal den Wochentag.
Je größer Sie das Fenster "BMD Kalender" horizontal oder vertikal ziehen, desto mehr Monate sind ersichtlich.
Hinweis | Bei Bedarf kann im unteren Fensterbereich des BMD Kalenders eine Zeitstatistik eingeblendet werden. Diese zeigt an, den wievielten Tag im Jahr, wie viele verbleibende Tage im Monat und wie viele verbleibende Tage im Jahr die aktuelle Tagesauswahl ergibt.
Per Parameter kann diese Anzeige gesteuert werden: TOOLS → Tools → Einstellungen → TOOLS Parameter → BMD System → Kalender-Einstellungen → Erweiterte Anzeige
| Aktiviert die Anzeige von erweiterten Kalenderinformationen zur speziellen Verwendung z. B. für Lohnverrechner. |
|
Mit dem Taschenrechner-Symbol

im Kalender können Sie einen speziellen
Datumsrechner aufrufen, in dem Tage, Wochen, Monate und Jahre addiert bzw. subtrahiert werden können.
Bei der Eingabe von Zahlen kombiniert mit Rechenoperatoren (+, -, *, /) in einem numerischen Feld wird nach der Eingabe-Taste automatisch das Endergebnis übernommen.
Alternativ kann der
BMD Taschenrechner direkt durch die Eingabe von "=" in einem numerischen Feld geöffnet werden. Der errechnete Wert wird anschließend in das Feld übernommen.
Voraussetzung: Folgender Parameter muss auf "ja" gestellt sein:
TOOLS → Tools → Einstellungen → TOOLS Parameter → BMD System → Feldeinstellungen → Öffnen des Taschenrechners mit "="
| Wird als erstes Zeichen ein = eingegeben, wird der Taschenrechner geöffnet. |
In manchen NTCS Feldern haben Sie die Möglichkeit, auf die letzten fünf erfassten Feldwerte zuzugreifen. Voraussetzung dafür ist, dass Sie in der Zwischenzeit NTCS nicht geschlossen haben. Die Liste der erfassten Werte kann mit der Tastenkombination STRG + Pfeil nach unten angezeigt werden, mit der Entertaste treffen Sie die Auswahl des Wertes.
Der letzte Wert, der in dieser Session manuell in ein Feld eingegeben worden ist, kann mit der Funktionstaste F12 wiederholt werden. Diese Funktion steht sowohl in Eingabemasken als auch in Tabellen zur Verfügung:
In der Detailansicht kann für jedes Feld mit STRG + F11 bzw. über Rechte Maustaste → Wert fixieren der aktuelle Wert als Vorschlagswert für diese Sitzung aktiviert bzw. deaktiviert werden.
Über die
Feldauswahl kann eingestellt werden, dass in einem Feld der zuletzt eingegebene Wert mit Enter übernommen wird, wenn man das Feld leer lässt.
Diese Einstellung befindet sich in der Feldauswahl unter "Vorschlag" und kann benutzerbezogen oder global gesetzt werden:
Der in den Feldeigenschaften hinterlegte Hilfetext kann direkt z. B. bei der Stammdatenbearbeitung eingeblendet werden und wird dadurch immer über dem momentan bearbeiteten Feld angezeigt. Die Funktion Kurzhinweis immer anzeigen finden Sie auf der rechten Maustaste im freien Bereich des Formulars:
Um die Kurzhinweise selbst zu ergänzen, verwenden Sie das Feld kurzer Hilfetext in den Feldeigenschaften (rechte Maustaste → Feldeigenschaften).
Damit ein Datensatz nicht nochmals neu erfasst werden muss, kann dieser kopiert und als neuer Datensatz eingefügt werden.
Bedingung für das Kopieren ist, dass der Datensatz nur im Ansehen- Modus geöffnet, also nicht in Bearbeitung ist!
Wählen Sie im 3-Punkte-Menü "Extras" → Datensatz kopieren (Umsch + Strg + C).
Nach dem Datensatz einfügen (Umsch + Strg + V) müssen noch Felder im Kopfbereich befüllt werden, und dann wird der kopierte Datensatz eingefügt. Im Anschluss müssen noch die abweichenden Felder geändert werden.
Das Kopieren und Einfügen eines Datensatzes kann auch in den
Terminen,
Aufgaben,
Fristen usw. durchgeführt werden (immer im
Ansichtsmodus des Datensatzes!).
Hinweis | Beim Kopieren von Daten werden nur die Daten der aktuellen Tabelle kopiert. Wenn Sie also z. B. einen Kunden kopieren, werden zusätzliche Daten wie Weitere Adressen, Weitere Telefonnummern etc. NICHT mitkopiert.
|
Hinweis | Alternativ können Sie auch im Bearbeitungsmodus auf der rechten Maustaste → Alle Felder kopieren wählen, dann einen neuen Datensatz anlegen und ebenfalls auf der rechten Maustaste → Alle Felder einfügen.
Dabei werden alle Inhalte der aktuell eingeblendeten Felder kopiert. Dies ist praktisch, wenn z. B. ein Kunde als Lieferant angelegt werden soll oder umgekehrt und schnell die Werte benötigt werden. |
Wenn in BMD NTCS Daten angelegt oder bearbeitet werden, werden folgende Felder automatisch befüllt:
| Ersteller | User-ID des Erstellers |
| Erst-Datum | Datum der Erstellung des Datensatzes |
| Letzer User | User-ID des letzten Bearbeiters |
| Änd-Dat | Datum der letzten Bearbeitung des Datensatzes |
Weitere Änderungen von Daten können in den jeweiligen Protokollierungen der Datentabellen mitgeloggt werden.
Diese Funktion finden Sie im 3-Punkte-Menü vieler Fenster, die Datensätze enthalten, unter Extras.
Durch Ausführen dieses Menüpunktes werden alle gerade angezeigten Datensätze in einem Fenster gelöscht. Das bedeutet, es wird auch auf Filterungen Rücksicht genommen.
Da diese Funktion bei unsachgemäßer Verwendung erheblichen Schaden anrichten kann, gibt es dafür eine eigene Berechtigung.
- TOOLS → Weitere TOOLS Funktionen → Fenster → Alle Datensätze löschen
Diese bezieht sich auf die Funktion im Allgemeinen, daher ist durch diese Berechtigung die Funktion in allen Fenstern, in welchen sie ausführbar ist, berechtigt.
Soll die Funktion allgemein nicht aktiv sein, und
nur für bestimmte Fenster erlaubt, so kann diese über die allgemeine Berechtigung deaktiviert und in den einzelnen Fenstern über die
Erweiterte Fenster-Rechte aktiviert werden.